Custom Query (325 matches)

Filters
 
Or
 
  
 
Columns

Show under each result:


Results (31 - 33 of 325)

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21
Ticket Resolution Summary Owner Reporter
#316 no change needed ANPM cannot fetch odin-win32k Peter Moylan pmoylan
Description

Error message while trying to install odin-win32k using ANPM:

[u'ERROR with transaction check vs depsolve:', 'libodin = 0.7.1-3 is needed by odin-win32k-0.7.1-3.i386', u'Please report this error at http://trac.netlabs.org/rpm/']

#315 no change needed rpm-yum-bootstrap not working on OS/2 4.52 rlange
Description

I have an ancient Pentium2 running OS/2 Warp CP2 4.52. It's running quite nicely and I'd like to get a few of the rpm packages (mostly cups) on it. I got cups working the manual (non-rpm) way but it was pretty kludgy, so I did a clean install and would like to do it the right way, if possible. Is this machine still a supported configuration? If not, then it should be clearly stated it's not. If so, then there's a technical or documentation problem.

Clean Warp 4.52 install. Added unzip and warpin 1.0.22. Tried:

warpin rpm-yum-bootstrap-1_5-i386.wpi

but WarpIN warned me that libc was required. I found and downloaded:

http://rpm.netlabs.org/release/00/zip/libc-0_6_6-37_oc00.zip

unpacked it to a temporary directory, and moved usr to \. I added the following to c:\config.sys and rebooted.

SET UNIXROOT=C: Appended C:\usr\lib to LIBPATH Appended C:\usr\bin to PATH SET TMP=C:\tmp SET TMPDIR=C:\tmp

Then I redid:

warpin rpm-yum-bootstrap-1_5-i386.wpi

and it succeeded in installing the bootstrap environment. I launched the yum bootstrap console, and it successfully downloaded the repolist packages and told me to run:

yum install yum

I did that and it spat out a tonne of errors like:

Error: Package: urpo-20150513-11.oc00.i386 (netlabs-rel)

Requires: libc >= 0.6.6

Error: Package: rpm-4.8.1-25.oc00.i386 (netlabs-rel)

Requires: libc066.dll

Error: Package: 2:mmap-0.5-1.oc00.i386 (netlabs-rel)

Requires: libc065.dll

I've cut out a tonne of similar errors, all involving libc. It seems every package that requires libc (pretty much all of them) failed.

I checked the repos manually, and there doesn't seem to be a libc rpm package for i386. Is what I did (use the zip version of libc) correct? (By the way, there are no other libcXXX.dll libraries on the system aside from the one installed by the yum bootstrap package and the one I installed manually in \usr from your zip.)

I also tried moving the LIBPATH for C:\usr\lib to the front of LIBPATH, rebooting, and trying again, but that made no difference.

I see that the bootstrap console uses:

BEGINLIBPATH=C:\tmp\yumbt\usr\lib;C:\usr\lib

I've checked both of those locations and the libcXXX.dll's are there in both locations. I'm not why yum/rpm isn't finding them...

#314 fixed Duplicate WarpIn database error David McKenna
Description

Just tried to update klusrmgr using ANPM and it ended with an error saying there was multiple WarpIn? databases. I only have one DATBAS_C.INI file on my computer, so opened up Warpin.exe and saw that there was an entry for every version of klusrmgr ever installed on this machine. Deleted all the entries and closed Warpin, then reinstalled klusrmgr using ANPM, this time it completed with no problem and created its objects. (Also noticed extra entries for bwwping, so trimmed those out too). Is it necessary to have a separate entry in Warpin for every version of klusrmgr installed?

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21
Note: See TracQuery for help on using queries.