Opened 8 years ago

Closed 8 years ago

#27 closed defect (fixed)

warpin-conflicts should use wic -p

Reported by: dmik Owned by: ydario
Priority: major Milestone:
Component: rpm Version:
Severity: Keywords:
Cc:

Description

WIC, starting from version 1.0.16, supports the -p parameter that returns the version number for the given package. See the WarpIn? programmer's documentation for more info.

It is much better to use this parameter than parsing the WarpIn? INI database files manually from Rexx when detecting conflicts. The former is known to suffer from strange bugs (e.g. inability to access the INI file with SysIni?).

Change History (3)

comment:1 Changed 8 years ago by dmik

One example of the problem is described in #31.

comment:2 Changed 8 years ago by dmik

Done in r297.

Yuri, please make a new RPM for it.

Last edited 8 years ago by dmik (previous) (diff)

comment:3 Changed 8 years ago by diver

  • Resolution set to fixed
  • Status changed from new to closed

new RPM is up, so i close it

Note: See TracTickets for help on using tickets.