Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#116 closed defect (invalid)

yum update on a new yum install fails

Reported by: guzzi Owned by:
Priority: major Milestone:
Component: rpm Version:
Severity: Keywords:
Cc:

Description

When running yum update on a fresh install, os2base package will fail to install, looks like because of missing libc. When I first run yum install libc, and then yum update, it all works.

Also, yum install yum on a fresh install will fail, did not check why saw mesaage about wrong python version..

Change History (6)

comment:1 Changed 5 years ago by ggamba

I can confirm this. Trying to cure http://trac.netlabs.org/rpm/ticket/111, I renamed /etc, /usr and /var, then downloaded the bootstrap WPI and run it.
WPI installed fine, the WPS objects were created, but running "yum install yum" failed in python.

comment:2 Changed 5 years ago by diver

what was the exact failure? Please be a bit more verbose, as this could save us a lot time in searching problems.

comment:3 Changed 5 years ago by ggamba

Sorry, I did not note down the error at the time, and now I'm not able to reproduce it again. I tried on two partitions and this time in both cases "yum install yum" worked. But then again I got problems. I'm listing here exactly what I did this time on the test partition:

1) renamed /etc, /usr and /var, then run the bootstrap WPI;
2) "yum install yum" went fine, 58 packages installed;
3) reboot and created "platform" file in /etc/rpm. Content of the file is "pentium4-OS/2-OS/2";
4) run "yum update" and I got:

...
Aggiornamento:  [Update]
 netlabs-rel        i386        0.0.0-5.oc00           netlabs-rel        2.1 k

Riepilogo della transazione   [Transaction resume]
================================================================================

Upgrade       1 Package

Dimensione totale del download: 2.1 k
Procedere [s/N]: s
Download dei pacchetti:
netlabs-rel-0.0.0-5.oc00.i386.rpm                           | 2.1 kB  00:00
Running Transaction Check
Test di transazione in corso


Errore nel controllo transazione:  [Error in the transaction check]
  package netlabs-rel-0.0.0-5.oc00.i386 is intended for a i386 architecture

comment:4 Changed 5 years ago by ggamba

For me, this problem went away reordering LIBPATH. Please see http://trac.netlabs.org/rpm/ticket/115#comment:8

comment:5 Changed 5 years ago by diver

  • Resolution set to invalid
  • Status changed from new to closed

ok thx. closing it

comment:6 Changed 5 years ago by guzzi

The order of libpath was already correct

Note: See TracTickets for help on using tickets.