Opened 7 years ago

Closed 6 years ago

#57 closed defect (invalid)

yum update failure - perl

Reported by: abwillis Owned by: ydario
Priority: major Milestone:
Component: rpm Version:
Severity: Keywords:
Cc:

Description

Attempting to update perl and I receive:
[d:\]yum update
Setting up Update Process
Error: Package tuple ('perl', 'i386', '0', '5.16.1', '0.7.oc00') could not be found in rpmdb

Tried:
yum clean packages
yum clean metadata
yum clean all
then a:
yum check-update
which shows (same results from Netlabs servers):
cpio.i386 2.11-4.oc00 netlabs-rel-2rosenthals
gawk.i386 4.0.0-2.oc00 netlabs-rel-2rosenthals
libc.i386 0.6.5-16.oc00 netlabs-rel-2rosenthals
libc-devel.i386 0.6.5-16.oc00 netlabs-rel-2rosenthals
perl.i386 5.16.1-0.8.oc00 netlabs-exp-2rosenthals
perl-libs.i386 5.16.1-0.8.oc00 netlabs-exp-2rosenthals

Change History (3)

comment:1 Changed 7 years ago by abwillis

also tried:
[d:\]yum downgrade perl
Setting up Downgrade Process
No Match for available package: perl-5.10.0-3.oc00.i386
Nothing to do

comment:2 Changed 7 years ago by abwillis

I have no idea on how to clean up the issue past what I have tried.

comment:3 Changed 6 years ago by abwillis

  • Resolution set to invalid
  • Status changed from new to closed

I eventually was able to clean this up, I'm not sure now but I think I had ended up nuking the rpm database.

Note: See TracTickets for help on using tickets.