Opened 4 years ago

Closed 3 months ago

Last modified 3 months ago

#96 closed defect (wontfix)

Running Python while VRXEDIT.EXE is running causes hang

Reported by: ataylor Owned by:
Priority: major Milestone:
Component: python Version:
Severity: highest Keywords:
Cc: lgrosenthal@…, herwigb

Description

Any time the Python interpreter is run while the VX-REXX Designer (VRXEDIT) is open, the Workplace Shell locks up and becomes completely unresponsive.

The only way out is to either reboot, or to use a utility like CAD-Handler in conjunction with XF86SUP.SYS to issue a SIGKILL to force-kill either python.exe or vrxedit.exe; this latter option does not always work.

This problem is 100% reproducible for me on multiple systems.

On rare occasions I have seen what I suspect is a similar hang with other programs (not simply VRXEDIT) but these are not consistently reproducible. In any case I suggest that this be taken as a general Python problem and not a VX-REXX specific one.

(In case it is relevant, I would note that VX-REXX makes heavy use of SOM. I have also occasionally seen a similar hang with Python while running Lucide, which is also SOM-based; might this be a possible clue?)

Attachments (1)

yum_list.py (2.2 KB) - added by ataylor 4 years ago.
Python script using YUM API

Download all attachments as: .zip

Change History (9)

comment:1 Changed 4 years ago by ataylor

TO REPRODUCE:

  1. Download http://hobbes.nmsu.edu/download/pub/os2/dev/rexx/vxrcsdemexpanded.zip
  2. Unzip this file into some directory.
  3. Run VRXEDIT.EXE from the subdirectory 'vxrexx'. The VX-REXX Designer will start.
  4. Run the script 'yum_list.py' (attached), e.g. "python yum_list.py updates", while the Designer is open.
  5. Be prepared to Ctrl-Alt-Del. :/

Changed 4 years ago by ataylor

Python script using YUM API

comment:2 Changed 4 years ago by Lewisr

  • Cc lgrosenthal@… added

comment:3 Changed 2 years ago by herwigb

  • Cc herwigb added
  • Severity set to highest

comment:4 Changed 2 years ago by diver

What VAL setting do you have in config.sys? As we discovered lately that all settings higher than 2048 cause several issues. We believe it's a kernel or libc defect.

comment:5 Changed 2 years ago by ataylor

On all my systems VAL is either 1536 or 1024. (1024 on my main development system.)

comment:6 Changed 2 years ago by diver

try to use 1536 or 2048 and see it it's better. Most of our dev use 2048 and we don't see this issues. When we set it higher we see it. So it's likely it's there also when the setting is to small.

comment:7 Changed 3 months ago by diver

  • Resolution set to wontfix
  • Status changed from new to closed

no feedback from the reporter, so closing it.

As a sidenote: we think this is a out of memory situation with VXREXX using a lot lower shared mem.

comment:8 Changed 3 months ago by ataylor

Sorry for the lack of updates. I did change to 1536 without any discernable change in this behaviour.

I do consider this a very serious problem because it makes it completely impossible to interactively debug ANPM, for example. However I understand that it's difficult to diagnose. Is it possible to switch this ticket to a long-term monitoring status rather than closing it outright?

Note: See TracTickets for help on using tickets.