Opened 9 years ago

Closed 8 years ago

#15 closed defect (fixed)

Bootstrap 1.3 tangle.

Reported by: David McKenna Owned by: ydario
Priority: major Milestone:
Component: rpm Version:
Severity: Keywords:
Cc:

Description

Deleted my YUM/RPM installation and reinstalled using the recent bootstrap 1.3 package. Installation went without error and I could perform YUM commands from the YUM-console.

Trying to use YUM commands from the eCS command line directly, I would get errors that in effect indicated the RPM database could not be opened.

Comparing the contents of /TMP/YUMBT/BIN and /USR/BIN showed there were files starting with db_* and tcl* in the /TMP/YUMBT/BIN directory not present in the /USR/BIN directory. Listing available packages (from the YUM-console) showed a 'DB4' package available. I installed from the YUM-console (it also installed a 'TCL' dependency) and now I can use YUM and RPM from the command line.

Previous issues I had with earlier installs seem to be gone now.

Change History (3)

comment:1 Changed 9 years ago by David McKenna

You updated the specs for the packages I had trouble with, so I deleted everything and ran Bootstrap 1.3 again.

This time it worked perfectly! This may be close to prime time...

The only 'trouble' I have had is when I went to install ClamAV, I got messages saying something like: 'xxxxxx was supposed to be installed but was not!'. It wasn't true, everything seems to be installed (including objects). Not sure if this is a problem with the ClamAV package or a more general YUM/RPM issue....

comment:2 Changed 9 years ago by ydario

It seems you had the migration issue from SQLite to Berkeley DB, see wiki.

'was supposed to be installed but was not' is a spurious message, should not be shown, I need to check why it is printed.

comment:3 Changed 8 years ago by ydario

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.