Opened 8 years ago

Closed 8 years ago

#37 closed defect (fixed)

YUM UPDATE problem

Reported by: David McKenna Owned by: ydario
Priority: major Milestone:
Component: rpm Version:
Severity: Keywords:
Cc:

Description

I ran YUM UPDATE today and got the following:

Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package ash.i386 0:0.0.0-9.oc00 set to be updated
---> Package coreutils.pentium4 0:8.6-7.oc00 set to be updated
--> Processing Dependency: gmp for package: coreutils-8.6-7.oc00.pentium4
---> Package tar.pentium4 2:1.23-7.oc00 set to be updated
--> Running transaction check
---> Package gmp.pentium4 0:5.0.2-2.oc00 set to be updated
--> Processing Dependency: /@unixroot/bin/sh for package: os2-base-0.0.0-4.oc00.i386
--> Processing Dependency: /@unixroot/bin/sh for package: qt4-assistant-4.7.3-1.i386
--> Processing Dependency: /@unixroot/bin/sh for package: openssl-1.0.0a-4.oc00.pentium4
--> Processing Dependency: /@unixroot/bin/sh for package: python-2.6.5-5.oc00.pentium4
--> Processing Dependency: /@unixroot/bin/sh for package: clamav-update-0.97.2-5.oc00.pentium4
--> Processing Dependency: /@unixroot/bin/sh for package: clamav-0.97.2-5.oc00.pentium4
--> Processing Dependency: /@unixroot/bin/sh for package: bash-3.2.0-6.oc00.i386
--> Processing Dependency: /@unixroot/bin/sh for package: rpm-4.8.1-13.oc00.i386
--> Processing Dependency: /@unixroot/bin/sh for package: clamav-server-0.97.2-5.oc00.pentium4
--> Processing Dependency: /@unixroot/bin/sh for package: qt4-doc-4.7.3-1.noarch
--> Processing Dependency: /@unixroot/bin/sh for package: qt4-demos-4.7.3-1.i386
--> Processing Dependency: /@unixroot/bin/sh for package: libqt4-4.7.3-1.i386
--> Processing Dependency: /@unixroot/bin/sh for package: clamav-lib-0.97.2-5.oc00.pentium4
--> Finished Dependency Resolution

You could try using --skip-broken to work around the problem

rpm-4.8.1-13.oc00.i386 has missing requires of curl

I was able to update coreutils and tar individually, but when I tried to update ash I got similar messages.

Change History (3)

comment:1 Changed 8 years ago by ydario

My yesterday update broke some things in exp repo...

I have updated ash package to provide a virtual /@unixroot/bin/sh package (it is no longer required, but older packages wants this).

Please try the following sequence for test purpouses:

Run 'yum update' again and report result: it is supposed to fail (at least did so here).

Then run 'yum clean metadata' and retry update (failed here too).

Then run 'yum clean all' and retry update: here this worked.

comment:2 Changed 8 years ago by David McKenna

I ran YUM UPDATE, and ash updated with no problem! YUM CLEAN METADATA worked too. Then ran YUM UPDATE again and it said nothing needed to be updated. In /bin there is only one file: bash. So the problem is solved?

Last edited 8 years ago by David McKenna (previous) (diff)

comment:3 Changed 8 years ago by ydario

  • Resolution set to fixed
  • Status changed from new to closed

Even better if it worked on first update!

I need to remove also that bash file...

Note: See TracTickets for help on using tickets.