Opened 5 years ago

Closed 5 years ago

#102 closed defect (duplicate)

yum update failed on updating RPM

Reported by: guzzi Owned by:
Priority: major Milestone:
Component: rpm Version:
Severity: Keywords:
Cc:

Description

From yum.log:

Jan 03 23:19:47 urpo-20150101-9.oc00.pentium4: 100
Jan 03 23:19:47 rpm-libs-4.8.1-19.oc00.pentium4: 100
Jan 03 23:19:48 Updated: rpm-4.8.1-19.oc00.pentium4
Jan 03 23:19:48 rpm-python-4.8.1-19.oc00.pentium4: 100
Jan 03 23:19:48 rpm: ts_done name in te is rpm-python should be rpm

After that yum would not display any output on the screen when it was run and didn't seem to work anymore.
I installed the bootstrap package and tried installing the packages with that:

Running Transaction

Updating : rpm-python-4.8.1-19.oc00.pentium4 1/2

Error unpacking rpm package rpm-python-4.8.1-19.oc00.pentium4
error: unpacking of archive failed on file /@unixroot/usr/lib/python2.7/site-packages/rpm/_rpm.dll: cpio: chmod
rpm-python-4.8.1-18.oc00.pentium4 was supposed to be removed but is not!

Failed:

rpm-python.pentium4 0:4.8.1-19.oc00

This is the file that was created:
F:\usr\lib\python2.7\site-packages\rpm\_rpm.dll;54a889d6

A similar error occurred for urpo-20150101-9.oc00.pentium4
This is the file that was created:
F:\usr\lib\urpo.dll;54a881c9

installing the urpo-debug-20150101-9.oc00.pentium4.rpm did work.

Is there a problem with these packages or with my yum/rpm install? (It did work well doing the last update, which was poppler)

Change History (2)

comment:1 Changed 5 years ago by guzzi

See http://www.os2world.com/forum/index.php/topic,613.0.html for both cause and solution. Urpo package seems to be broken.

comment:2 Changed 5 years ago by diver

  • Resolution set to duplicate
  • Status changed from new to closed

See ticket #100 for more info. Please always use the search function first.

Note: See TracTickets for help on using tickets.