Opened 5 years ago

Closed 5 years ago

#107 closed defect (fixed)

gettext-libs-0.18.1.1-5.oc00.i386 requires gcc1.dll

Reported by: Lewis Rosenthal Owned by:
Priority: major Milestone:
Component: rpm Version:
Severity: Keywords:
Cc:

Description

Typo? I can't find where this is happening in the specfile.

Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package gettext.i386 0:0.18.1.1-5.oc00 set to be updated
--> Processing Dependency: gcc1.dll for package: gettext-0.18.1.1-5.oc00.i386
---> Package gettext-devel.i386 0:0.18.1.1-5.oc00 set to be updated
---> Package gettext-legacy.i386 0:0.18.1.1-5.oc00 set to be updated
---> Package gettext-libs.i386 0:0.18.1.1-5.oc00 set to be updated
--> Processing Dependency: gcc1.dll for package: gettext-libs-0.18.1.1-5.oc00.i3
86
---> Package libc.i386 0:0.6.6-25.oc00 set to be updated
---> Package libc-devel.i386 0:0.6.6-25.oc00 set to be updated
--> Finished Dependency Resolution
Error: Package: gettext-libs-0.18.1.1-5.oc00.i386 (netlabs-exp)
           Requires: gcc1.dll
Error: Package: gettext-0.18.1.1-5.oc00.i386 (netlabs-exp)
           Requires: gcc1.dll
 You could try using --skip-broken to work around the problem
createrepo-0.4.11-2.noarch has missing requires of rpm-python
yum-3.2.27-6.oc00.noarch has missing requires of rpm-python

and

{0}[c:\] yum provides */gcc1.dll
Loaded plugins: changelog, fastestmirror, remove-with-leaves, rpm-warm-cache
Loading mirror speeds from cached hostfile
 * netlabs-exp: rpm.netlabs.org
 * netlabs-rel: rpm.netlabs.org
No Matches found

I'm not familiar with gcc1.dll. Did I miss the memo on this one? ;-)

Change History (4)

comment:1 Changed 5 years ago by Yuri Dario

gcc1.dll is the new name for gcc runtime, it replaces all gccXXX.dll we had in the past. libgcc1 rpm package is already on netlabs-exp, I wonder why you have this problem.

comment:2 Changed 5 years ago by Lewis Rosenthal

Resolution: invalid
Status: newclosed

Hmmm... Perhaps a mirror issue (we only update every 12 hours over here, so maybe we got the updated gettext package and the libgcc1 package went up just after).

Thanks for the quick follow-up, Yuri. Looks like we should probably sync more often. I'll close this as not a bug, sync the mirror, and if the issue persists, we'll trace it down separately.

comment:3 Changed 5 years ago by Yuri Dario

Resolution: invalid
Status: closedreopened

I'm reopening this ticket since gcc1.dll is built only for p4, we need it also for i386/i686. While this is still an exp repository, full builds are required to install new packages.

comment:4 Changed 5 years ago by Yuri Dario

Resolution: fixed
Status: reopenedclosed

upload done.

Note: See TracTickets for help on using tickets.