Opened 8 years ago

Closed 8 years ago

#34 closed defect (fixed)

yum update fails (looks like download fails)

Reported by: djburtness Owned by: David Burtness
Priority: major Milestone:
Component: yum Version:
Severity: Keywords:
Cc:

Description

Here's the commands and results:
yum update
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package ash.i386 0:0.0.0-8.oc00 set to be updated
---> Package gcc-stack-protector.i386 0:4.4.6-12.oc00 set to be updated
--> Processing Dependency: gcc446.dll for package: gcc-stack-protector-4.4.6-12.oc00.i386
---> Package libc.i386 0:0.6.4-12.oc00 set to be updated
---> Package netlabs-rel.i386 0:0.0.0-3.oc00 set to be updated
--> Running transaction check
---> Package libgcc446.i386 0:4.4.6-12.oc00 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================

Package Arch Version Repository Size

================================================================================
Updating:

ash i386 0.0.0-8.oc00 netlabs-exp 77 k
gcc-stack-protector i386 4.4.6-12.oc00 netlabs-exp 6.6 k
libc i386 0.6.4-12.oc00 netlabs-exp 858 k
netlabs-rel i386 0.0.0-3.oc00 netlabs-exp 2.0 k

Installing for dependencies:

libgcc446 i386 4.4.6-12.oc00 netlabs-exp 25 k

Transaction Summary
================================================================================
Install 1 Package(s)
Upgrade 4 Package(s)

Total download size: 969 k
y
Is this ok [y/N]: Downloading Packages:
http://rpm.netlabs.org/experimental/00/i386/i386/ash-0.0.0-8.oc00.i386.rpm: [Errno -1] Package does not match intended download. Suggestion: run yum clean metadata
Trying other mirror.
http://rpm.netlabs.org/experimental/00/i386/i386/gcc-stack-protector-4.4.6-12.oc00.i386.rpm: [Errno -1] Package does not match intended download. Suggestion: run yum clean metadata
Trying other mirror.
http://rpm.netlabs.org/experimental/00/i386/i386/libc-0.6.4-12.oc00.i386.rpm: [Errno -1] Package does not match intended download. Suggestion: run yum clean metadata
Trying other mirror.
http://rpm.netlabs.org/experimental/00/i386/i386/libgcc446-4.4.6-12.oc00.i386.rpm: [Errno -1] Package does not match intended download. Suggestion: run yum clean metadata
Trying other mirror.
http://rpm.netlabs.org/experimental/00/i386/i386/netlabs-rel-0.0.0-3.oc00.i386.rpm: [Errno -1] Package does not match intended download. Suggestion: run yum clean metadata
Trying other mirror.

Error Downloading Packages:

gcc-stack-protector-4.4.6-12.oc00.i386: failure: i386/gcc-stack-protector-4.4.6-12.oc00.i386.rpm from netlabs-exp: [Errno 256] No more mirrors to try.
ash-0.0.0-8.oc00.i386: failure: i386/ash-0.0.0-8.oc00.i386.rpm from netlabs-exp: [Errno 256] No more mirrors to try.
libc-0.6.4-12.oc00.i386: failure: i386/libc-0.6.4-12.oc00.i386.rpm from netlabs-exp: [Errno 256] No more mirrors to try.
libgcc446-4.4.6-12.oc00.i386: failure: i386/libgcc446-4.4.6-12.oc00.i386.rpm from netlabs-exp: [Errno 256] No more mirrors to try.
netlabs-rel-0.0.0-3.oc00.i386: failure: i386/netlabs-rel-0.0.0-3.oc00.i386.rpm from netlabs-exp: [Errno 256] No more mirrors to try.

Change History (5)

comment:1 Changed 8 years ago by djburtness

urlgrabber downloads extra bytes. urlgrabber-3.1.0.2

comment:2 Changed 8 years ago by ydario

Please try workaround described in ticket:35

comment:3 Changed 8 years ago by djburtness

Thanks. I added the c:\usr\lib before c:\ecs\dll and the downloads worked. Backed up and replaced libc* in c:\ecs\lib with libc* in c:\usr\lib.

comment:4 Changed 8 years ago by ydario

Not a good idea to have duplicate dlls, you are likely to get same problems on next libc update. It is better to remove the files in c:\ecs\lib.

comment:5 Changed 8 years ago by ydario

  • Resolution set to fixed
  • Status changed from new to closed

This is caused by binary mode flag to be set only for libc 0.6.3 dlls, while 0.6.4 linked dlls does not inherit it (because python executable is linked with 0.6.3).
Fixed in today python rebuild (libc 0.6.4 based).

Note: See TracTickets for help on using tickets.