Opened 11 years ago

Closed 9 years ago

#187 closed defect (unknown)

Toshiba Tecra a9-12t acpi not working with /smp

Reported by: LeWhoo Owned by:
Priority: major Milestone: Release version 3.18
Component: ACPI PSD Version: 3.13
Keywords: Cc: lewhoo@…

Description

without /smp it boots, with /smp it does not, with /pic or with /apic. Also, ecs 2.0 rc4 installation traps on acpi, when acpi is enabled.

Attachments (28)

acpi2.log (11.0 KB) - added by guest 11 years ago.
acpi3.log (11.0 KB) - added by guest 11 years ago.
acpi-log-toshiba-tecra-a9-12t.ziq (61.7 KB) - added by guest 11 years ago.
ZOC0802.LOG (14.2 KB) - added by guest 11 years ago.
comport log from booting debug kernel with acpi /smp /apic /o1 from 31.01
ZOC0802.2.LOG (13.9 KB) - added by guest 11 years ago.
Now with /smp /o1. Hangs on random drivers: usbuhcd, os2dasd, lvm…
suc_boot.log (17.1 KB) - added by guest 11 years ago.
successfull boot with /smp after adding LINK LNKH 5 to config.sys
config.sys (7.7 KB) - added by guest 11 years ago.
tecraa9-12t (24.2 KB) - added by guest 11 years ago.
tecraa9-12t_with_acpi (24.2 KB) - added by guest 11 years ago.
pci.exe output from boot with acpi.psd without /smp
acpi_linux (2.1 KB) - added by guest 11 years ago.
toshiba_acpi.c output from working linux acpi. The first type of hci_raw message appears only once, the second type is repeated constantly while system is running.
acpi-log-Model-of-your-PC.ziq (40.1 KB) - added by LeWhoo 11 years ago.
DSC00098.JPG (117.1 KB) - added by LeWhoo 11 years ago.
One hang without /SMP
DSC00099.JPG (109.2 KB) - added by LeWhoo 11 years ago.
Another hang without /SMP
DSC00102.JPG (91.4 KB) - added by LeWhoo 11 years ago.
Hang with /SMP
DSC00115.JPG (112.6 KB) - added by lewhoo 11 years ago.
one random hang on new kernel in single cpu mode
single.zip (13.3 KB) - added by LeWhoo 11 years ago.
acpi.psd single core
smp.log (15.7 KB) - added by LeWhoo 11 years ago.
with /smp
smpapic.log (16.0 KB) - added by LeWhoo 11 years ago.
with /smp /apic (3.14)
smp1.log (31.8 KB) - added by LeWhoo 11 years ago.
patched, /smp
d2fb.log (42.1 KB) - added by LeWhoo 11 years ago.
os2ldr.ini kernel with shareirq 0xd2fb
d2fb_1.log (42.1 KB) - added by LeWhoo 11 years ago.
os2ldr.ini kernel with shareirq 0xd2fb
nolinkchanges.log (44.5 KB) - added by LeWhoo 11 years ago.
dbgibmkrnl.log (3.2 KB) - added by LeWhoo 11 years ago.
nsmp.log (29.1 KB) - added by LeWhoo 11 years ago.
with /smp, krnl with os4krnl.ini
nsmpapic.log (14.8 KB) - added by LeWhoo 11 years ago.
with /smp /apic, krnl with os4krnl.ini
n1smp.log (10.8 KB) - added by LeWhoo 11 years ago.
another try
n2smp.log (10.9 KB) - added by LeWhoo 11 years ago.
/smp, removed acpi.* from os4krnl.ini
n3smp.log (10.6 KB) - added by LeWhoo 11 years ago.
/smp, kernel 1009

Download all attachments as: .zip

Change History (50)

Changed 11 years ago by guest

Changed 11 years ago by guest

comment:1 Changed 11 years ago by eco

Please send us additional photos and information:

how to collect logs: http://ecomstation.ru/projects/acpitools/?action=logs

comment:2 Changed 11 years ago by guest

  • Cc lewhoo@… added

With /SMP it hangs right after displaying ecs logo, before any driver loads (with alt-f2 display). Debug version (3.06) displays rapidly 2 screens of data, than third with only two lines:

CPU0 status evaluate _PCT 0x5 AE_NOT_FOUND

CPU0 status evaluate _CST 0x0 AE_OK

that's where it stops. Previous screens disappear too quickly.

I tried os2apic, which hangs when loading clock01.sys.

Changed 11 years ago by guest

comment:3 Changed 11 years ago by guest

today os/2 with acpi without /smp hanged loading usbuchi/usbehci drivers. I had to unplug the power cable to make it boot.

comment:4 Changed 11 years ago by pasha

Please download experimental ACPI build from Mensys site:

  • Experimental build for you:

acpi31012008.zip

Changed 11 years ago by guest

comport log from booting debug kernel with acpi /smp /apic /o1 from 31.01

Changed 11 years ago by guest

Now with /smp /o1. Hangs on random drivers: usbuhcd, os2dasd, lvm...

Changed 11 years ago by guest

successfull boot with /smp after adding LINK LNKH 5 to config.sys

Changed 11 years ago by guest

Changed 11 years ago by guest

comment:5 Changed 11 years ago by pasha

very strange output. Attach pls output from pci.exe with acpi.psd

Changed 11 years ago by guest

pci.exe output from boot with acpi.psd without /smp

Changed 11 years ago by guest

toshiba_acpi.c output from working linux acpi. The first type of hci_raw message appears only once, the second type is repeated constantly while system is running.

comment:6 Changed 11 years ago by pasha

I look to your DSDT acpi table, there is absent method \_SB_.VALZ.GHCI

comment:8 Changed 11 years ago by eco

It's necessary load fixed ACPI tables. Current version of ACPI.PSD doesn't support this for SMP kernel.

I am sorry to tell this, but we can't solve the problem today.

comment:9 Changed 11 years ago by guest

But acpi is also unstable for UNI kernel - is it the same problem?

comment:10 Changed 11 years ago by stevenhl

  • Milestone changed from eCS 2.0 to Release version 3.11

comment:11 follow-up: Changed 11 years ago by guest

Do you mean you plan to fix it in release 3.11?

comment:12 in reply to: ↑ 11 Changed 11 years ago by stevenhl

Replying to guest:

Do you mean you plan to fix it in release 3.11?

I plan to have the developers revisit this in release 3.11. I need to talk with them to understand the level of effort it will take to resolve your issue.

comment:14 Changed 11 years ago by eco

ok, and you can try test build: http://ecomstation.ru/projects/acpitools/?action=testcase there was new build ~ 1 week ago

comment:15 Changed 11 years ago by LeWhoo

  • Version changed from 3.05 to 3.12

Tried with the testcase version.

Without /SMP:

  • sometimes boots, and I attach logs collector output here
  • sometimes hangs on rather random drivers. I'll attach pictures in another entry

With /SMP:

  • I didn't manage to boot it without hang

Changed 11 years ago by LeWhoo

Changed 11 years ago by LeWhoo

One hang without /SMP

Changed 11 years ago by LeWhoo

Another hang without /SMP

Changed 11 years ago by LeWhoo

Hang with /SMP

comment:16 Changed 11 years ago by lewhoo

  • Version changed from 3.12 to 3.13

Hangs on random drivers, both with old and new kerenel.

Changed 11 years ago by lewhoo

one random hang on new kernel in single cpu mode

Changed 11 years ago by LeWhoo

acpi.psd single core

Changed 11 years ago by LeWhoo

with /smp

Changed 11 years ago by LeWhoo

with /smp /apic (3.14)

Changed 11 years ago by LeWhoo

patched, /smp

Changed 11 years ago by LeWhoo

os2ldr.ini kernel with shareirq 0xd2fb

Changed 11 years ago by LeWhoo

os2ldr.ini kernel with shareirq 0xd2fb

Changed 11 years ago by LeWhoo

Changed 11 years ago by LeWhoo

Changed 11 years ago by LeWhoo

with /smp, krnl with os4krnl.ini

Changed 11 years ago by LeWhoo

with /smp /apic, krnl with os4krnl.ini

Changed 11 years ago by LeWhoo

another try

Changed 11 years ago by LeWhoo

/smp, removed acpi.* from os4krnl.ini

Changed 11 years ago by LeWhoo

/smp, kernel 1009

comment:17 Changed 10 years ago by pasha

Please download experimental ACPI build from Mensys site:

  • Experimental build for you:

ACPI-APIC-BAT.ZIP

comment:18 Changed 10 years ago by stevenhl

  • Milestone changed from Release version 3.15 to Feedback pending

comment:19 Changed 10 years ago by stevenhl

  • Reporter changed from guest to LeWhoo

comment:20 Changed 10 years ago by pasha

Please download experimental ACPI build from Mensys site:

  • Experimental build for you:

ACPI315PRE.ZIP

comment:21 Changed 10 years ago by pasha

  • Owner pasha deleted

comment:22 Changed 9 years ago by stevenhl

  • Milestone changed from Feedback pending to Release version 3.18
  • Resolution set to unknown
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.