Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#65 closed defect (fixed)

NVidia HDA and Realtek ALC882: no sound with RC3

Reported by: ggamba Owned by: psmedley
Priority: highest Milestone: HDA
Component: UNIAUD32 Version: 1.9.2
Severity: major Keywords: HDA NVIDIA ALC882
Cc: yoda

Description (last modified by gentux2)

Hi all,

with NVidia MCP 570 (detected mixer: Realtek ALC882) I have no sound with RC3, while I had it with RC2. Attached are logs from both RC2 and RC3.

Attachments (6)

log_RC2.zip (1.5 KB) - added by ggamba 12 years ago.
log_RC3.zip (1.4 KB) - added by ggamba 12 years ago.
unimix_log_RC3.zip (859 bytes) - added by ggamba 12 years ago.
debuginfo.zip (6.9 KB) - added by ggamba 12 years ago.
debuginfo071201.zip (42.4 KB) - added by ggamba 12 years ago.
S6300045.jpg (107.9 KB) - added by guest 12 years ago.
TRAP0008 criguada _at_ gmail .dot. com

Download all attachments as: .zip

Change History (29)

Changed 12 years ago by ggamba

Changed 12 years ago by ggamba

comment:1 Changed 12 years ago by ggamba

  • Component changed from Building to UNIAUD32

comment:2 Changed 12 years ago by ggamba

  • Milestone changed from milestone1 to AlsaResync

Changed 12 years ago by ggamba

comment:3 Changed 12 years ago by ggamba

Read: "I have no sound with RC3", obviously :-)

comment:4 Changed 12 years ago by gentux2

  • Description modified (diff)
  • Milestone changed from AlsaResync to 1.1.4GA

comment:5 follow-up: Changed 12 years ago by gentux2

As this is a 1.1.4 regression, it should be fixed for the GA release.

Does manually copying the 1.1.4RC2 uniaud32.sys and uniaud16.sys over the installed 1.1.4RC3 give you sound again? (isolate whether the problem is caused by the 1.1.4RC3 installer)

If that works, please try "mixing and matching" the uniaud16 and uniaud32 versions. (i.e. isolate whether it is the newer uniaud16.sys or the newer uniaud32.sys that causes the problem).

Looks like it is probably uniaud32, so it will help to have a log from the debug uniaud32.sys, downloadable from Netlabs ftp. Do not use the debug uniaud16.

comment:6 in reply to: ↑ 5 ; follow-up: Changed 12 years ago by ggamba

Replying to gentux2:

As this is a 1.1.4 regression, it should be fixed for the GA release.

Does manually copying the 1.1.4RC2 uniaud32.sys and uniaud16.sys over the installed 1.1.4RC3 give you sound again? (isolate whether the problem is caused by the 1.1.4RC3 installer)

Yes; not an installer problem.

If that works, please try "mixing and matching" the uniaud16 and uniaud32 versions. (i.e. isolate whether it is the newer uniaud16.sys or the newer uniaud32.sys that causes the problem).

Looks like it is probably uniaud32, so it will help to have a log from the debug uniaud32.sys, downloadable from Netlabs ftp. Do not use the debug uniaud16.

Seems it is instead uniaud16. RC2 uniaud16 and RC3 uniaud32 has sound, RC3 uniaud16 and RC2 uniaud32 has no sound.

By the way, RC2 never worked very well (sometimes worked, other times WPS hanged or sound disappeared), but this is probably a more general problem with HDA...

Thanks a lot for the assistance!

comment:7 in reply to: ↑ 6 ; follow-up: Changed 12 years ago by yoda

  • Cc yoda added

Seems it is instead uniaud16. RC2 uniaud16 and RC3 uniaud32 has sound, RC3 uniaud16 and RC2 uniaud32 has no sound.

It is a bit odd, that you do not get any sound; because it looks like it plays. It looks like RC2 sets your device to 44100 in sample rate, where RC3 sets it to 48000. 48000 should work fine with ALC882 - it works fine with my ALC883. However, I don't think we changed anything to make samplerate change, weird.

By the way, RC2 never worked very well (sometimes worked, other times WPS hanged > or sound disappeared), but this is probably a more general problem with HDA...

Do check how sound is working using Warpvision (through UNIAUD API)

HDA/ALC88x has known problems.

I have created a workaround for the WPS hangs(system sounds never ends), which work for me.

It doesn't fix the broken sounds, only the hangs. Get it here: ftp://ftp.ecomstation.dk/uniaud32.zip

comment:8 in reply to: ↑ 7 Changed 12 years ago by ggamba

Replying to yoda:

Seems it is instead uniaud16. RC2 uniaud16 and RC3 uniaud32 has sound, RC3 uniaud16 and RC2 uniaud32 has no sound.

It is a bit odd, that you do not get any sound; because it looks like it plays. It looks like RC2 sets your device to 44100 in sample rate, where RC3 sets it to 48000. 48000 should work fine with ALC882 - it works fine with my ALC883. However, I don't think we changed anything to make samplerate change, weird.

By the way, RC2 never worked very well (sometimes worked, other times WPS hanged > or sound disappeared), but this is probably a more general problem with HDA...

Do check how sound is working using Warpvision (through UNIAUD API)

With RC3 (and your uniaud32.sys) I have no sound, also in Warpvision, with any possible combination (Dart, Uniaud no resample, Uniaud resample 44 Khz, Uniaud resample 48 Khz), both with a mp3 file with sample rate 44100 and with an AVI with sample rate 48000.

With RC2 uniaud16.sys, Dart works while Uniaud doesn't, and if I try Uniaud, then Dart doesn't work anymore and gives the error "Blocked unit".

Attached is log done with uniinfo.zip!

Changed 12 years ago by ggamba

comment:9 Changed 12 years ago by ggamba

  • Component changed from UNIAUD32 to UNIAUD16

Hi, I tried RC4, the problem is still here (not surprisingly, as I think that most of the work for RC4 went in uniaud32.sys).

With uniaud16.sys from RC2, the command:

[c:\]play file="\MMOS2\SOUNDS\startup.wav"

works; with uniaud16.sys from RC2, like with the one from RC3, the command never ends (it remains forever with a blinking cursor just under the "play file" line).

comment:10 Changed 12 years ago by yoda

  • Owner set to yoda
  • Status changed from new to assigned

I fixed up some of the problem in debug versions for RC4.

try: ftp://ftp.ecomstation.dk/ac97-1.zip

It should give us a lot more debug info...

comment:11 follow-up: Changed 12 years ago by ggamba

Hi Yoda,

I installed ac97-1.zip and now I have sound :-)
Furthermore, I was able to run 'play file="\MMOS2\SOUNDS\startup.wav"' consecutively several times and system never hanged. There is just a peak of 99% CPU usage (on both CPUs; this is a DualCore? system) when the sound finishes, just before the prompt is back, but no hangs.
Sometimes startup.wav sounds chopped, and volume control doesn't work for speakers while works for headphones, but I guess these are known problems for HDA (like #53 but without hangs, #55) and in any case not related to this ticket.
I would say that this ticket can be closed. Please ask if you need more experiments. debuginfo071201.zip attached.

Thanks for all your work!!

Changed 12 years ago by ggamba

comment:12 in reply to: ↑ 11 ; follow-up: Changed 12 years ago by yoda

  • Priority changed from normal to highest

I installed ac97-1.zip and now I have sound :-)

What ? For your hardware there shouldn't have been any fixes in it.

Sometimes startup.wav sounds chopped, and volume control doesn't work for speakers while works for headphones, but I guess these are known problems for HDA (like #53 but without hangs, #55) and in any case not related to this ticket.

Yes, these things will not be fixed for version 1.1.4

I would say that this ticket can be closed. Please ask if you need more experiments. debuginfo071201.zip attached.

That is a bit too early, as I'm not sure, why I fixed your problem :-)
In this build however, I changed the fixed samplerate 48000 -> 44100
which seems to be what RC2 was using too.

Your hw should work fine with 48000 too - a bit strange it doesn't.

We might change RC5 to use 44100 - and see if any1 gets hurt by that.

Thanks for all your work!!

It is your feedback, that makes it possible!

comment:13 in reply to: ↑ 12 Changed 12 years ago by guest

Replying to yoda:

I installed ac97-1.zip and now I have sound :-)

What ? For your hardware there shouldn't have been any fixes in it.

As you noted, it is probably related to the sample rate. Is there anything I can do to verify this? Or, is there something you need me to test?

Bye and thanks

Gabriele

comment:14 follow-up: Changed 12 years ago by yoda

I can't see anything else than sample rate is the cure here; although it is not obvious why. Then again, as we know, HDA is generally unreliable in current state.

I think we will try this change in sample rate in RC5, and see if it brakes/helps others.

So, no tests needed for now.

comment:15 in reply to: ↑ 14 ; follow-up: Changed 12 years ago by guest

I had the same problem here: NVidia chipset (detected mixer ALC888 IIRC) and no sound with RC3 (RC2 did work). Installing AC97-1 solved the problem. Sound is still not perfectly stable though: short sounds are often clipped. Long sounds are sometimes stuttering. Sometimes when a sound plays the system locks _completely_solid_ for a few seconds (i.e. mouse is frozen, C-A-D does not work), then it resume working normally as if nothing had happened. If you need more precise hardware info let me know, I am at work now and don't remember the exact details. criguada _at_ gmail .dot. com Thankyou!!

comment:16 in reply to: ↑ 15 ; follow-up: Changed 12 years ago by guest

I had to restore the original files because with AC97-1 eCS sometimes trapped with a TRAP0008 when playing sounds. I am going to upload a screenshot of the trap screen, hope it helps. I'll try again after upgrading to 1.1.4RC4. criguada _at_ gmail .dot. com

Changed 12 years ago by guest

TRAP0008 criguada _at_ gmail .dot. com

comment:17 in reply to: ↑ 16 Changed 12 years ago by guest

Hi, I tried AC97-1 on top of 1.1.4RC4 and still have the traps. They're triggered by playing very short sounds.

Replying to guest:

I had to restore the original files because with AC97-1 eCS sometimes trapped with a TRAP0008 when playing sounds. I am going to upload a screenshot of the trap screen, hope it helps. I'll try again after upgrading to 1.1.4RC4. criguada _at_ gmail .dot. com

comment:18 Changed 12 years ago by yoda

  • Milestone changed from 1.1.4GA to milestone4

comment:19 Changed 11 years ago by psmedley

Please test with unaiud32.sys from http://download.smedley.info/uniaud32-1.9.2.zip - preferably with unaiud16.sys from 1.1.4RC5

comment:20 Changed 11 years ago by ggamba

With uniaud114RC6.zip + uniaud32-1.9.2.zip sound works fine|

Thanks a lot!

Gabriele

comment:21 Changed 11 years ago by yoda

  • Component changed from UNIAUD16 to UNIAUD32
  • Owner changed from yoda to psmedley
  • Status changed from assigned to new
  • Version changed from 1.1.4 to 1.9.2

comment:22 Changed 11 years ago by psmedley

  • Resolution set to fixed
  • Status changed from new to closed

comment:23 Changed 11 years ago by psmedley

Feedback from Gabriele indicates that latest builds fix this problem.

Note: See TracTickets for help on using tickets.