Opened 13 years ago

Closed 10 days ago

#55 closed defect (too-old)

Intel HDAudio ICH7 and Realtek ALC883 several missing controls using UnimixPM

Reported by: Yoda Owned by: Paul Smedley
Priority: high Milestone: ALSA Hardware Compatibility
Component: Mixer Version: 2.0
Severity: major Keywords:
Cc:

Description

If I try using UnimixPM to control sound, lots of the controls are disabled, and can't be used. Using Unimix, a lot more controls seems to be available. Something in the interface must be wrong.

Attached unimix.log and a picture of UnimixPM layout window.

Attachments (1)

uniaud14.zip (16.5 KB) - added by Yoda 13 years ago.
unimix.log and picture of UnimixPM layout

Download all attachments as: .zip

Change History (9)

Changed 13 years ago by Yoda

Attachment: uniaud14.zip added

unimix.log and picture of UnimixPM layout

comment:1 Changed 12 years ago by Brendan Oakley

Resolution: wontfix
Status: newclosed
Version: 1.0

UnimixPM is not part of the Uniaud project.

comment:2 Changed 11 years ago by Paul Smedley

Resolution: wontfix
Status: closedreopened

comment:3 Changed 11 years ago by Paul Smedley

Owner: set to Paul Smedley
Status: reopenednew

comment:4 Changed 11 years ago by Paul Smedley

This affects lbmix as well - it seems HDA mixer controls aren't correctly mapped to ioctl90 names.

OCO/trunk/drv16/mixer.cpp is probably the culprit

comment:5 Changed 10 years ago by Yoda

Version: 2.0

Only 3 controls exists now in UNIMIXPM. UNIMIX has 20 controls.

Older drivers used to have 30-40 controls available (unimix)

It seems to go backwards for every new build :-(

comment:6 Changed 7 years ago by jep

I've installed: Uniaud16 1.9.5 and Uniaud32 2.1.3 Based on ALSA 1.0.23 (Beta version)

Can't change the volume inside MPlayer nor with UniMix? (now only 1 control), the only way to change it is with the standard OS/2 Volume control. The great part is athat it's now possible to change the volume to something louder than a whisper (on this specific computer) as compared to other computers that I own! Great!!!

This Laptop has a built in chip that ALSA introduced support for in ALSA 1.0.23 according to the web site.

Last edited 7 years ago by jep (previous) (diff)

comment:7 Changed 10 days ago by martini

Hi

PMUniMix is not part of UniAud? and the latest version is PMUniMix-bin-0_82.zip (on hobbes).

This report is too old, if the problem persist please try contacting the PMUniMix author and if the issue is related to Uniaud, please re open the ticket.

Regards

comment:8 Changed 10 days ago by martini

Resolution: too-old
Status: newclosed
Note: See TracTickets for help on using tickets.