Opened 12 years ago

Closed 8 years ago

#53 closed defect (duplicate)

Intel HDAudio ICH7 and Realtek ALC883 choppy sound through Dart

Reported by: yoda Owned by: dazarewicz
Priority: high Milestone: HDA
Component: UNIAUD16 Version: 2.0
Severity: major Keywords: HDA ICH7 ALC883
Cc:

Description

Playing sound through UNIAUD API (WarpVision?) works fine, but playing through Dart only works corect for first sound. Sounds after that are cut either at start or end. Often the player doesn't exit, which can make WPS hang, if system sounds are enabled.

Attached log shows a mem allocation problem.

Attachments (1)

uniaud11.zip (2.1 KB) - added by yoda 12 years ago.
alsahlp$ and unimix logs

Download all attachments as: .zip

Change History (9)

Changed 12 years ago by yoda

alsahlp$ and unimix logs

comment:1 Changed 12 years ago by yoda

  • Summary changed from Intel HDAudio ICH7 and Realtek ALC883 to Intel HDAudio ICH7 and Realtek ALC883 choppy sound through Dart

comment:2 Changed 12 years ago by yoda

  • Component changed from UNIAUD32 to UNIAUD16
  • Milestone changed from milestone1 to 1.1.4GA
  • Owner set to yoda
  • Status changed from new to assigned
  • Version changed from 1.0 to 1.1.4

Problem analyzed to be the resampler code in UNIAUD16.
If a wav file is resampled to 48000 before playing, there is no problems.

comment:3 Changed 11 years ago by yoda

  • Milestone changed from 1.1.4GA to milestone4
  • Version changed from 1.1.4 to 1.1.4RC5

comment:4 Changed 11 years ago by psmedley

Please test with unaiud32.sys from http://download.smedley.info/uniaud32-1.9.2.zip - preferably with unaiud16.sys from 1.1.4RC5

comment:5 follow-up: Changed 9 years ago by dazarewicz

  • Owner changed from yoda to dazarewicz
  • Status changed from assigned to new

Does this problem still exist in the latest BETA build?

comment:6 Changed 9 years ago by dazarewicz

  • Status changed from new to assigned

comment:7 in reply to: ↑ 5 Changed 9 years ago by yoda

  • Version changed from 1.1.4RC5 to 2.0

Replying to dazarewicz:

Does this problem still exist in the latest BETA build?

It seems Dart it playing corret now, but now UNIAUD API is completely broken again. Through UNIAUD API sound is choppy, and there is a lot of echoing.

comment:8 Changed 8 years ago by dazarewicz

  • Resolution set to duplicate
  • Status changed from assigned to closed

The uniaud api problem is known in version 2.x. Version 1.9.24 works fine. This ticket is a duplicate of 191.

Note: See TracTickets for help on using tickets.