Opened 14 years ago

Closed 12 years ago

#22 closed defect (fixed)

Now audio is played to fast...

Reported by: rwklein@… Owned by: yoda
Priority: normal Milestone: Stabilization
Component: UNIAUD32 Version: 1.1.4
Severity: critical Keywords:
Cc:

Description

When not connected to the an AC power adapter something with throtheling the CPU speed seems to interfere with playing. Now I got audio played to fast after the machine was booted with an AC adapter connected.

Attachments (5)

alsahlp_audio_to_fast.txt (4.9 KB) - added by anonymous 14 years ago.
uniaud.LOG (8.0 KB) - added by gentux2 12 years ago.
1.1.4RC3 Release ALSAHLP$
uniauddebug.LOG (18.5 KB) - added by gentux2 12 years ago.
1.1.4RC3 Debug ALSAHLP$ (8086:24D5)
unimix.LOG (12.2 KB) - added by gentux2 12 years ago.
1.1.4RC3 Unimix output (8086:24D5)
pci.LOG (1.4 KB) - added by gentux2 12 years ago.
PCI info for device used to generate last 3 logs

Download all attachments as: .zip

Change History (10)

Changed 14 years ago by anonymous

comment:1 Changed 13 years ago by rwklein@…

You send a reply via email of which I remeber you where a little bit confused. Just to summerize it. All previous builds of UNIAUD had the problem where, the a laptop would run on battery power (boot time!) it would play the audio to fast or to slow.

You then send me a private build and this fixed the problems with to slow or to fast audio playback when running on battery! However it introduced a new problem. Now when the AC adapter is plugged in at the system gets a cold boot it always plays a slow rate the audio.

comment:2 Changed 12 years ago by gentux2

  • Component changed from UNIAUD-API to UNIAUD32

Is this a problem with only a private test build, or can it be reproduced with publicly available builds? Does it occur with any recent builds (after, say Feb. 2007)?

Changed 12 years ago by gentux2

1.1.4RC3 Release ALSAHLP$

comment:3 Changed 12 years ago by gentux2

David McKenna reports on uniaud-user that on his Intel ICH5 with AD1985 codec (8086:24D5) audio plays too fast using version 1.1.4RC3 of Uniaud32, but 1.1.4RC2, either from November or January, is fine. The debug build of 1.1.4RC3, with or without running lxlite on it, does not play sounds fast but has a slight pause before sounds. Attaching logs from 1.1.4RC3 debug and release, and pci output.

Changed 12 years ago by gentux2

1.1.4RC3 Debug ALSAHLP$ (8086:24D5)

Changed 12 years ago by gentux2

1.1.4RC3 Unimix output (8086:24D5)

Changed 12 years ago by gentux2

PCI info for device used to generate last 3 logs

comment:4 Changed 12 years ago by yoda

  • Milestone set to 1.1.4GA
  • Owner changed from vladest to yoda
  • Status changed from new to assigned
  • Version set to 1.1.4

Seems related to ticket #73
Please try: ftp://ftp.ecomstation.dk/ac97-1.zip

comment:5 Changed 12 years ago by gentux2

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.