Opened 12 years ago

Closed 12 years ago

#73 closed defect (fixed)

UniAud 1.1.4 rc3+4 high pitch

Reported by: guest Owned by: yoda
Priority: normal Milestone: Stabilization
Component: UNIAUD32 Version: 1.1.4
Severity: normal Keywords: ac97 clock
Cc: yoda

Description

With both 1.1.4rc3 and the new 1.2 beta, system sounds play at a slightly high pitch.... like 44.1kHz being played at 48kHz. This only happens about 1 out of 3 boots. I have attached 2 files: alsa-normal.log is acpihlp$ when booted with normal sound, alsa-high.log is alsahlp$ when sound is high pitched.

1.1.4rc2 has never done this.

Attachments (7)

alsa-normal.log (5.0 KB) - added by guest 12 years ago.
alsahlp$ with normal sound
alsa-high.log (5.0 KB) - added by guest 12 years ago.
alsahlp$ with high pitch sounds
alsa-rc2.log (20.8 KB) - added by guest 12 years ago.
alsahlp$ using 1.1.4rc2
rc4high.log (5.2 KB) - added by guest 12 years ago.
RC4 when booted and pitch is high
rc4normal.log (6.1 KB) - added by guest 12 years ago.
RC4 when booted and pich is normal
ac97-1normal.zip (11.6 KB) - added by guest 12 years ago.
AC97-1 drivers, normal sound
alsalog1.zip (32.2 KB) - added by guest 12 years ago.
A few alsahlp$ logs 11/27-11/30

Download all attachments as: .zip

Change History (18)

Changed 12 years ago by guest

alsahlp$ with normal sound

Changed 12 years ago by guest

alsahlp$ with high pitch sounds

comment:1 Changed 12 years ago by guest

  • Component changed from Building to UNIAUD32

Computer is Asus P4C800 Deluxe with ICH5/AD1985 integrated audio.

Changed 12 years ago by guest

alsahlp$ using 1.1.4rc2

Changed 12 years ago by guest

RC4 when booted and pitch is high

Changed 12 years ago by guest

RC4 when booted and pich is normal

comment:2 Changed 12 years ago by guest

RC4 is more or less the same... it does seem the pitch is even higher though. I have attached two more log files for RC4.

comment:3 Changed 12 years ago by yoda

  • Cc yoda added
  • Keywords ac97 clock added
  • Milestone set to 1.1.4GA
  • Owner set to yoda
  • Status changed from new to assigned
  • Summary changed from UniAud 1.1.4 rc3 high pitch to UniAud 1.1.4 rc3+4 high pitch
  • Version set to 1.1.4

I can see what happens - but I wonder why this doesn't happen for RC2. I don't think pitch is different for RC4 - it looks random.

Could you try these drivers please.

ftp://ftp.ecomstation.dk/ac97-1.zip

Might not fix anything, but gives me more output.

And... please use uniinfo.zip (@ netlabs) to collect all logs.

Changed 12 years ago by guest

AC97-1 drivers, normal sound

comment:4 Changed 12 years ago by guest

I have loaded your test drivers and they seem to work fine... at least after 8 reboots the pitch is still normal. With rc3+4 I usually got the high pitch the first time. I have uploaded the log files you requested.

I'll keep running these and let you know if there is any change.

Dave McKenna?

comment:5 Changed 12 years ago by yoda

I'm happy to hear it helped. I'm however still very interested in more logs, because they seem to be a bit different from time to time.
The problem here happens during init, so you don't need to play anything; just create the log after each boot. Now, don't start rebooting just for us; that is not needed, but just collect the logs, and zip a bunch together and upload here (not urgent).
(it is of course only alsahlp.log we really need in this case - you're welcome to filter the others out)

Thank you for helping us making Uniaud better !

Changed 12 years ago by guest

A few alsahlp$ logs 11/27-11/30

comment:6 Changed 12 years ago by guest

Thank YOU for making UNIAud! I have uploaded a few alsahlp$ logs from the past few days...

Dave McKenna?

comment:7 Changed 12 years ago by gentux2

Committed fix in changeset:275. This can be closed if fixed in 1.1.4RC5, when released.

This may be related to Ticket #22.

comment:8 Changed 12 years ago by guest

FWIW... the latest resync version (1.01) seems to have corrected this issue.

Dave McKenna?

comment:9 Changed 12 years ago by guest

Whoops.... looks like I spoke too soon. It does still happen (the high pitch sound) just much less often.

Dave McKenna?

comment:10 Changed 12 years ago by guest

It looks like RC5 has corrected my original problem with the high pitch sound. Thanks for doing it!

Also... ticket #22 does refer to this same issue (which I had reported on the GMane newsgroup as well).

comment:11 Changed 12 years ago by gentux2

  • Resolution set to fixed
  • Status changed from assigned to closed

Confirmed fixed in 1.1.4RC5. Thanks.

Note: See TracTickets for help on using tickets.