Opened 14 years ago

Closed 12 years ago

#21 closed defect (fixed)

Playing audio it sounds like a record recorded ay 45 RPM playing at 33 1/3

Reported by: rwklein@… Owned by: gentux2
Priority: normal Milestone: Stabilization
Component: UNIAUD32 Version: 1.1.4
Severity: critical Keywords:
Cc:

Description

Iiittt souunds sloooow. I let you hear this at the Developer Workshop Vladest, you play music and it plays slow. This also does not occur with the Soundmax driver.

Attachments (2)

alsahlp.txt (10.7 KB) - added by anonymous 14 years ago.
log (51.9 KB) - added by abwillis 13 years ago.

Download all attachments as: .zip

Change History (20)

Changed 14 years ago by anonymous

comment:1 Changed 14 years ago by vladest

  • Owner changed from vladest to anonymous
  • Status changed from new to assigned

How can I test it at my side? the only difference I see it's different ac97 codec rates btw, I will not at dev workshop

comment:2 Changed 14 years ago by anonymous

Well I have had this problem a Thinkpad with a Crystal AC 4297 chipset. And I have had this on a T23 and a T40. It seems to be something with AC 97 on Intel side. How can I provide more information ?

comment:3 Changed 14 years ago by vladest

provide me T23 or T40. Or even T34 - I'll come to nl on it :) w/o jokes: I wonna you to test it via uniaud api

comment:4 Changed 13 years ago by rwklein@…

Finaly getting time to get back to this. Its not the UNIAUD API that will make a difference, its a timing issue on hardware level. Rudiger Ihle confirmed it was something in the AC 97 Intel (and Intel compatible code).

comment:5 Changed 13 years ago by anonymous

I see this on my T42 with the latest uniaud netlabs testcase dated-6-23-2006 when my system boots off of battery. This is not an issue here if I boot while on power. I do not recall seeing this on other versions of the driver however.

comment:6 Changed 13 years ago by guest

Today for the first time I have slow audio on the T42 after booting on AC. Same drivers dated 6-23-2006.

comment:7 Changed 13 years ago by guest

OK, the 7-09-06 testcase release is working fine when booting under battery or AC on the T42 now.

comment:8 Changed 13 years ago by abwillis

On T42 I am now experiencing this with the uniaud_28012007_testcase.zip build. This is on power, haven't tried battery. Previous drivers versions haven't done this. Will attach log. Vendor 8086h Intel Corporation Device 24C5h 82801DB/DBL AC'97 Audio Controller (ICH4/ICH4-L A1 step) Subsystem ID 05541014h SoundMAX Integrated Digital Audio

Changed 13 years ago by abwillis

comment:9 Changed 13 years ago by abwillis

I had skipped the msv_ich_test build but went back to double check that the problem was not introduced there. With that build sound is fine so it was indeed introduced with the uniaud_28012007_testcase build.

comment:10 Changed 12 years ago by abwillis

OK, just determined that in my case the slow down is caused by the power saver changes done in the latest release. I was set to battery optimized even on AC and I just changed that and it works fine when not in battery optimized as far as sound goes.

comment:11 Changed 12 years ago by gentux2

This problem does not occur with a build of the source from revision 85 (which needs slight modification to allow it to build). Date 10/2006. Revision 86 causes a TRAP E on the effected hardware, and Revision 88 does not TRAP but does have this slow sound problem with power saving enabled.

comment:12 Changed 12 years ago by gentux2

Selectively updating files from revision 85 to revision 88 and testing reveals that this problem occurs only when the AC'97 code is updated. This includes 4 files: /alsa-kernel/pci/ac97/ac97_codec.c /alsa-kernel/pci/ac97/ac97_patch.c /alsa-kernel/pci/ac97/ac97_patch.h /alsa-kernel/include/sound/ac97_codec.h

comment:13 Changed 12 years ago by gentux2

  • Component changed from UNIAUD-API to UNIAUD32

comment:14 Changed 12 years ago by gentux2

  • Owner changed from anonymous to gentux2
  • Status changed from assigned to new

I believe this is fixed now in Revision 229. Leaving the ticket open for now until tested and confirmed.

comment:15 Changed 12 years ago by gentux2

  • Status changed from new to assigned

comment:16 follow-up: Changed 12 years ago by yoda

please test:
ftp://ftp.ecomstation.dk/ac97-1.zip[[BR]]

And see if it changes anything....
and give us "uniinfo" logs

comment:17 in reply to: ↑ 16 Changed 12 years ago by gentux2

  • Milestone set to 1.1.4GA
  • Version set to 1.1.4

All recent testing with this has been done by Andy. Roderick, can you please confirm that this is fixed in Uniaud 1.1.4RC4? (The fix applied to 1.1.4RC3.)

comment:18 Changed 12 years ago by yoda

  • Resolution set to fixed
  • Status changed from assigned to closed

No response for too long...

Note: See TracTickets for help on using tickets.