Opened 7 years ago

Closed 10 months ago

#54 closed defect (invalid)

broken tk>=8.4 dependency for git-gui & gitk packages

Reported by: estellnb Owned by: ydario
Priority: minor Milestone:
Component: rpm Version:
Severity: highest Keywords:
Cc:

Description

[e:\]yum install git-gui
Einrichten des Installationsprozess
Löse Abhängigkeiten auf
--> Führe Transaktionsprüfung aus
---> Paket git-gui.i386 0:1.7.6.1-7.oc00 markiert, um aktualisiert zu werden
--> Verarbeite Abhängigkeiten: gitk = 1.7.6.1-7.oc00 für Paket: git-gui-1.7.6.1-
7.oc00.i386
--> Verarbeite Abhängigkeiten: tk >= 8.4 für Paket: git-gui-1.7.6.1-7.oc00.i386
--> Führe Transaktionsprüfung aus
---> Paket git-gui.i386 0:1.7.6.1-7.oc00 markiert, um aktualisiert zu werden
--> Verarbeite Abhängigkeiten: tk >= 8.4 für Paket: git-gui-1.7.6.1-7.oc00.i386
---> Paket gitk.i386 0:1.7.6.1-7.oc00 markiert, um aktualisiert zu werden
--> Verarbeite Abhängigkeiten: tk >= 8.4 für Paket: gitk-1.7.6.1-7.oc00.i386
--> Abhängigkeitsauflösung beendet
Fehler: Package: git-gui-1.7.6.1-7.oc00.i386 (netlabs-rel)

Requires: tk >= 8.4

Fehler: Package: gitk-1.7.6.1-7.oc00.i386 (netlabs-rel)

Requires: tk >= 8.4

Sie können versuchen --skip-broken zu benutzen, um das Problem zu umgehen.
You could try running: rpm -Va --nofiles --nodigest

same problem for gitk.

[e:\]rpm -q tkinter
tkinter-2.6.5-6.oc00.i386

Change History (2)

comment:1 Changed 7 years ago by ydario

  • Priority changed from major to minor

gui packages are probably non working even if deps are resolved.

comment:2 Changed 10 months ago by diver

  • Resolution set to invalid
  • Severity set to highest
  • Status changed from new to closed

git 1.7.6 is obsolete since long. Please use 2.11. If there are still issues with the installation, then open a new ticket please.

Note: See TracTickets for help on using tickets.