Opened 9 days ago

Closed 7 days ago

Last modified 7 days ago

#323 closed enhancement (invalid)

Consider setting sane value for INFOPATH in postin scriptlet

Reported by: lewisr Owned by:
Priority: Feedback Pending Milestone:
Component: spec files Version:
Severity: low Keywords:
Cc:

Description

Currently, info (5.2-3) and man-db (2.7.6.1-3) do not set path variables during installation. While some of us prefer to set these values for ourselves, others may not be aware as to why, for example:

[q:\] info info

fails to find info.

It might be wise to add basic settings via postin scriplet for each of these (basic = x:\usr\share\man and x:\usr\share\info, where x: is %UNIXROOT%).

Related: https://mantis.arcanoae.com/view.php?id=2277

Change History (6)

comment:1 Changed 9 days ago by lewisr

  • Severity changed from low to highest

comment:2 Changed 8 days ago by diver

  • Priority changed from major to minor
  • Severity changed from highest to low

Please always do one ticket for one issue. Mixing them is never good.
For man there is no need for a manpath, as it can be added to man_db.conf in /@unixroot/etc. All normal path are include already.
For Info i will take a look next week.

Last edited 8 days ago by diver (previous) (diff)

comment:3 Changed 8 days ago by lewisr

  • Summary changed from Consider setting sane values for MANPATH and INFOPATH in postin scriptlets to Consider setting sane value for INFOPATH in postin scriptlet

Oy, vey ist mir! ;-)

You are entirely correct concerning MANPATH (I haven't kept current). I put both of these together mainly thinking that this was a philosophical issue as to whether you felt that these variables should be set during installation, and the same logic could be applied to other packages needing variables set in CONFIG.SYS.

So, this only applies to INFOPATH, then. Summary updated to better reflect the issue.

comment:4 Changed 7 days ago by diver

  • Priority changed from minor to Feedback Pending

Strange is here all works. Did you just use your bootstrap? As when you install Info it adds all needed Strings to config files. And all newer rpm also add Info stuff when enabled.
So please recheck.

comment:5 Changed 7 days ago by lewisr

I can confirm that on one older install info works with no INFOPATH. On the newer one (ArcaOS 5.0.3.4), it does not. The bootstrap did change in between. I'll test a few bootstraps and some manual installs to track this down.

More feedback coming later today.

comment:6 Changed 7 days ago by lewisr

  • Resolution set to invalid
  • Status changed from new to closed

i can confirm that earlier bootstrap installs run info just fine (at least 2017-04-08 and 2017-06-10). I see breakage with the 2017-09-23 bootstrap. The error is:

SYS0003: The system cannot find the path specified. "N:\@unixroot\usr\share\info\info.info.gz"

Note the improper handling of %UNIXROOT%. This is a consistent issue with later bootstraps until setting INFOPATH.

This is not bootstrap breakage, either, as I can start with the 2017-06-10 bootstrap which works, test info (all fine), update that to the latest packages available, and get the breakage.

The issue is in info-5.2-3. The problem does not occur with 5.2-2. fresh ticket coming.

Last edited 7 days ago by lewisr (previous) (diff)
Note: See TracTickets for help on using tickets.