Opened 2 months ago

Closed 2 months ago

#320 closed defect (no change needed)

Yum crashes and trashes database

Reported by: shmuel Owned by:
Priority: Feedback Pending Milestone:
Component: yum Version:
Severity: low Keywords: yum database panic
Cc:

Description

The command yum --disablerepo=*-rel install aspell bind-utils bison bison-runtime clamav clamav-data coreutils createrepo diffutils flex gawk gcc gcc-stdc++-shared-lib highmem info libc libxml2 m4 openssh-clients os2-rpm-build os2tk45 os2tk45-books os2tk45-heade

gives panic dumps, with most packages failing.

...
LIBC error: Couldn't fork %post(bison-3.0.4-1.oc00.i686): No such file or directory
fork: Child aborting fork()! rc=0xfffffffe
pid=0x0073 ppid=0x0068 tid=0x0001 slot=0x008b pri=0x0200 mc=0x0000 ps=0x0010
Q:\USR\BIN\PYTHON2.7.EXE

Installing : os2tk45-ipfc-4.5.2-7.oc00.i686 41/46

Non-fatal POSTIN scriptlet failure in rpm package os2tk45-ipfc-4.5.2-7.oc00.i686

error: Couldn't fork %post(os2tk45-ipfc-4.5.2-7.oc00.i686): No such file or directory

LIBC PANIC!!
LIBC fork: Child aborting fork()! rc=0xfffffffe
pid=0x0074 ppid=0x0068 tid=0x0001 slot=0x008e pri=0x0200 mc=0x0000 ps=0x0010
Q:\USR\BIN\PYTHON2.7.EXE

Installing : bison-runtime-3.0.4-1.oc00.i686 42/46

Installing : highmem-1.0.1-1.oc00.i686 43/46

Installing : clamav-data-0.99.2-2.oc00.i686 44/46

Process has been dumped

Cleanup : os2-rpm-1-1.oc00.noarch 45/46

Cleanup : libxml2-2.9.4-3.oc00.i686 46/46

Failed to remove transaction file /@unixroot/var/lib/yum/transaction-done.2018-1
0-01.08.16.51
clamav-data-0.99.2-2.oc00.i686 was supposed to be installed but is not!
createrepo-0.4.11-2.noarch was supposed to be installed but is not!
bind-libs-9.8.1-1.oc00.i686 was supposed to be installed but is not!
libxml2-2.9.8-1.oc00.i686 was supposed to be installed but is not!
os2tk45-readme-4.5.2-7.oc00.noarch was supposed to be installed but is not!
mpfr-3.1.0-2.oc00.i686 was supposed to be installed but is not!
diffutils-3.2-3.oc00.i686 was supposed to be installed but is not!
os2tk45-rc-4.5.2-7.oc00.i686 was supposed to be installed but is not!
os2-rpm-1-2.oc00.noarch was supposed to be installed but is not!
2:tar-1.23-7.oc00.i686 was supposed to be installed but is not!
libtool-ltdl-2.4.6-3.oc00.i686 was supposed to be installed but is not!
patch-2.6.1-4.oc00.i686 was supposed to be installed but is not!
clamav-0.99.2-2.oc00.i686 was supposed to be installed but is not!
1:findutils-4.6.0-2.oc00.i686 was supposed to be installed but is not!
aspell-en-7.1-1.noarch was supposed to be installed but is not!
binutils-2.27-2.oc00.i686 was supposed to be installed but is not!
aspell-0.60.6.1-4.oc00.i686 was supposed to be installed but is not!
gawk-4.0.0-2.oc00.i386 was supposed to be installed but is not!
os2tk45-headers-4.5.2-7.oc00.noarch was supposed to be installed but is not!
gcc-4.9.2.1-3.oc00.i686 was supposed to be installed but is not!
os2tk45-ipfc-4.5.2-7.oc00.i686 was supposed to be installed but is not!
libc-devel-0.6.6-37.oc00.i686 was supposed to be installed but is not!
os2tk45-libs-4.5.2-7.oc00.i686 was supposed to be installed but is not!
highmem-1.0.1-1.oc00.i686 was supposed to be installed but is not!
flex-2.5.35-2.oc00.i686 was supposed to be installed but is not!
xz-5.2.3-2.oc00.i686 was supposed to be installed but is not!
libmpc3-1.0.1-3.i686 was supposed to be installed but is not!
bind-license-9.8.1-1.oc00.noarch was supposed to be installed but is not!
rpm-build-4.13.0-17.oc00.i686 was supposed to be installed but is not!
file-5.30-2.oc00.i686 was supposed to be installed but is not!
os2tk45-utils-4.5.2-7.oc00.i686 was supposed to be installed but is not!
python-libxml2-2.9.8-1.oc00.i686 was supposed to be installed but is not!
bison-runtime-3.0.4-1.oc00.i686 was supposed to be installed but is not!
bison-3.0.4-1.oc00.i686 was supposed to be installed but is not!
openssh-clients-7.7p1-1.oc00.i686 was supposed to be installed but is not!
clamav-lib-0.99.2-2.oc00.i686 was supposed to be installed but is not!
os2tk45-books-4.5.2-7.oc00.noarch was supposed to be installed but is not!

Installed:

bind-utils.i686 0:9.8.1-1.oc00 m4.i686 0:1.4.17-3.oc00
os2-rpm-build.noarch 0:1-2.oc00 os2tk45.i686 0:4.5.2-7.oc00

Dependency Installed:

json-c.i686 0:0.10-2.oc00 pkgconfig.i686 1:0.29.1-4.oc00

Failed:

aspell.i686 0:0.60.6.1-4.oc00 aspell-en.noarch 0:7.1-1
bind-libs.i686 0:9.8.1-1.oc00 bind-license.noarch 0:9.8.1-1.oc00
binutils.i686 0:2.27-2.oc00 bison.i686 0:3.0.4-1.oc00
bison-runtime.i686 0:3.0.4-1.oc00 clamav.i686 0:0.99.2-2.oc00
clamav-data.i686 0:0.99.2-2.oc00 clamav-lib.i686 0:0.99.2-2.oc00
createrepo.noarch 0:0.4.11-2 diffutils.i686 0:3.2-3.oc00
file.i686 0:5.30-2.oc00 findutils.i686 1:4.6.0-2.oc00
flex.i686 0:2.5.35-2.oc00 gawk.i386 0:4.0.0-2.oc00
gcc.i686 0:4.9.2.1-3.oc00 highmem.i686 0:1.0.1-1.oc00
libc-devel.i686 0:0.6.6-37.oc00 libmpc3.i686 0:1.0.1-3
libtool-ltdl.i686 0:2.4.6-3.oc00 libxml2.i686 0:2.9.8-1.oc00
mpfr.i686 0:3.1.0-2.oc00 openssh.i686 0:7.7p1-1.oc00
openssh-clients.i686 0:7.7p1-1.oc00 os2-rpm.noarch 0:1-2.oc00
os2tk45-books.noarch 0:4.5.2-7.oc00 os2tk45-headers.noarch 0:4.5.2-7.oc00
os2tk45-ipfc.i686 0:4.5.2-7.oc00 os2tk45-libs.i686 0:4.5.2-7.oc00
os2tk45-rc.i686 0:4.5.2-7.oc00 os2tk45-readme.noarch 0:4.5.2-7.oc00
os2tk45-utils.i686 0:4.5.2-7.oc00 patch.i686 0:2.6.1-4.oc00
python-libxml2.i686 0:2.9.8-1.oc00 rpm-build.i686 0:4.13.0-17.oc00
tar.i686 2:1.23-7.oc00 xz.i686 0:5.2.3-2.oc00

Complete!
Process has been dumped

+++ "RC(1)"

At this point the ANPM database was unusable and ANPM failed with the message

YUM returned an error:

error: rpmdbNextIterator: skipping h# 269 region trailer: BAD, tag 1700881454 type 1886978148 offset -1970105721 count 1601464434

and an empty package list. As expected, invoking yum from the command line gave the same error message.

Attachments (4)

anpm.log (12.8 KB) - added by shmuel 2 months ago.
ANPM log of yum messages
transaction-done.2018-10-01.08.16.51 (1.7 KB) - added by shmuel 2 months ago.
yum.log (16.4 KB) - added by shmuel 2 months ago.
MIGRATEWPS.CMD (71.7 KB) - added by shmuel 2 months ago.
REXX script that generates long yum commands

Download all attachments as: .zip

Change History (12)

Changed 2 months ago by shmuel

ANPM log of yum messages

Changed 2 months ago by shmuel

Changed 2 months ago by shmuel

comment:1 Changed 2 months ago by shmuel

There are 11 process dumps; should I upload them?

comment:2 Changed 2 months ago by diver

  • Priority changed from major to Feedback Pending

did you issue the above command by hand from a cmdline? If yes did you do that from the root? or from a subdir?
As this looks similar to #252

The possible fix for you broken database is in Ticket #300.

Changed 2 months ago by shmuel

REXX script that generates long yum commands

comment:3 Changed 2 months ago by shmuel

The attached migratewps.cmd generated the initial yum command. I was probably running it from H:\utility; H is not the boot drive. In the meantime I've reinstalled ArcaOS 5.0.3 in a different partition and retained the copy on Q: in case you need for me to upload or test anything.

Would the process dumps help you to diagnose this?

Re #300, did you mean to delete /@unixroot/var/lib/rpm and then run "rpm --rebuilddb"?

comment:4 Changed 2 months ago by diver

start with comment 5 from #300. First try "yum clean all". If this doesn't help do what was suggested in comment 6 and 7

comment:5 Changed 2 months ago by shmuel

That gets rid of the error messages, but the list of installed packages is empty.

comment:6 Changed 2 months ago by diver

so it seems your only choice is to reinstall the rpm's.

comment:7 Changed 2 months ago by shmuel

Actually, I've already reinstalled ArcaOS in another partition; I only kept this one around in case you need something for problem analysis. My concern was preventing this from happening again.

Can I wipe out the old partition, or might you still need something from it? Thanks.

comment:8 Changed 2 months ago by diver

  • Resolution set to no change needed
  • Status changed from new to closed

no need for it, as the cause is unknown so far. If it happens again we might look into it.

Note: See TracTickets for help on using tickets.