Opened 3 years ago

Closed 17 months ago

#252 closed defect (fixed)

LIBC PANIC!! - LIBC fork: when 'yum install docbook*'

Reported by: Andib Owned by:
Priority: major Milestone:
Component: rpm Version:
Severity: low Keywords:
Cc:

Description

I thought this LIBC Panics are solved but...

I don't think the following problems are related to another ticket but sorry in case I overlooked matching ticket.

Here comes a lot of information I don't understand. But clearly something went wrong.

{1}[m:\] yum install docbook*
Einrichten des Installationsprozess
Löse Abhängigkeiten auf
--> Führe Transaktionsprüfung aus
---> Paket docbook-dtds.noarch 0:1.0-1.oc00 markiert, um installiert zu werden
--> Verarbeite Abhängigkeiten: xml-common für Paket: docbook-dtds-1.0-1.oc00.noar
ch
--> Verarbeite Abhängigkeiten: sgml-common für Paket: docbook-dtds-1.0-1.oc00.noa
rch
---> Paket docbook-style-xsl.noarch 0:1.79.2-1.oc00 markiert, um installiert zu w
erden
--> Führe Transaktionsprüfung aus
---> Paket sgml-common.noarch 0:0.6.3-45.oc00 markiert, um installiert zu werden
---> Paket xml-common.noarch 0:0.6.3-45.oc00 markiert, um installiert zu werden
--> Abhängigkeitsauflösung beendet

Abhängigkeiten aufgelöst

================================================================================
 Paket                  Arch        Version              Repository       Größe
================================================================================
Installieren:
 docbook-dtds           noarch      1.0-1.oc00           netlabs-rel      1.2 M
 docbook-style-xsl      noarch      1.79.2-1.oc00        netlabs-rel      2.3 M
Als Abhängigkeiten installiert:
 sgml-common            noarch      0.6.3-45.oc00        netlabs-rel       55 k
 xml-common             noarch      0.6.3-45.oc00        netlabs-rel       23 k

Vorgangsübersicht
================================================================================
Installieren     4 Packages

Gesamte Downloadgröße: 3.6 M
Installationsgröße: 3.6 M
Ist dies in Ordnung? [j/N] :j
Lade Pakete herunter:
(1/4): docbook-dtds- | 1.2 MB  00:06     ====-] 166 kB/s | 1.2 MB  00:00 ETA
(2/4): docbook-style | 2.3 MB  00:13     =====] 171 kB/s | 2.3 MB  00:00 ETA
(3/4): sgml-common-0 |  55 kB  00:00
(4/4): xml-common-0. |  23 kB  00:00
--------------------------------------------------------------------------------
Gesamt                                          178 kB/s | 3.6 MB     00:20
Running Transaction Check
Führe Verarbeitungstest durch
Verarbeitungstest erfolgreich
Führe Verarbeitung durch
Warnung: RPMDB wurde außerhalb von yum verändert.
** 1 bereits bestehende(s) rpmdb Problem(e) gefunden, 'yum check' gibt Folgendes
aus:
python-libs-2.7.6-14.oc00.i686 ist ein Duplikat von python-libs-2.7.6-14.oc00.i68
6
Error in PREIN scriptlet in rpm package xml-common-0.6.3-45.oc00.noarch
  Installieren : sgml-common-0.6.3-45.oc00.n [                            ] 2/4
LIBC PANIC!!
LIBC fork: Child aborting fork()! rc=0xfffffffe
pid=0x3185 ppid=0x314d tid=0x0001 slot=0x001c pri=0x0200 mc=0x0000 ps=0x0010
P:\USR\BIN\PYTHON2.7.EXE
Process dumping was disabled, use DUMPPROC / PROCDUMP to enable it.
  Installieren : sgml-common-0.6.3-45.oc00.noarch                           2/4
Error unpacking rpm package sgml-common-0.6.3-45.oc00.noarch
Fehler: xml-common-0.6.3-45.oc00.noarch: installieren fehlgeschlagen
Fehler: Entpacken des Archivs fehlgeschlagen bei Datei /@unixroot/etc/sgml/sgml.c
onf;590eff94: cpio: open
  Installieren : docbook-dtds-1.0-1.oc00.noarch                             3/4
Non-fatal POSTIN scriptlet failure in rpm package docbook-dtds-1.0-1.oc00.noarch

LIBC PANIC!!
LIBC fork: Child aborting fork()! rc=0xfffffffe
pid=0x3188 ppid=0x314d tid=0x0001 slot=0x0120 pri=0x0200 mc=0x0000 ps=0x0010
P:\USR\BIN\PYTHON2.7.EXE
Process dumping was disabled, use DUMPPROC / PROCDUMP to enable it.
  Installieren : docbook-style-xsl-1.79.2-1.oc00.noarch                     4/4
Non-fatal POSTIN scriptlet failure in rpm package docbook-style-xsl-1.79.2-1.oc00
.noarch

LIBC PANIC!!
LIBC fork: Child aborting fork()! rc=0xfffffffe
pid=0x3191 ppid=0x314d tid=0x0001 slot=0x0120 pri=0x0200 mc=0x0000 ps=0x0010
P:\USR\BIN\PYTHON2.7.EXE
Process dumping was disabled, use DUMPPROC / PROCDUMP to enable it.

Installiert:
  docbook-dtds.noarch 0:1.0-1.oc00   docbook-style-xsl.noarch 0:1.79.2-1.oc00

Fehlgeschlagen:
  sgml-common.noarch 0:0.6.3-45.oc00      xml-common.noarch 0:0.6.3-45.oc00

Komplett!

For the casual rpm user like me it's not clear if the whole thing is installed correctly as another 'yum install docbook*' says, or something went wrong - 'Fehlgeschlagen: sgml-common.....'. Of course I can reinstall sgml-common. But is this necessary?

The message 'python-libs-2.7.6-14.oc00.i686 ist ein Duplikat von python-libs-2.7.6-14.oc00.i686' does not sound very informative to me too.

Change History (6)

comment:1 Changed 3 years ago by Silvan Scherrer

unfortunately this is one of the issues we face from time to time. But we can't reproduce it. And "Fehlgeschlagen" means it's not completely installed, as some scriplets are not run. This might or might not hurt. All depends on the scriplet.

comment:2 Changed 3 years ago by Silvan Scherrer

please try to issue the command not on a root dir. I wonder if it makes a difference.
As I had this issue today as well when doing it on a root dir. If going to some subdir it worked.
It could give us some hints, when others see the same.

comment:3 Changed 3 years ago by Andib

Confirmed.

'yum reinstall docbook*' started from p:\ reproducible gives some LIBC PANIC!!
'yum reinstall docbook*' started from p:\etc\ --> no LIBC PANIC anymore.

Last edited 3 years ago by Andib (previous) (diff)

comment:4 Changed 3 years ago by Lewis Rosenthal

I'm working on updating the bootstrap (last build was 2016-06-10). Upon updating python, I'm seeing the same thing (when running yum from root), but in (or before) a postin scriptlet (same panic, though).

I can confirm that reinstalling while changed to \etc reinstalls properly, and other than warning of a failure removing a transaction file, the reinstallation succeeds (no panic).

comment:5 Changed 20 months ago by Lewis Rosenthal

comment:6 Changed 17 months ago by dmik

Resolution: fixed
Status: newclosed

This was a LIBC issue, fixed within https://github.com/bitwiseworks/libc/issues/31.

Note: See TracTickets for help on using tickets.