Opened 3 months ago

Closed 3 months ago

#315 closed defect (no change needed)

rpm-yum-bootstrap not working on OS/2 4.52

Reported by: rlange Owned by:
Priority: major Milestone:
Component: rpm Version:
Severity: low Keywords:
Cc:

Description

I have an ancient Pentium2 running OS/2 Warp CP2 4.52. It's running quite nicely and I'd like to get a few of the rpm packages (mostly cups) on it. I got cups working the manual (non-rpm) way but it was pretty kludgy, so I did a clean install and would like to do it the right way, if possible. Is this machine still a supported configuration? If not, then it should be clearly stated it's not. If so, then there's a technical or documentation problem.

Clean Warp 4.52 install. Added unzip and warpin 1.0.22. Tried:

warpin rpm-yum-bootstrap-1_5-i386.wpi

but WarpIN warned me that libc was required. I found and downloaded:

http://rpm.netlabs.org/release/00/zip/libc-0_6_6-37_oc00.zip

unpacked it to a temporary directory, and moved usr to \. I added the following to c:\config.sys and rebooted.

SET UNIXROOT=C:
Appended C:\usr\lib to LIBPATH
Appended C:\usr\bin to PATH
SET TMP=C:\tmp
SET TMPDIR=C:\tmp

Then I redid:

warpin rpm-yum-bootstrap-1_5-i386.wpi

and it succeeded in installing the bootstrap environment. I launched the yum bootstrap console, and it successfully downloaded the repolist packages and told me to run:

yum install yum

I did that and it spat out a tonne of errors like:

Error: Package: urpo-20150513-11.oc00.i386 (netlabs-rel)

Requires: libc >= 0.6.6

Error: Package: rpm-4.8.1-25.oc00.i386 (netlabs-rel)

Requires: libc066.dll

Error: Package: 2:mmap-0.5-1.oc00.i386 (netlabs-rel)

Requires: libc065.dll

I've cut out a tonne of similar errors, all involving libc. It seems every package that requires libc (pretty much all of them) failed.

I checked the repos manually, and there doesn't seem to be a libc rpm package for i386. Is what I did (use the zip version of libc) correct? (By the way, there are no other libcXXX.dll libraries on the system aside from the one installed by the yum bootstrap package and the one I installed manually in \usr from your zip.)

I also tried moving the LIBPATH for C:\usr\lib to the front of LIBPATH, rebooting, and trying again, but that made no difference.

I see that the bootstrap console uses:

BEGINLIBPATH=C:\tmp\yumbt\usr\lib;C:\usr\lib

I've checked both of those locations and the libcXXX.dll's are there in both locations. I'm not why yum/rpm isn't finding them...

Change History (3)

comment:1 Changed 3 months ago by diver

Unfortunately the bootstrap is very old and outdated. I suggest you use the ANPM way like described here http://trac.netlabs.org/rpm#Installation as variant 1.

comment:2 Changed 3 months ago by rlange

Thanks, using ANPM worked. I guess the docs should be updated to indicate that the old bootstrap isn't supported/likely to work anymore.

comment:3 Changed 3 months ago by diver

  • Resolution set to no change needed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.