Opened 4 months ago

Closed 4 months ago

Last modified 4 months ago

#310 closed defect (fixed)

Perl install reports missing depedency

Reported by: gyoung Owned by:
Priority: major Milestone:
Component: spec files Version:
Severity: low Keywords:
Cc:

Description

[u'ERROR with transaction check vs depsolve:', 'perl-Parse-CPAN-Meta is needed by perl-core-0:5.16.1-4.i686', 'perl(DBI) >= 1.57 is needed by perl-DBD-SQLite-1.58-2.oc00.i686', 'perl(DBI) is needed by perl-DBIx-Simple-1.37-1.oc00.noarch', u'Please report this error at http://trac.netlabs.org/rpm/']

It appears that perl-Parse-CPAN-Meta gets renamed as perl-CPAN-Meta when it is installed. It installs fine by itself but it isn't recognized by the other perl packages resulting in the error.

Change History (5)

comment:1 Changed 4 months ago by diver

http://trac.netlabs.org/rpm/browser/spec/trunk/SPECS/perl-CPAN-Meta.spec
needs a
Provides: perl-Parse-CPAN-Meta

as else it will not work. Lets hope @Elbert has time to look at it soon. As I don't have any atm.

comment:2 Changed 4 months ago by tellie

I add the provides and rebuild the package, please try it again.

comment:3 Changed 4 months ago by gyoung

It work this time. Thanks

comment:4 Changed 4 months ago by tellie

  • Resolution set to fixed
  • Status changed from new to closed

comment:5 Changed 4 months ago by tellie

Great, thankz for the feedback...

Note: See TracTickets for help on using tickets.