Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#163 closed defect (invalid)

qt-4.7.3 development environement not usable

Reported by: ak120 Owned by:
Priority: major Milestone:
Component: rpm Version:
Severity: low Keywords:
Cc:

Description

Installing all qt-4.7.3 from RPM packages via YUM will result in a non-working development environment. The QT readme mentions ftp://ftp.netlabs.org/pub/qt4/gcc-4_4_5-complete-20110303.zip thats not existing, so installing also gcc (which is of course 4.9.1) with yum. But when trying to build a small project from *.pro with qmake, make following happens all the time:

ilink.exe: No such file or directory

Then I also installed wl.exe from RPM but nothing changed in behaviour.

Change History (5)

comment:1 Changed 4 years ago by tomtom

You can find that specific zip-file in the tools subdirectory of the directory mentioned above: ftp://ftp.netlabs.org/pub/qt4/tools/gcc-4_4_5-complete-20110303.zip .

comment:2 Changed 4 years ago by ak120

So it's a documentation bug inside Qt's readme file. Should I remove gcc that was installed by RPM first?

comment:3 Changed 4 years ago by dmik

  • Resolution set to invalid
  • Status changed from new to closed

There are no bugs in the Qt readme — you should not mix manual ZIP installations with RPMs. Also, Qt4 RPMs work just fine with gcc RPM v4.9.2. Perhaps, you somehow killed the EMXOMFLD_ variables that the gcc-wlink and gcc-wrc RPM packages should have added to your CONFIG.SYS (or don't have these packages installed). The thing is that qt4-devel-kit doesn't automatically install gcc-wlink or gcc-wrc but that's not a bug because technically you may want to use ILINK instead of WLINK (however, this doesn't make any sense nowadays). Anyway, this is not a problem of Qt, this is a GCC thing. But ILINK is proprietary so I don't think we can make an RPM for it. We perhaps should install gcc-wlink and gcc-wrc by default whenever gcc is installed. I created #164 for that.

Last edited 4 years ago by dmik (previous) (diff)

comment:4 Changed 4 years ago by ak120

But even for zip installation the url for gcc should be changed inside the readme file. Or alternatively a note about usage of gcc 4.9.2? I installed gcc-wlink and gcc-wrc manually via YUM, but gcc still uses ILINK.EXE. My CONFIG.SYS contains:

SET EMXOMFLD_LINKER=wl.exe
SET EMXOMFLD_TYPE=WLINK
SET EMXOMFLD_RC=wrc.exe
SET EMXOMFLD_RC_TYPE=WRC

comment:5 Changed 4 years ago by dmik

The Qt package hasn't been updated for years. We will surely refresh the links once updated. Did you reboot after instilling these packages? Also make sure that you don't start gcc from an environment that overrides these variables with something else (or zeroes them out).

Note: See TracTickets for help on using tickets.