Opened 5 years ago

Closed 5 years ago

#84 closed defect (not a bug)

qpdfview-0_4_10-ga - crash when opening a .pdf or Settings dialog

Reported by: andib Owned by:
Priority: major Component: qpdfview
Version: Keywords:
Cc:

Description

popuplog.os2 entry -

05-31-2014  16:23:57  SYS2070  PID 7e6e  TID 0001  Slot 0175
T:\TEMP\QPDFVIEW-0_4_10-GA\QPDFVIEW.EXE
QPDFPDF->POPPQT44.__ZNK7Poppler8Document13textDirectionEv
127

My current v4.6 still works.

pmdll shows all dll loadable. All prerequisites available are installed via rpm. Others from zip as described.

Deleting Trolltech.ini does not help. Same with .config\pdfview.

qpdfview.exe >>log.txt 2>&1 writes nothing into log.txt

Is there still a dll missing which should be loaded when opening a pdf or Settings dialog?

Change History (2)

comment:1 Changed 5 years ago by andib

Problem solved - there was another poppqt44.dll on my system in libpath before.

Reasons why I didn't find this out the first try are the following -

1) Even with 'set libpathstrict=T'

set beginlibpath=.;

or

set beginlibpath=.

do not work as I expected. Although the correct dll is in current directory it will not be used. But

set beginlibpath=t:\temp\qpdfview-0_4_10-ga

(=current directory where all qpdfview4.10 files and dlls are) does work.

Don't know if this is a well known problem with beginlibpath. At least it's new for me.

2) Another interesting thing I discovered is if you once

set libpathstrict=T

it does not matter if you set afterwards

set libpathstrict=Y

or

set LIBPATHSTRICT=abcd

Libpathstrict is still honored until

set libpathstrict=

For completeness it does not matter if you use 'T' or 't'

Btw. wonders if it would be possible to name newer enhanced dlls with different names. Something like poppqt45.dll instead using the same name.

comment:2 Changed 5 years ago by diver

  • Resolution set to not a bug
  • Status changed from new to closed

ok good to know you solved it. About poppqtxy.dll: this dll name is changed as soon as it's not abi compatible anymore.

Note: See TracTickets for help on using tickets.