Opened 8 years ago

Last modified 4 years ago

#255 new defect

QtCreator ZIP lacks QML components

Reported by: rudi Owned by:
Priority: major Milestone: Qt 5
Component: General Version: 4.7.3
Severity: low Keywords:
Cc:

Description

The package ftp://ftp.netlabs.org/pub/qt4/qtcreator/qtcreator-2.2.1-1.zip is missing the QML components. Therefore it is not possible to run QMLDesigner. Also please consider

https://github.com/dmik/qt-creator-os2/issues/7

Here is a picture of the dialog on my machine without the fix suggested there...

http://telefon.s-t.de/rudi/creator_options.png

Change History (12)

comment:1 Changed 7 years ago by rudi

Ping...

Do we have a reason not to ship QML support with the Creator ZIP (I have not tested if it is present in RPM) ?

comment:2 Changed 7 years ago by dmik

I can't check it until 28.09, could you please be more specific about what is missing? RPM should be the same as ZIP, they are made from a single tree.

comment:3 Changed 7 years ago by rudi

Missing in action are:

/bin/qmlpuppet.exe
/lib/qmldesigner/
/lib/qmldesigner/extrapl.dll
/lib/qmldesigner/meegopl.dll
/lib/qmldesigner/symbnpl.dll
/lib/qtcreator/plugins/Nokia/QmlDesigner.pluginspec
/lib/qtcreator/plugins/Nokia/QmlDsgn.dll

as well as the matching *.sym files. It looks like the QML components were not delivered by purpose. What did you use to create the distribution ? I used:

SET BUILD_TREE=<my_qtc_build>
SET INSTALL_ROOT=<some_absolute_file_path>
rm -r %INSTALL_ROOT%
cmd /c "cd %BUILD_TREE% & make release-install install_qch_docs"

and it would copy all files except the license stuff.

Last edited 7 years ago by rudi (previous) (diff)

comment:4 Changed 7 years ago by dmik

  • Milestone changed from Qt Enhanced to Qt 4.next

I now see it. The QML part is not built by qtcreator.spec because private Qt headers are missing in the RPM distribution of Qt (which is used for building it). Once they are there (see #261), I will rebuild Qt Creator to fix this.

comment:5 Changed 7 years ago by rudi

Arrg. I saw that Creator is using some private stuff. But since I always compile my own Qt build, I never thought that this could be missing...

BTW, to me it pretty much looks like the repository at github has been abandoned by Nokia. There are no updates since august, while there is a lot activity on Gitorious... Could it be that it was a bad idea to move to github ?

comment:6 Changed 7 years ago by dmik

No-no, Nokia has nothing to do with github. It's my own clone. I took the bare Qt Creator repo from gitorious and pushed it to github. Under this scheme, your local repo has two remote ones: origin, pointing to github, and upstream, pointing to gitorious. When I want to pick up new changes from upstream, I have to do it locally and then push them to origin. This technique is described somewhere in github help. I will do this update soon, while working on Qt Creator 2.3 and Qt 4.7.4.

comment:7 Changed 7 years ago by rudi

Bummer. I always thought we are working in the Creator main repository and that we pick up their changes automatically !

BTW, my local clone doesn't seem to know about the "upstream" at gitorious, it only knows "origin". Do I have to add that manually ?

comment:8 Changed 7 years ago by dmik

Yes, you have to add all remotes (except the one you are cloning from) manually. This

git remote add upstream git://gitorious.org/qt-creator/qt-creator.git

should do that for your local Qt Creator clone AFAIR.

I chose github over gitorious because its web interface is much more powerful and also because it has the issue tracker (and paid private repos which we will need later).

Later, when we are about to merge to upstream, we will create a clone of Qt Creator at gitorious which will become upstream and push our patches there so that Qt guys could easily pick them up within their gitorious merge request environment.

Last edited 7 years ago by dmik (previous) (diff)

comment:9 Changed 7 years ago by rudi

I tried to update my Creator sources to 2.3.1. It went surprisingly well ! I'm starting to like Git... There are a few conflicts that have to be resolved manually, but nothing big as it seems. I did it in less than an hour. Can't test it though, because Qt 3.7.4 is required to build this version of Creator ;-).

Why would we later need paid private repositories ?

comment:10 Changed 7 years ago by dmik

Good. What did you merge where, BTW?

Re paid services, because we want some repos to be private rather than public. And because there is some space limit on free accounts.

comment:11 Changed 7 years ago by rudi

I added the remote repo as you wrote. Then I ran:

git fetch upstream
git merge upstream/master

Then I created a new branch from the tag "v2.3.1".

git checkout -b 2.3-os2-test v2.3.1

And merged our changes

git merge 2.2-os2

I got about 15 conflicts. Two plugins have been removed. Some changes in the doc building process. The part that needed some more attention was the console process handling. Due to some restructuring the class "AbstractProcess?" has been removed and our extensions had to be moved to the OS/2 specific part of the "ConsoleProcess?" class. There were also some conflicts in "abi.h" due to the fact that they added an "unknown" platform.

comment:12 Changed 4 years ago by diver

  • Milestone changed from Qt 4.next to Qt 5

Milestone renamed

Note: See TracTickets for help on using tickets.