Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#256 closed defect (fixed)

Unable to install qt4-devel-kit or qt4-demos packages using YUM

Reported by: sev0600 Owned by:
Priority: major Milestone: Qt Enhanced
Component: General Version: 4.7.3
Severity: high Keywords:
Cc:

Description

I have been unable to install the latest QT4 4.7.3 package using YUM.

Actions Taken:

  • yum update
  • yum remove '*qt4*'


Here are the results from YUM...

[U:\]yum install qt4-devel-kit
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package qt4-devel-kit.i386 0:4.7.3-1 set to be updated
--> Processing Dependency: qt4-demos = 4.7.3-1 for package: qt4-devel-kit-4.7.3-
1.i386
--> Processing Dependency: qt4-doc = 4.7.3-1 for package: qt4-devel-kit-4.7.3-1.
i386
--> Processing Dependency: libqt4-webkit-devel = 4.7.3-1 for package: qt4-devel-
kit-4.7.3-1.i386
--> Processing Dependency: libqt4-devel = 4.7.3-1 for package: qt4-devel-kit-4.7
.3-1.i386
--> Processing Dependency: qt4-designer = 4.7.3-1 for package: qt4-devel-kit-4.7
.3-1.i386
--> Processing Dependency: qt4-qmlviewer = 4.7.3-1 for package: qt4-devel-kit-4.
7.3-1.i386
--> Processing Dependency: qt4-linguist = 4.7.3-1 for package: qt4-devel-kit-4.7
.3-1.i386
--> Processing Dependency: qt4-assistant = 4.7.3-1 for package: qt4-devel-kit-4.
7.3-1.i386
--> Processing Dependency: qt4-devel-tools = 4.7.3-1 for package: qt4-devel-kit-
4.7.3-1.i386
--> Running transaction check
---> Package libqt4-devel.i386 0:4.7.3-1 set to be updated
--> Processing Dependency: libqt4-gui = 4.7.3-1 for package: libqt4-devel-4.7.3-
1.i386
--> Processing Dependency: qtxml4.dll for package: libqt4-devel-4.7.3-1.i386
--> Processing Dependency: qtcore4.dll for package: libqt4-devel-4.7.3-1.i386
---> Package libqt4-webkit-devel.i386 0:4.7.3-1 set to be updated
--> Processing Dependency: libqt4-webkit = 4.7.3-1 for package: libqt4-webkit-de
vel-4.7.3-1.i386
---> Package qt4-assistant.i386 0:4.7.3-1 set to be updated
---> Package qt4-demos.i386 0:4.7.3-1 set to be updated
--> Processing Dependency: qt4-doc = 4.7.3-1 for package: qt4-demos-4.7.3-1.i386

--> Processing Dependency: libqt4-designer = 4.7.3-1 for package: qt4-demos-4.7.
3-1.i386
--> Processing Dependency: qtdsgn4.dll for package: qt4-demos-4.7.3-1.i386
---> Package qt4-designer.i386 0:4.7.3-1 set to be updated
---> Package qt4-devel-kit.i386 0:4.7.3-1 set to be updated
--> Processing Dependency: qt4-doc = 4.7.3-1 for package: qt4-devel-kit-4.7.3-1.
i386
---> Package qt4-devel-tools.i386 0:4.7.3-1 set to be updated
---> Package qt4-linguist.i386 0:4.7.3-1 set to be updated
---> Package qt4-qmlviewer.i386 0:4.7.3-1 set to be updated
--> Running transaction check
---> Package libqt4.i386 0:4.7.3-1 set to be updated
---> Package libqt4-designer.i386 0:4.7.3-1 set to be updated
---> Package libqt4-gui.i386 0:4.7.3-1 set to be updated
---> Package libqt4-webkit.i386 0:4.7.3-1 set to be updated
---> Package qt4-demos.i386 0:4.7.3-1 set to be updated
--> Processing Dependency: qt4-doc = 4.7.3-1 for package: qt4-demos-4.7.3-1.i386

---> Package qt4-devel-kit.i386 0:4.7.3-1 set to be updated
--> Processing Dependency: qt4-doc = 4.7.3-1 for package: qt4-devel-kit-4.7.3-1.
i386
--> Finished Dependency Resolution
Error: Package: qt4-demos-4.7.3-1.i386 (netlabs-rel)

Requires: qt4-doc = 4.7.3-1
Available: qt-doc-4.6.3-1.noarch (netlabs-rel)

Error: Package: qt4-devel-kit-4.7.3-1.i386 (netlabs-rel)

Requires: qt4-doc = 4.7.3-1
Available: qt-doc-4.6.3-1.noarch (netlabs-rel)

You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

[U:\]yum install qt4-demos
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package qt4-demos.i386 0:4.7.3-1 set to be updated
--> Processing Dependency: qt4-doc = 4.7.3-1 for package: qt4-demos-4.7.3-1.i386

--> Processing Dependency: libqt4-designer = 4.7.3-1 for package: qt4-demos-4.7.
3-1.i386
--> Processing Dependency: libqt4-webkit = 4.7.3-1 for package: qt4-demos-4.7.3-
1.i386
--> Processing Dependency: libqt4-gui = 4.7.3-1 for package: qt4-demos-4.7.3-1.i
386
--> Processing Dependency: qtscri4.dll for package: qt4-demos-4.7.3-1.i386
--> Processing Dependency: qttest4.dll for package: qt4-demos-4.7.3-1.i386
--> Processing Dependency: qtgui4.dll for package: qt4-demos-4.7.3-1.i386
--> Processing Dependency: qtcore4.dll for package: qt4-demos-4.7.3-1.i386
--> Processing Dependency: qtnet4.dll for package: qt4-demos-4.7.3-1.i386
--> Processing Dependency: qtdecl4.dll for package: qt4-demos-4.7.3-1.i386
--> Processing Dependency: qtdsgn4.dll for package: qt4-demos-4.7.3-1.i386
--> Processing Dependency: qtsvg4.dll for package: qt4-demos-4.7.3-1.i386
--> Running transaction check
---> Package libqt4.i386 0:4.7.3-1 set to be updated
---> Package libqt4-designer.i386 0:4.7.3-1 set to be updated
---> Package libqt4-gui.i386 0:4.7.3-1 set to be updated
---> Package libqt4-webkit.i386 0:4.7.3-1 set to be updated
---> Package qt4-demos.i386 0:4.7.3-1 set to be updated
--> Processing Dependency: qt4-doc = 4.7.3-1 for package: qt4-demos-4.7.3-1.i386

--> Finished Dependency Resolution
Error: Package: qt4-demos-4.7.3-1.i386 (netlabs-rel)

Requires: qt4-doc = 4.7.3-1
Available: qt-doc-4.6.3-1.noarch (netlabs-rel)

You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Change History (3)

comment:1 Changed 8 years ago by David McKenna

It looks like the 'qt4-doc' file is mis-named in the netlabs-rel/noarch repository. If you want, as a workaround you can add the 'exp' repository (yum install netlabs-exp) then re-try installing qt4-demos and qt4-devel-kit. Afterwards, if you aren't interested in experimental RPM's, type 'yum remove netlabs-exp'.

comment:2 Changed 8 years ago by dmik

  • Resolution set to fixed
  • Status changed from new to closed

It was simply a missing file issue. The file is now copied from netlabs-exp to netlabs-rel so the problem should have gone.

comment:3 Changed 8 years ago by dmik

Thank you for reporting and feel free to report any other installation issues if you face them.

Note: See TracTickets for help on using tickets.