Opened 14 years ago

Closed 14 years ago

#17 closed defect (invalid)

LIBC PANIC!!

Reported by: abwillis1@… Owned by: bird
Priority: normal Milestone:
Component: libc Version: 0.6
Severity: normal Keywords: panic
Cc:

Description

Building coreutils fails under gcc 3.3.5ga2, worked in RC1. chmod +x groups-t chmod: fts_read failed: Function not implemented

LIBC PANIC!! _um_free_maybe_lock: Tried to free block twice - block=20035180 lock=0x1 pid=0x17b6 ppid=0x1351 tid=0x0001 slot=0x00c5 pri=0x0200 mc=0x0000 E:\CVS\WORK\COREUTILS-5.2.1\SRC\CHMOD.EXE Process have been dumped

Change History (3)

comment:1 Changed 14 years ago by anonymous

[e:\cvs\work\coreutils-5.2.1\src]chmod +x groups-t chmod.exe: fts_read failed: Function not implemented

Killed by SIGSEGV pid=0x17b9 ppid=0x0082 tid=0x0001 slot=0x0097 pri=0x0200 mc=0x0001 E:\CVS\WORK\COREUTILS-5.2.1\SRC\CHMOD.EXE CHMOD 0:00002797 cs:eip=005b:00012797 ss:esp=0053:0011fed0 ebp=0011fef8

ds=0053 es=0053 fs=150b gs=0000 efl=00012246

eax=00000000 ebx=732f6c61 ecx=1bff0002 edx=2003013c edi=00000000 esi=2003ac20 Process have been dumped

comment:2 Changed 14 years ago by bird

The error has nothing to do with libc. "Tried to free block twice" means that the application did free() twice (or more) on the same memory block. I've seen this particular problem myself and I *think* I managed to fix it by doing something in coreutils. exactly what that was escapes me now.

It would be interesting to know if this worked with a previous libc build. It could be caused by some fts detection stuff.

comment:3 Changed 14 years ago by anonymous

  • Resolution set to invalid
  • Status changed from new to closed

Worked previously and after running configure it now works again. The error looked familiar here to but I don't remember any details from the previous time.

Note: See TracTickets for help on using tickets.