Opened 14 years ago

Closed 14 years ago

#15 closed defect (fixed)

Duplicate definition of setkey

Reported by: paul@… Owned by: bird
Priority: high Milestone: libc-0.6
Component: libc Version: 0.6
Severity: critical Keywords: crypt setkey
Cc:

Description

When building Apache2 with Innotek GCC 3.3.5R1 & also latest cvs, following error appears: In file included from apr_md5.c:73: U:/CVSUSR/include/unistd.h:542: error: conflicting types for `setkey' U:/CVSUSR/include/crypt.h:41: error: previous declaration of `setkey'

Easily resolved by only including one of the headers, but guess could be fixed in the headers themselves with some 'ifndef setkey' statements...

Change History (1)

comment:1 Changed 14 years ago by bird

  • Component changed from emx to libc
  • Keywords crypt setkey added
  • Milestone set to libc-0.6
  • Priority changed from normal to high
  • Resolution set to fixed
  • Severity changed from normal to critical
  • Status changed from new to closed

the problem is simply differente return type in the BSD header (unistd.h). I've changed it to conform to the implementation we're using (glibc) and the standard. (This just barely made it into the 0.6ga build here.

Note: See TracTickets for help on using tickets.