Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#205 closed defect (fixed)

Desktop on Call crashes browser and then graphicall corrupts the PMSHELL.

Reported by: ecsnl Owned by:
Priority: major Milestone: GA5
Component: general Version: 1.6.0 Build 27 GA4
Severity: medium Keywords:
Cc:

Description

This is *possibly* the same problem as ticket #200.

With the internal eCS 2.2 beta's that install ODIN via RPM and the latest JAVA I get a graphically corrupted PMSHELL. I need to reboot.

The problem does not go away by dragging for example an open folder over the desktop.

What happens is that Desktop On Call works. In the browser you see the login window loaded. Then when the you type in the password and userid normaly a new browser window is loaded that displays the remote desktop. This is where the crash occurs.

In some cases the java.exe does not crash by it. But if I go into TOP and kill it the same corruption occurs.

I will privately send a link where a desktop on call workstation is open so you guys can test this!

Attachments (1)

dtoc_java_crash.JPG (94.6 KB) - added by ecsnl 6 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 6 years ago by ecsnl

I ran some more tests. Not in all cases is the result the same.

Previous tests I had a crashed java.exe and then PM was hoozed at once (needed a reboot).
In some cases the browser dropped out and I'm not certain but I seem to remember that the PMSHELL access was locked.

If I then hit C-A-D and killed the java.exe process that was started by Firefox the PM got corrupted.

Attached is a screenshot of what happens. Its a bit blurry but if you look at the ecenter you see the CPU going up a lot. The weird thing is that firefox and java.exe are no longer in the task list (also can not be seen with TOP.EXE). Something in PM I guess during the crash is being corrupted.

I will also give you guys access to the current eCS 2.2 ISO so you can test with it.

Don't know if that is a Panorama issue.

If I get a crash I get this for example:

02-05-2013 14:46:35 SYS3175 PID 005d TID 000e Slot 00af
I:\PROGRAMS\OPENJDK6\BIN\JAVA.EXE
c0000005
1ffca32a
P1=00000008 P2=0000a2ec P3=XXXXXXXX P4=XXXXXXXX
EAX=03e5ecc4 EBX=00000000 ECX=1ffca2ee EDX=21150000
ESI=03e5f654 EDI=1417e680
DS=0053 DSACC=d0f3 DSLIM=5fffffff
ES=0053 ESACC=d0f3 ESLIM=5fffffff
FS=150b FSACC=00f3 FSLIM=00000030
GS=0000 GSACC= GSLIM=
CS:EIP=005b:1ffca32a CSACC=d0df CSLIM=5fffffff
SS:ESP=0053:03e5ec94 SSACC=d0f3 SSLIM=5fffffff
EBP=03e5ecbc FLG=00010217

DOSCALL1.DLL 0002:0000a32a

Changed 6 years ago by ecsnl

comment:2 Changed 6 years ago by ecsnl

I don't know if it matters that I start Firefox.exe with run!.exe. Don't know...

comment:3 Changed 6 years ago by dmik

I get something similar. Right after login firefox crashes and PM gets unresponsive (mouse moves but I can't activate windows, can't type in them etc).

POPUPLOG.OS2 contains some nonsense in my case (though the crash is in JAVA.EXE too) but I get the following to the console:

Killed by SIGABRT
pid=0x007d ppid=0x0020 tid=0x0016 slot=0x00cb pri=0x0200 mc=0x0001
C:\PROGRAMS\FIREFOX10\FIREFOX.EXE
Process dumping was disabled, use DUMPPROC / PROCDUMP to enable it.
#
# A fatal error has been detected by the Java Runtime Environment:
#
#  EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x1cfe5d1e, pid=127, tid=8323088
#
# JRE version: 6.0_27
# Java VM: OpenJDK Client VM (20.0-b12 mixed mode os2-x86 )
# Problematic frame:
# C  [USER32+0x15d1e]
#
# An error report file with more information is saved as:
# C:\PROGRAMS\firefox10\hs_err_pid127.log

I will check this.

comment:4 Changed 6 years ago by dmik

Getting various crashes here but all in USER32.DLL. Once got an assertion in Mozilla code, in jsapi.cpp, line #6365, this is JS_AbortIfWrongThread(JSRuntime *rt). So somehow plugin ends on a wrong thread.

Debugging is quite complicated because I have to reboot OS/2 after almost every test run as it corrupts PM somehow.

comment:5 follow-up: Changed 6 years ago by dmik

It is VERY bad that I can't debug Mozilla itself... (The first thing I will do when switching to the Mozilla task is make it build with KMK and fix the debug build).

comment:6 Changed 6 years ago by dmik

  • Milestone changed from Enhanced to GA5

I got an idea to try a new release of Icedtea-web to see if it helps here. The latest release of icedtea-web is 1.3 (http://icedtea.classpath.org/wiki/IcedTea-Web#IcedTea-Web_1.3).

comment:7 Changed 6 years ago by dmik

  • Resolution set to fixed
  • Status changed from new to closed

I successfully updated IcedTea?-Web to version 1.3 and I must say that my assumption worked. It was a plugin problem indeed -- it called the browser function on a wrong thread indeed.

I can now successfully navigate through the remote desktop at the server Roderick gave me access to.

Last edited 6 years ago by dmik (previous) (diff)

comment:8 in reply to: ↑ 5 Changed 6 years ago by dryeo

Replying to dmik:

It is VERY bad that I can't debug Mozilla itself... (The first thing I will do when switching to the Mozilla task is make it build with KMK and fix the debug build).

There is a debug-symbol build of FF 10.0.12 on Netlabs, it crashes if started in a debugger but runs fine if you attach to it with the JIT debugger.
Debug builds fail due to xul.dll object being over 32 MBs.

Note: See TracTickets for help on using tickets.