Opened 6 years ago

Closed 6 years ago

#206 closed defect (fixed)

java.awt.print failes

Reported by: gap Owned by:
Priority: major Milestone: GA5
Component: general Version: 1.6.0 Build 27 GA4
Severity: medium Keywords:
Cc:

Description

The java.awt.print fails in Java 1.6 (B27) but works in earlier versions.

Attachments (1)

printing_test.zip (7.2 KB) - added by gap 6 years ago.
complete printing test with source

Download all attachments as: .zip

Change History (3)

Changed 6 years ago by gap

complete printing test with source

comment:1 Changed 6 years ago by dmik

Thanks for the test case! I can confirm it doesn't work.

The only working combination is Odin 0.7.1 + Java 1.6 GA and GA 2.

Odin 0.8.8 + all Javas crashes at the same location: WGSS50+0x9a07, exception 0xC0000005 when writing to some high memory area (e.g. 0x00841000).

Odin 0.8.7 + Java 1.6 GA gives something different: terminate called after throwing an instance of 'std::bad_alloc'. This usually means a failure of the new C++ operation to allocate memory.

All this tells us that this is another regression of the Odin switch to GCC. I guess we need to sort it out now.

comment:2 Changed 6 years ago by dmik

  • Milestone changed from Enhanced to GA5
  • Resolution set to fixed
  • Status changed from new to closed

This was fixed within http://svn.netlabs.org/odin32/ticket/84. The test case now works fine. It was indeed an Odin regression (the older version of Odin worked just by accident because the internal code didn't analyze all the fields of some structure).

Thanks again for the test case, it helped a lot.

Note: See TracTickets for help on using tickets.