Opened 8 years ago

Closed 6 years ago

#11 closed defect (fixed)

ahci unable to operate T410

Reported by: abwillis Owned by: cjm
Priority: major Milestone:
Component: driver Version:
Keywords: Cc:

Description

Same type issue as ticket #9 http://svn.ecomstation.nl/ahci/ticket/9
Enable AHCI in the BIOS results in the same message as the picture there has:
OS/2 is unable to operate your hard disk or diskette drive,
The system is stopped. Correct the preceding error and restart the system.
This was true with the version that shipped with eCS 2.1 (1.12) as well as with 1.19 that I built from SVN. I will also attach a diff I tried too, but it did not help.

Attachments (1)

AHCI2.TXT (3.8 KB) - added by abwillis 7 years ago.
debug log file

Download all attachments as: .zip

Change History (24)

comment:1 Changed 8 years ago by abwillis

Index: src/os2ahci/pci.c
===================================================================
--- src/os2ahci/pci.c	(revision 124)
+++ src/os2ahci/pci.c	(working copy)
@@ -234,6 +234,8 @@
   { PCI_VDEVICE(INTEL, 0x3b29), board_ahci,            chip_pchahci }, /* PCH AHCI */
   { PCI_VDEVICE(INTEL, 0x3b2b), board_ahci,            chip_pchraid }, /* PCH RAID */
   { PCI_VDEVICE(INTEL, 0x3b2c), board_ahci,            chip_pchraid }, /* PCH RAID */
+  { PCI_VDEVICE(INTEL, 0x3b2d), board_ahci,            chip_pchahci }, /* PCH AHCI */
+  { PCI_VDEVICE(INTEL, 0x3b2e), board_ahci,            chip_pchahci }, /* PCH AHCI */
   { PCI_VDEVICE(INTEL, 0x3b2f), board_ahci,            chip_pchahci }, /* PCH AHCI */
 
   /* JMicron 360/1/3/5/6, match class to avoid IDE function */

comment:2 Changed 8 years ago by abwillis

PCI output:

Bus 0 (PCI Express), Device Number 31, Device Function 2
Vendor 8086h Intel Corporation
Device 3B2Eh 5 Series/3400 Series Chipset 4 port SATA IDE Controller
Command 0007h (I/O Access, Memory Access, BusMaster?)
Status 02B0h (Has Capabilities List, Supports 66MHz,

Supports Back-To-Back Trans., Medium Timing)

Revision 06h, Header Type 00h, Bus Latency Timer 00h
Self test 00h (Self test not supported)
PCI Class Storage, type IDE (ATA)
PCI EIDE Controller Features :

BusMaster? EIDE is supported
Primary Channel is at I/O Port 01F0h and IRQ 14
Secondary Channel is at I/O Port 0170h and IRQ 15

Subsystem ID 216917AAh Unknown
Subsystem Vendor 17AAh Lenovo
Address 0 is an I/O Port : 0000h (unconfigured)
Address 1 is an I/O Port : 0000h (unconfigured)
Address 2 is an I/O Port : 0000h (unconfigured)
Address 3 is an I/O Port : 0000h (unconfigured)
Address 4 is an I/O Port : 1840h..1847h
Address 5 is an I/O Port : 1810h..181Fh
System IRQ (disabled), INT# B
New Capabilities List Present:

Power Management Capability, Version 1.2

Does not support low power State D1 or D2
Does not support PME# signalling
Current Power State : D0 (Device operational, no power saving)

Unknown Capability (Code 13h)!!

Bus 0 (PCI Express), Device Number 31, Device Function 5
Vendor 8086h Intel Corporation
Device 3B2Dh 5 Series/3400 Series Chipset 2 port SATA IDE Controller
Command 0005h (I/O Access, BusMaster?)
Status 02B0h (Has Capabilities List, Supports 66MHz,

Supports Back-To-Back Trans., Medium Timing)

Revision 06h, Header Type 00h, Bus Latency Timer 00h
Self test 00h (Self test not supported)
PCI Class Storage, type IDE (ATA)
PCI EIDE Controller Features :

BusMaster? EIDE is supported
Primary Channel is in native mode at Addresses 0 & 1
Secondary Channel is in native mode at Addresses 2 & 3

Subsystem ID 216A17AAh Unknown
Subsystem Vendor 17AAh Lenovo
Address 0 is an I/O Port : 18A0h
Address 1 is an I/O Port : 1894h
Address 2 is an I/O Port : 1898h
Address 3 is an I/O Port : 1890h
Address 4 is an I/O Port : 1880h
Address 5 is an I/O Port : 1850h
System IRQ 11, INT# C
New Capabilities List Present:

Power Management Capability, Version 1.2

Does not support low power State D1 or D2
Does not support PME# signalling
Current Power State : D0 (Device operational, no power saving)

Unknown Capability (Code 13h)!!

comment:3 Changed 8 years ago by abwillis

Tried no parameters, tried with /s /r, tried with /r /!t.

comment:4 Changed 8 years ago by abwillis

Sorry, T410 was supposed to be written out as Thinkpad T410 but forgot to get that typed.

comment:5 Changed 8 years ago by cjm

Does the T410 have a serial COM port and do you have a serial null modem cable which you could hook up to another computer with a terminal program to get boot-time debug output? If yes, please add the command line parameter "/d /d" to OS2AHCI.ADD, start a terminal program on the other computer with 9600 baud, no flow control, and send us the resulting debug log.

If this is no option, please let us know and we'll think of something else.

Thanks,
--Christian

comment:6 Changed 8 years ago by cjm

  • Owner changed from somebody to cjm
  • Status changed from new to accepted

comment:7 Changed 8 years ago by abwillis

The Thinkpad T410 only has a COM port with a dock and I do not have a dock for that model.

Last edited 8 years ago by abwillis (previous) (diff)

comment:8 Changed 8 years ago by abwillis

I am not sure now if this model even has a serial option at all... I was able to get hold of a port replicator that fits it but it did not have serial port on it like the ones up to the T400 did.

comment:9 Changed 8 years ago by cjm

Hmmm... this problem happens so early in the boot process that serial debugging is about the only thing that will really work. I've been thinking about adding a hack which takes over the VGA screen buffer to display debug information but the amount of information required would not fit on a single screen, thus it would be necessary to add some kind of paging control via keyboard as well.

Let me first check the option of getting my hands on a T410 and adding a [miniPCI] serial card to it for debugging purposes. This might take a while, though -- I hope all this is not urgent. I am determined to find out why OS2AHCI doesn't work on mobile ICH8 chipsets...

Thanks,
--Christian

comment:10 Changed 8 years ago by abwillis

No rush for me... the system is one at work I have installed to for testing. I could end up needing to issue the system to someone else but at some point I should be able to get another if that did occur.

comment:11 Changed 8 years ago by dgbisse

I would point out that I have been using OS2AHCI (as came with eCS 2.1) for some time, on my Lenovo ThinkPad? T510 (4313-CTO), with no trouble. I use the parameters "/r /s /n". The updated AHCI 1.22 also works good (about 4 hours now). AFAIK, the T410 is the same machine, with a smaller screen. You do need to switch the SATA mode in the BIOS.

comment:12 Changed 7 years ago by markus.thi

@abwillis: can you give it another try with the current version (1.22)?

Thanks
Markus

comment:13 Changed 7 years ago by abwillis

I tried 1.22 from built from SVN 2011/10/14
I haven't seen any changes since then in SVN.
I tried combinations of /r/s/n to no avail.
I lost access to the machine I had been using, it could be some weeks before I have another available.

comment:14 Changed 7 years ago by abwillis

Interesting that it is working on the T510 for Doug as I now had the chance to try on a W510 and it is not working on it.
Where the T410 was 8086:3B2E the W510 is 8086:3B2D.
I tried combinations of /!t /r /s /n /f and no parameters.
In compatibility mode it boots fine with Danis506 but as soon as it is switched to SATA mode it stops the same way as the T410.
Using current svn 1.23.
I also tried /g:8086:3B2D but my build does have the patch from above with it defined.

comment:15 Changed 7 years ago by abwillis

I pulled the drive from a T410 where it doesn't work and put it into a T420 and it does work there.

comment:16 Changed 7 years ago by abwillis

I've determined that the patch above is useless or worse. In order to run pci.exe I had to put the system into compatibility mode which I've now realized causes pci.exe to report a different number than it would if in Sata mode.
I determined this when I found yet another machine I am having problems with. The Thinkpad W500. I took the drive out of a Thinkpad Z61M where the OS2AHCI driver was working fine. In the W500 I get the same OS/2 is unable to operate your hard disk or diskette drive that I get in the T410 and W510.
I had run the pci.exe when booted via compatibility and found 8086:2928 which was not in the list. Adding it, of course, did not help. I realized I had never noticed the /d /d /d options and added those and found that with either /t or /!t (just takes longer in the former case) it says:
Found AHCI ICH9M 8086:2929
class 0x010601
bus:0 devfunc:0xfa

8086:2929 is in the list so it is not a function of not being found as I had initially thought. One advantage, the dock for the W500 does have a serial port so I will try to debug it.

Changed 7 years ago by abwillis

debug log file

comment:17 Changed 7 years ago by abwillis

This log file is with the following parameters:

/n /f /s /d /d

/r showed the same data
/!t is not likely to show differently as both show with /v that it found the the 8086:2929
For this issue, I found that there was very little difference if I had the retail kernel or the debug kernel... it shows the error I get in the log with the debug kernel being the only difference.

comment:18 Changed 7 years ago by markus.thi

Thanks a lot, your help is most appreciated!
We will look into this soon - we're just too busy at the moment...

Thanks again
Markus

comment:19 Changed 7 years ago by abwillis

Just to an an update... I saw that a message about "unable to operate" was fixed in air-boot. It was related to HPFS and I am running JFS but decided to test it just on the off chance it would help. As I had anticipated, it did not make a difference.

comment:20 Changed 7 years ago by abwillis

With the newly issued eCS Demo 2.2 CD I verified the problem exists with it on the same hardware that existed with my normal installation. When booting with the eCS Demo CD it is unable to find the CD during the boot process if the BIOS has the AHCI set instead of legacy.

comment:21 Changed 7 years ago by abwillis

Once the svn is updated this issue may be resolved.
Downloaded the eCS 2.2 beta and the W500 is now able to boot off of the DVD in AHCI mode and can see the HDD and LVM sees the partitions. I then copied os2ahci.add from the DVD to the harddrive and it boots fine now.
However, the "may be resolved" is because in the T410 and W510 there is an issue that may be still in os2ahci.add or it may be in lvm. They are able to boot from the DVD, however, a HDD that had a test installation of eCS 2.1 on it was seen as having a problem by the disk integrity check. I went ahead and tried to let it fix it but it kept saying it had a problem. I finally tried wiping the full MBR and it still had a problem. I finally put it in compatibility mode and used LVM to create a partition. Then back in AHCI it still saw the problem but was then able to correct it. However, then LVM will not launch due to errors. Booting to maintenance mode and trying to launch LVM I can check the popuplog.os2 and see errors from minilvm in it. So I do not know for sure if it is an error in LVM or if there is something wrong still in os2ahci.add.

comment:22 Changed 7 years ago by dazarewicz

Actually, the problem described in this ticket was resolved in version 1.26. A new ticket should be opened for a new problem. I will attempt to reproduce the new problem described and wait for a new ticket to be opened.

comment:23 Changed 6 years ago by dazarewicz

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.