Opened 6 years ago

Closed 6 years ago

#577 closed defect (duplicate)

Resume hangs

Reported by: mst Owned by: dazarewicz
Priority: minor Milestone: Release 4.00
Component: Suspend-Resume Version: 3.21.07
Keywords: Resume Cc:

Description

My system with ASUS M2N board and ACPI.PSD without switches. It hangs undefined at boot or even the WPS is half loaded. Always hard reset is needed.

With /PIC switch all works fine but only with one of two cores enabled.

With /VW switch system boots sometimes with SBLIVE drivers error message "SBLIVE hardware not detected". Also is the system unstable and freezes undefined while working. I assume its related to a ACPI<->SBLIVE driver problem. One time I have seen a trap screen "Trap in SBLIVE". The SBLIVE card uses IRQ10. No change since version 3.21.04

My older setup with ACPI 3.17 and a patched kernel from www.os4.su SVN1313 worked very stable.

Attachments (3)

config.sys (7.8 KB) - added by mst 6 years ago.
acpid.cfg (2.6 KB) - added by mst 6 years ago.
OBEN-20130221-acpi-3.21.07.zip (62.9 KB) - added by mst 6 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 6 years ago by dazarewicz

  • Milestone changed from Release Version 4.0.0 to Feedback pending

You have not provided any information with which to help you resolve your issue. You must provide some specific details about what happens, and some logs, and probably your CONFIG.SYS. Please see http://svn.netlabs.org/acpi/wiki/Requirements

Also, the SBLIVE driver is known to be buggy and known to cause the type of problems you are reporting. Please remove this driver until you get the system booting properly.

comment:2 Changed 6 years ago by mst

I have tested my two systems a lot of days now without the SBLIVE driver. Now with the Uniaud driver (poor performance, no sound sharing possible) all runs stable.

ACPI.PSD without switches runs fine ACPI.PSD /VW also OK. ACPI.PSD /PIC runs with singe core OK.

But suspend/resume is the same like ticket #565. Pressing the Space key starts the HD, screen remains black (Snap driver, ATI X600) and I hear one beep. Keyboard seems to be powered off. CAD doesn't word, LED's are still all off, no change while pressing NUM or CAPSLOCK. Hard reset required.

Changed 6 years ago by mst

Changed 6 years ago by mst

comment:3 Changed 6 years ago by dazarewicz

I suspected your problems were caused by the SBLIVE driver since the symptoms were exactly what would be caused by the known bugs in that driver.

Regarding resume, please read the "Suspend / Resume" section at: http://svn.netlabs.org/acpi/wiki/Requirements and the "Suspend and Resume" section of the PSD_EN.INF documentation included in the ACPI package for instructions on how to debug resume.

comment:4 Changed 6 years ago by mst

I have installed the acpi debug version. Suspend startet with the acpistat suspend command. After pressing a key resume beginns. I see the keyboard LED's flickering, but this is to fast to see a sequence. All LED's are finally on. I hear the four beeps with rising frequency, immediately followed by a lower beep. After a minute I hear an other beep. No more system reaction. I collected a acpi log while system runs normally. But how collect a log while resuming? I have no idea.

Changed 6 years ago by mst

comment:5 Changed 6 years ago by dazarewicz

  • Milestone changed from Feedback pending to Release Version 4.0.0

Since you hear the 4 tones, that means that the PSD has finished resuming the system and is working correctly. My suggestion is to try and find out which driver is causing your problems. If you can identify specifically which driver is not working, then perhaps I can suggest something.

The documentation really is telling the truth:

"Remember, for an eCS system to suspend and resume properly, every single hardware device driver installed in the system must properly stop the hardware on suspend and properly start the hardware on resume. If any one driver fails to to this properly, the system will either not suspend or not resume. This is not a defect in any of the ACPI project software, it is a defect in the hardware device driver."

and

"If you hear the 4 tones and your system has not returned to a usable state, then you have a driver that is not resuming correctly."

and

"There are no logs that can help debug suspend and resume problems so we are unable to provide assistance for "it doesn't work" type of tickets."

comment:6 Changed 6 years ago by dazarewicz

  • Component changed from ACPI PSD to Suspend-Resume
  • Keywords Resume added
  • Priority changed from blocker to minor
  • Summary changed from System hangs to Resume hangs

comment:7 Changed 6 years ago by dazarewicz

  • Resolution set to duplicate
  • Status changed from new to closed

Consolidating all "resume does not work" problems into a single ticket #585

Note: See TracTickets for help on using tickets.