Opened 12 years ago

Closed 11 years ago

#57 closed defect (fixed)

ACPI, Gateway 7405GX laptop

Reported by: David McKenna Owned by: anonymous
Priority: minor Milestone: Release version 3.15
Component: ACPI PSD Version: 3.14
Keywords: Cc:

Description

Using eCS 2.0 rc2 with ACPI 3.02 (debug), APM 1.18 and DaniS506 1.8.1.

Computer is a Gateway 7405GX laptop containing an AMD 3200+ Mobile Athlon 64 CPU, VIA K8T800 chipset, ATI Radeon Mobility 9600 AGP video, Rhine II NIC, Broadcom WiFi?, VT 8233 audio (see pci.log).

To get all hardware to work with this laptop, I must add the following lines to acpi.cfg:

LINK LNKA 9

LINK LNKB 11

LINK LNKC 11

LINK LNKD 9

With w4 kernal everything works good. With smp kernal and no switches or /SMP switch everything also works good. Problems occur when /APIC switch is added.

Normally I also add /EIS switch to remove errors in acpi.log. With /SMP /APIC /EIS the computer boot hangs during logo (see file logo-hang.jpg). I need to do a hard reset. I include the file acpi-smp-eis.log for comparison (booted with /SMP /EIS)

With /SMP /APIC the computer boot hangs after all drivers are loaded (see file driver-hang.jpg). I need to do a hard reset. I include the file acpi-smp.log for comparison (booted with /SMP)

Removing audio, NIC, WiFi? and USB drivers made no change. Also /ALS and /CD switches had no effect.

Attachments (19)

pci.log (20.1 KB) - added by anonymous 12 years ago.
driver-hang.jpg (60.6 KB) - added by anonymous 12 years ago.
logo-hang.JPG (146.6 KB) - added by anonymous 12 years ago.
acpi-smp-eis.log (13.6 KB) - added by anonymous 12 years ago.
acpi-smp.log (13.9 KB) - added by anonymous 12 years ago.
smp-acpi-als-hang.jpg (115.6 KB) - added by anonymous 12 years ago.
SMP-APIC-EIS-hang305.jpg (232.1 KB) - added by guest 12 years ago.
Photo of boot hang ver 3.05 (/SMP /APIC /EIS)
acpi-smp-eis-305.log (10.2 KB) - added by guest 12 years ago.
ACPICA$ log booted /SMP /EIS ver 3.05
SMP-APIC305 Trap.JPG (212.1 KB) - added by guest 12 years ago.
Trap screen booting with /SMP
acpi-smp305.log (12.8 KB) - added by guest 12 years ago.
Debug ACPICA$ with SMP kernel and /Q switch
acpi-smp305-smp.log (13.5 KB) - added by guest 12 years ago.
Debug ACPICA$, SMP kernel and /SMP /Q switches
acpi-smp305-smp-apic.log (17.7 KB) - added by guest 12 years ago.
Debug ACPICA$, SMP kernel and /SMP /APIC /Q switches
ACPIIRQ0.LOG (6.9 KB) - added by guest 12 years ago.
ACPIIrq 0
ACPIIRQ1.LOG (6.3 KB) - added by guest 12 years ago.
ACPIIrq 1
CONFIG.SYS (5.7 KB) - added by guest 12 years ago.
Config.sys used with minimum drivers
ACPI-SMP305-smp-apic-als.LOG (12.1 KB) - added by guest 12 years ago.
ACPICA$ with /SMP /APIC /ALS switches
SMP-APIC-ALS-EIC-Hang.JPG (221.9 KB) - added by guest 12 years ago.
Photo of boot hang with /SMP /APIC /ALS /EIS switches
acpi306.log (14.5 KB) - added by guest 11 years ago.
ACPI log using ver. 3.06
amouse.sys (23.0 KB) - added by jojo 11 years ago.

Download all attachments as: .zip

Change History (66)

Changed 12 years ago by anonymous

Changed 12 years ago by anonymous

Changed 12 years ago by anonymous

Changed 12 years ago by anonymous

Changed 12 years ago by anonymous

comment:1 Changed 12 years ago by pasha

  • Owner changed from pasha to anonymous
  • Status changed from new to assigned

You need try add /ALS for /SMP /APIC

Changed 12 years ago by anonymous

comment:2 Changed 12 years ago by David McKenna

I tried booting with /SMP /ACPI /ALS but it still hangs right after all drivers have loaded. I have attached a photo smp-acpi-als-hang,jpg. Maybe SNAP again? I'll try the new Panorama and see what happens.

comment:3 Changed 12 years ago by David McKenna

Unfortunately, Panorama boots to a blank screen on this laptop....

comment:4 Changed 12 years ago by David McKenna

I mean with no switches....

comment:5 Changed 12 years ago by pasha

for /APIC you need update version of danis506.add. But I see any problem in your log, which don't resolved now. Problem is in "0:17.1 1106:571 'IDE_' IRQs: PCI:0 PIC:'LNKC':0 APIC:'ALKA':16"

comment:6 Changed 12 years ago by guest

  • Resolution set to fixed
  • Status changed from assigned to closed

The ticket was opened 3 monthes ago. ACPI is updated every 30 days. So, user should try the latest version and re-open ticket if problem is not solved.

comment:7 Changed 12 years ago by guest

  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Version changed from 3.02 to 3.05

I have tried version 3.05 on this laptop. Results are the same as before. I will upload new log (booted to /SMP /EIS with SMP kernel) and photo of boot screen hang (booting with debug ACPI.PSD).

Changed 12 years ago by guest

Photo of boot hang ver 3.05 (/SMP /APIC /EIS)

Changed 12 years ago by guest

ACPICA$ log booted /SMP /EIS ver 3.05

comment:8 Changed 12 years ago by pasha

Try remove /EIS and /OS="Microsoft Windows NT"

comment:9 Changed 12 years ago by guest

OK... I removed /EIS and /OS. Things are very different now.

I can boot with the SMP kernel and ACPI.PSD /Q - everything works. If I add /SMP or /SMP /ACPI I get a Trap 0008 at the moment the WPS would appear. I will upload a photo of the trap screen (same in both cases). Notice in the lower right corner you can see a part of the 'clock' cursor. I tried switching from AMouse to regular mouse, but it did not help. I also tried standard VGA (instead of SNAP), but it did not help either.

Using the ACPILog parameter in AcpiD.cfg, I was able to capture acpica$ logs. I will upload 3 logs - one booted with only /Q, one with /SMP /Q (which trapped), and one with /SMP /ACPI /Q (which trapped).

Changed 12 years ago by guest

Trap screen booting with /SMP

Changed 12 years ago by guest

Debug ACPICA$ with SMP kernel and /Q switch

Changed 12 years ago by guest

Debug ACPICA$, SMP kernel and /SMP /Q switches

Changed 12 years ago by guest

Debug ACPICA$, SMP kernel and /SMP /APIC /Q switches

comment:10 Changed 12 years ago by guest

I forgot to mention... the trap screen flashes on and off about twice a second. I have never seen that before!

comment:11 Changed 12 years ago by pasha

Ok. acpi-smp305-smp-apic.log and acpi-smp305-smp.log seem good. Where is problem now? Note: for using amouse need get latest version and use as device=amouse.sys SMP

comment:12 Changed 12 years ago by guest

The problem is I get the Trap 0008 when I try to boot with the /SMP switch right when the WPS should appear.... (I did have the SMP switch on the AMouse driver).

comment:13 Changed 12 years ago by pasha

As I see , you can boot, so trap 8 can be and can not be. Need look to amouse, SNAP, print01.sys

Note, /ACPI is't options for acpi.psd. psd=acpi.psd /SMP /ACPI resolving as psd=acpi.psd /SMP

comment:14 Changed 12 years ago by guest

Sorry, I typed wrong, I meant /APIC. I should point out again... I could not boot with PSD=ACPI.PSD /SMP. I got the log files by adding the line: 'AcpiLog?=C:\Acpi.log' to the file C:\mptn\etc\acpid.cfg. This would write the log file during the boot process up to the time of the Trap 0008. I did try changing mouse and video drivers, but it did not help. I will try removing the print01.sys (there is no parallel port on the laptop) and let you know tomorrow.... thanks for your patience.

comment:15 Changed 12 years ago by guest

I tried removing print01.sys, but booting still ends with a Trap 0008. I am going to try a fresh install of eCSrc3, installing only the IBM VGA video and IBM mouse, Then install ACPI 3.05 and remove all unneeded drivers. I'll keep you posted....

comment:16 Changed 12 years ago by guest

OK... I have a new install of eCS 2.0 rc3. The only drivers in use are: standard VGA, IBM mouse, IBM kbd, DaniS506(1.8.1), DaniAtapi?, IBM DASD, IBM LVM. There is no DOS/WinOS2 support installed, no NIC, no Cardbus, no APM and no sound. I added the 3.05 ACPI driver and 14.104a smp kernel.

I still get the same flashing Trap 0008 at the moment the WPS tries to start if I add the '/SMP' or '/SMP /APIC' switches. Is there anything else I can remove?

comment:17 Changed 12 years ago by pasha

Remove all, leave only need for boot. Keyboard, disk driver, VGA. If fail - try set in config.sys protshell=c:\os2\cmd.exe and boot with debug acpi. If freeze - send photo of screen.

Next for resolve problem I need in output "AcpiIRQ 0", AcpiIRQ 1"

comment:18 Changed 12 years ago by pasha

To add. Your chipset very seem nVidia nForce4. I think you need use /ALS option. So try:

psd=acpi.psd /SMP /APIC /ALS

and

psd=acpi.psd /SMP /APIC /ALS /EIS

Changed 12 years ago by guest

ACPIIrq 0

Changed 12 years ago by guest

ACPIIrq 1

Changed 12 years ago by guest

Config.sys used with minimum drivers

Changed 12 years ago by guest

ACPICA$ with /SMP /APIC /ALS switches

Changed 12 years ago by guest

Photo of boot hang with /SMP /APIC /ALS /EIS switches

comment:19 Changed 12 years ago by guest

With /SMP or /SMP /APIC or /SMP /APIC /ALS switches, and PROTSHELL=C:\OS2\CMD.EXE I can boot to command prompt. Adding /EIS causes a hang at the boot logo (see smp-apic-als-eis-Hang.jpg). I have also attached the ACPIIRQ results you requested along with the CONFIG.SYS I have used for these tests. Also the result of ACPICA$ for /SMP /APIC /ALS.

With PROTSHELL=C:\OS2\PMSHELL.EXE and /SMP /APIC /ALS switches, I get the same Trap 0008 as with /SMP.

Now that I have done this many times, I notice that the Trap 0008 is actually being re-written to the screen over and over (not flashing)- as if it is in an endless loop of Traps.

comment:20 Changed 12 years ago by pasha

From logs I see, that you can use "/SMP /EIS" or "/SMP /APIC /ALS", and see, that without /EIS your acpi table has problem.

So, using now "/SMP /EIS". What you need try:

  1. Remming run=AcpiDaemon?.exe
  2. Remming all driver, that don't need for boot (mean boot with keybord, VGA and diskdriver only)

About result say pls

comment:21 follow-up: Changed 12 years ago by guest

1.) I have not been using APM during these tests, APMDaemon.exe has not been installed. 2.) I believe I have REMmed out all drivers I can, but I attached the CONFIG.SYS I am using so if you see any others I can REM out let me know.

I tried /SMP /EIS and I still get the same looping Trap 0008 as I always get when /SMP is present.

There is one error in my ACPI table and I have created a corrected DSDT file... but I thought it cannot be used with SMP?

comment:22 in reply to: ↑ 21 Changed 12 years ago by pasha

Replying to guest:

1.) I have not been using APM during these tests, APMDaemon.exe has not been installed. 2.) I believe I have REMmed out all drivers I can, but I attached the CONFIG.SYS I am using so if you see any others I can REM out let me know.

I tried /SMP /EIS and I still get the same looping Trap 0008 as I always get when /SMP is present.

There is one error in my ACPI table and I have created a corrected DSDT file... but I thought it cannot be used with SMP?

Yes, now you can't load DSDT from SMP. Ask to eCS memsys team. They have think, that PCI scanner is more important, then read file from SMP. So I work under PCI scanner. Wait version where in "whatnew: will be "Add read file from SMP kernel"

comment:23 Changed 12 years ago by guest

OK... thanks, I look forward to it. I will report here when I try it.

Changed 11 years ago by guest

ACPI log using ver. 3.06

comment:24 Changed 11 years ago by guest

I am happy to report that the new (3.06) version of ACPI now works in APIC mode with the SMP kernel on this laptop. All hardware functions good. FWIW - I attached acpi log. One thing different - booting hesitates for ~10 seconds while loading HELPERW.EXE, but then continues with no trouble.

With /SMP /APIC everything works. I tried adding /EIS, but it hangs at boot logo like before.

The only other problem left is getting suspend/resume to work. Thanks for your great work!

comment:25 Changed 11 years ago by eco

  • Resolution set to fixed
  • Status changed from reopened to closed

please post final bug-report to http://ecomstation.ru/hardware.php?action=new

try /VBE for suspend-resume

comment:26 Changed 11 years ago by guest

eco,

I updated my previous hardware report with a comment.

I have tried /VBE, but the computer hangs when I try to resume, and must be hard booted (CAD doesn't work). Trying to resume without /VBE, it seems to work, but the screen stays blank - CAD then reboots.

comment:27 Changed 11 years ago by guest

  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Version changed from 3.05 to 3.08

With ACPI version 3.08 I can not boot with /SMP /APIC. Version 3.07 worked good. With 3.08, boot hangs on the AMouse driver. If I remove 'SMP' from the end of the driver in CONFIG.SYS, I can boot to desktop, but desktop freezes if I try to use the mouse...

comment:28 Changed 11 years ago by pasha

Need say to autor of amouse.sys "Don't use in/out to PIC, use DevHlp?"

comment:29 Changed 11 years ago by guest

e-co:

OK,

we have sent all info to the developer of AMouse http://ecomstation.ru/projects/acpitools/Known-issues

comment:30 Changed 11 years ago by jojo

Attaching new version of the amouse.sys driver, from the developer of Amouse:

The issue about ACPI is difficult for me to reproduce. I have now changed the bahaviour of AMOUSE. It will now always call des DevHlp? routine and no longer use OUT 20h for EOI (and the same for all masking operations). The SMP parameter is therefore removed. The "old" behaviour can be produced with W3COMP for diagnostic purposes (I don't think anyone will need this).

Can you give this new driver a try and provide me with any feedback or new upcoming issues.

Changed 11 years ago by jojo

comment:31 Changed 11 years ago by guest

I tried this new driver with ACPI 3.08, but boot still hangs at the Amouse driver, both with and without the 'SMP' switch.

comment:32 follow-up: Changed 11 years ago by mckinnis

I can confirm that all is not well with this driver. On my T61, I get past the Amouse driver, but the desktop fails to open.

It is interesting to note that the build levels of the various Amouse components are not consistent and the headers appear to be of the old MZ - NE variety instead of the MZ - LX type.

comment:33 Changed 11 years ago by guest

This new Amouse driver DOES work with the ACPI13042008.zip ACPI package in /SMP /APIC mode. Thanks!

comment:34 in reply to: ↑ 32 Changed 11 years ago by jojo

Replying to mckinnis:

I can confirm that all is not well with this driver. On my T61, I get past the Amouse driver, but the desktop fails to open.

The developer asks:

Does this mean, that the computer is "stuck" while switchin from text to graphics mode (starting PM) or does it fail loading the workplace shell?

Please clarify!

Thanks, Joachim

comment:35 follow-up: Changed 11 years ago by mckinnis

It means the "black screen of death".

comment:36 in reply to: ↑ 35 Changed 11 years ago by jojo

Replying to mckinnis:

It means the "black screen of death".

Alright, a trap you mean. Could you please give some more details then? Like, in which module the system traps?

Thanks.

comment:37 Changed 11 years ago by mckinnis

I am trying to get a trap dump. With the original Amouse (SMP parm), sound is in a loop. Why Amouse has to play with audio, I am not sure.

I just copied the new amouse.sys to \Amouse and rebooted with Alt+F2. I am still staring at C:\Amouse\AMOUSE.SYS. I am not even far enough along to get a trap dump.

Removed the SMP parm from amouse and tried again. No change.

FYI. It is stuck so bad that Ctrl+Alt+Del is not functional.

PS - After booting to a command line and getting the regular mouse driver active and rebooting, I removed Amouse via WarpIN. The script added mouse.sys and usbmouse.sys back to config.sys even though they were already there. I think the wis needs a little work as well.

comment:38 Changed 11 years ago by eco

What is the current state? ACPI 3.9

comment:39 follow-up: Changed 11 years ago by guest

ACPI 3.09 works good with the Amouse driver provided here on my Gateway 7405GX laptop. Still can't resume from suspend though (even with /VBE)....

One strange thing is none of the UHCI USB drivers appear in the hardware manager - only the EHCI driver does. I am able to use the USB ports with no trouble though...

Dave McKenna?

comment:40 Changed 11 years ago by stevenhl

  • Milestone set to Release version 3.10

comment:41 Changed 11 years ago by David McKenna

There is no change with ACPI 3.10...

comment:42 Changed 11 years ago by stevenhl

  • Milestone changed from Release version 3.10 to Release version 3.11

comment:43 Changed 11 years ago by David McKenna

There is no change with ACPI 3.11....

comment:44 Changed 11 years ago by David McKenna

There is no change with ACPI 3.13....

comment:45 in reply to: ↑ 39 Changed 11 years ago by David McKenna

  • Version changed from 3.08 to 3.14

Replying to guest:

One strange thing is none of the UHCI USB drivers appear in the hardware manager - only the EHCI driver does. I am able to use the USB ports with no trouble though...

FWIW... it turns out that only USB 2.0 devices were working. USB 1.1 devices were not (didn't have one until now).

I noticed in the \OS2\BOOT directory there is a file called USBUHCD2.SYS. I tried this in place of USBUHCD.SYS in my CONFIG.SYS and now USB 1.1 devices work and the ports show up in the hardware manager again!

Still can't resume with 3.14 though....

comment:46 Changed 11 years ago by eco

e-co:

try boot EHCD then UHCD drivers.

comment:47 Changed 11 years ago by eco

  • Resolution set to fixed
  • Status changed from reopened to closed

David:

Yes... OK you can close that one. Everything works fine except resume, which seems to be a common problem when using SNAP. I have tried UNI and SMP kernels with no luck resuming. Unfortunately, I cannot get Panorama to work with that computer (boots to blank screen) so I can't try resume with Panorama..

When a new version of ACPI comes out I will post a new ticket (if needed).

Note: See TracTickets for help on using tickets.