Opened 12 years ago

Closed 11 years ago

#58 closed defect (wontfix)

Thinkpad r40e, unusable if boot with ACPI.PSD (ACPI 3.04)

Reported by: Peter Owned by: pasha
Priority: major Milestone:
Component: ACPI PSD Version: 3.05
Keywords: Cc:

Description

ACPI V3.01 and V3.02, system slows down so much that keyboard keys are missed

Description: I use a Thinkpad r40e. ACPI V3.01 does not shutdown the laptop I tried V3.02, but never did have the opportunity to try shutdown. The whole pc is massively slowed down. Mouse moves, and keystrokes are missed, the system is very unresponsive. Removing ACPI V3.xx fixes slowdown. The slowdowns are not consistent, only about once every 20 secs.

ACPI V2.13 and APM.add V1.06 work with this laptop with no major issues to report.

I suspect that this problem might be affecting netwk apps too.

Attachments (12)

ACPILOG.zip (9.0 KB) - added by maulpub@… 12 years ago.
acpilog304_58.zip (30.9 KB) - added by maulman 12 years ago.
logs of acpi 3.04 (on eCS 2.0 rc2 !_not rc3_!)
acpilog.zip (31.8 KB) - added by maulman 12 years ago.
log with link setting in acpi.cfg
acpilog3.zip (33.3 KB) - added by maulman 12 years ago.
created by startup.cmd with acpi-t code
acpilog4.zip (28.9 KB) - added by maulman 12 years ago.
created with acpi-t code after 2mins use of PC
acpilog5.zip (33.3 KB) - added by maulman 12 years ago.
acpi-t2
acpilog6.zip (35.5 KB) - added by maulman 12 years ago.
added pci.log
acpilog7.zip (33.6 KB) - added by maulman 12 years ago.
1 of two files from sourceforge
acpilog8.zip (33.7 KB) - added by maulman 12 years ago.
2 of two files from sourceforge
DSDT.aml (22.5 KB) - added by pasha 11 years ago.
acpilog9.zip (35.8 KB) - added by maulman 11 years ago.
V3.05 - still the same
table.zip (683 bytes) - added by maulman 11 years ago.
Results of running GetTable? FACP

Download all attachments as: .zip

Change History (49)

comment:1 follow-ups: Changed 12 years ago by pasha

  • Owner changed from pasha to anonymous
  • Status changed from new to assigned

Do "copy acpica$ acpi.log" and attach here pls

comment:2 in reply to: ↑ 1 Changed 12 years ago by anonymous

Replying to pasha:

Do "copy acpica$ acpi.log" and attach here pls

Later, a re-install with new cvs is required first - this will take a little time.

Changed 12 years ago by maulpub@…

comment:3 in reply to: ↑ 1 Changed 12 years ago by maulpub@…

Replying to pasha:

Do "copy acpica$ acpi.log" and attach here pls

Attaching now

comment:4 Changed 12 years ago by pasha

Need:

  • Iasl.exe -d

Then ou can see created files. File with .dsl attached here.

Changed 12 years ago by maulman

logs of acpi 3.04 (on eCS 2.0 rc2 !_not rc3_!)

comment:5 Changed 12 years ago by maulman

  • Owner changed from anonymous to maulman
  • Status changed from assigned to new
  • Summary changed from Thinkpad r40e, unusable if boot with ACPI.PSD to Thinkpad r40e, unusable if boot with ACPI.PSD (ACPI 3.04)

Sorry Pasha,

I somehow lost your email asking for further information. I have installed ACPI 3.04 on my eCSV2.0 rc2 installation, and I did not want install rc3.

Anyway, I hope this gives you the information you require. V 3.04 is much better than V3.03, but when typing sometimes characters are missing (interrupt problem ?), this gets worse over time.

comment:6 follow-up: Changed 12 years ago by pasha

Do battery show correct? In AC and in battery power.

comment:7 in reply to: ↑ 6 Changed 12 years ago by maulman

Replying to pasha:

Do battery show correct? In AC and in battery power.

Yes, everything works. Battery Power takes >60 seconds to open. Other Apps are slow to open. Boot times are long. Text edit is impossible, characters are lost.

comment:8 follow-up: Changed 12 years ago by pasha

  • Owner changed from maulman to pasha
  • Status changed from new to assigned

Success working T40 has:

psd=acpi.psd /EIS /VBE

and in acpi.cfg:

LINK LNKA 10

LINK LNKH 6

Note: Here was removed uhci drivers for success suspend/resume S3.

comment:9 in reply to: ↑ 8 Changed 12 years ago by maulman

Replying to pasha:

Success working T40 has:

psd=acpi.psd /EIS /VBE

and in acpi.cfg:

LINK LNKA 10

LINK LNKH 6

Note: Here was removed uhci drivers for success suspend/resume S3.

Hi Pasha,

Sorry, r40e is not like T40.

Changes crash this PC.

comment:10 follow-up: Changed 12 years ago by pasha

You have many devices using 1 IRQ - IRQ11, for each link you can choice from 3, 4, 6, 7, 10, 11. Also, don't use IRQ for ISA device. For example, if you have com1 - don't use IRQ4, if have LPT1 - don't use IRQ7, if have FDD - don't use IRQ6. You havelinks for setting:

LNKA

LNKB

LNKG

LNKI

LNKH

All this link use IRQ11 in share mode. It is bad, so part from this link need remove to any IRQ from possible.

comment:11 in reply to: ↑ 10 Changed 12 years ago by maulman

Replying to pasha:

You have many devices using 1 IRQ - IRQ11, for each link you can choice from 3, 4, 6, 7, 10, 11. Also, don't use IRQ for ISA device. For example, if you have com1 - don't use IRQ4, if have LPT1 - don't use IRQ7, if have FDD - don't use IRQ6. You havelinks for setting:

LNKA

LNKB

LNKG

LNKI

LNKH

All this link use IRQ11 in share mode. It is bad, so part from this link need remove to any IRQ from possible.

Intersting. Some people at Warpstock complained that ACPI was putting all irq's on 11.

What does LINKxxx mean? What is a link. Why does ACPI not set this automatically?

comment:12 follow-up: Changed 12 years ago by pasha

I say, if you set in ACPI.CFG

LINK name newirqnumber

Then acpi try change IRQ for all device, which are controlled by this link. ACPI only set all, that has your ACPI table. Auto route balancing don't do, because many manafacters don't do full check own ACPI table. So can be problem with LINK. One of problem you see.LINK LNKH 6 crashed your PC.

comment:13 in reply to: ↑ 12 Changed 12 years ago by maulman

Replying to pasha:

I say, if you set in ACPI.CFG

LINK name newirqnumber

Then acpi try change IRQ for all device, which are controlled by this link. ACPI only set all, that has your ACPI table. Auto route balancing don't do, because many manafacters don't do full check own ACPI table. So can be problem with LINK. One of problem you see.LINK LNKH 6 crashed your PC.

Ok, adjusted all links until irq conflict gone. PC still works, net access ok. added apm.add The bug is the same as before. No change!

comment:14 follow-up: Changed 12 years ago by pasha

Attach current log (after your IRQ resolving) and say email where I can send version for test.

Changed 12 years ago by maulman

log with link setting in acpi.cfg

comment:15 in reply to: ↑ 14 Changed 12 years ago by maulman

Replying to pasha:

Attach current log (after your IRQ resolving) and say email where I can send version for test.

irq 11 has 2 devices attached. broadcom device to another irq stops mpts, apm.add still slows system

REM BASEDEV=APM.ADD fixes bug, 'E3' in eCenter, no power off

acpi.cfg

;============================================================================ ; LINK LNKF 14 ;;LINK LNKB 0xA ; r40e settings below ;vga display - moved LINK LNKA 10 ;PC Card CardBus? Controller - moved LINK LNKB 8 ;broadcom lan0, cannot move, mpts fails ;LINK LNKC 11 ;no idea... ;LINK LNKD ;no idea... ;LINK LNKE ;no idea... ;LINK LNKF ;Agere Systems AC'97 Modem - moved LINK LNKG 6 ;sound? breaks when moved ;LINK LNKH 9

other settings?

comment:16 follow-up: Changed 12 years ago by pasha

IRQ8 is absent in possible. Ok. What is a email for send test version?

comment:17 in reply to: ↑ 16 Changed 12 years ago by maulman

Replying to pasha:

IRQ8 is absent in possible. Ok. What is a email for send test version?

I tried irq 6,7,9... also, no difference.

You can send info/test to peter at mensys dot nl (replace 'at' with @, 'dot' with .)

Thanks :)

Changed 12 years ago by maulman

created by startup.cmd with acpi-t code

Changed 12 years ago by maulman

created with acpi-t code after 2mins use of PC

comment:18 follow-up: Changed 12 years ago by maulman

The problem is the same. Maybe not as bad as before.

acpilog3 created by startup.cmd

acpilog4 created after 2mins of using PC

comment:19 in reply to: ↑ 18 Changed 12 years ago by pasha

Replying to maulman:

The problem is the same. Maybe not as bad as before. acpilog3 created by startup.cmd acpilog4 created after 2mins of using PC

Get acpi.psd from http (where you get acpi-t.zip), boot, then attach log

Changed 12 years ago by maulman

acpi-t2

comment:20 Changed 12 years ago by maulman

I typed some text in E editor

With apm.add

"This atst o see what is going on Thesystem seems terr unresponsive."

apm.add removed

"This is a test to see what is going on. The system seems terribly unresponsive"

comment:21 Changed 12 years ago by pasha

At http://acpi.sourceforge.net/dsdt/view.php I see 2 ACPI table for IBM ThinkPad? R40e, can you try it?

This table can be use by acpi.cfg:

FILE name_file

name_file must be in \os2\boot directory

Changed 12 years ago by maulman

added pci.log

comment:22 Changed 12 years ago by maulman

No change since first report 8 Nov 07

Bug is not fixed by:-

LINK statements

FILE statements

Test files

What now....

comment:23 Changed 12 years ago by pasha

file_name mean, what you download table from sourceforge, place this file to \os2\boot and write to acpi.cfg FILE this_file_name, for exapmle, you donwload file with name R40e.aml, next you write FILE R40e.aml

comment:24 Changed 12 years ago by guest

Pasha this might help ? BIOS version ? Only did a quick google on this machine.

https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.15/+bug/18095

Roderick

Changed 12 years ago by maulman

1 of two files from sourceforge

Changed 12 years ago by maulman

2 of two files from sourceforge

comment:25 Changed 12 years ago by pasha

Here is problem with embedded controller. Also I see error at ACPI init stage. Embedded controller work right, but don't generate interrupt, so we have wait and slow work. I try small change in embedded controller works - this don't help. So next step - change ACPI table. About BIOS I don't know, I have't TP R40e. This can be one of possible case, but note - this is dangerously case.

comment:26 Changed 12 years ago by maulman

Neither file allows ACPI to start.

ERROR warning when booting.

My BIOS is 2.10 (in PCI.LOG)

Machine:

Type = 2684-QVG

Num = KBBV542 306

No bios info visible

comment:27 Changed 12 years ago by maulman

ubuntu CD will not run on this machine

freebsd CD works perfect, including ACPI

comment:28 Changed 12 years ago by pasha

Ok. I see. Linux man remove from your table all, that give error in compile. This is IRQ routing and embedded controller. I need some time for try compile your DSDT and resolve error.

BTW, Link LNKB 8 is not good idea, change or leave in 11

Changed 11 years ago by pasha

comment:29 Changed 11 years ago by pasha

  • Version changed from 3.02 to 3.05

Try use this table, you need write to acpi.cfg:

FILE dsdt.aml

File dsdt.aml copy to \os2\boot.

If boot, create acpi.log and attach here

Changed 11 years ago by maulman

V3.05 - still the same

comment:30 Changed 11 years ago by maulman

Hi Pasha,

Sorry, it is still the same. 100% identical problem.

comment:31 Changed 11 years ago by pasha

Need GetTable? FACP and table.dat attach here. GetTable?.exe you can find in http://fortuna.odessa.ua:8080/GetTable.exe

Changed 11 years ago by maulman

Results of running GetTable? FACP

comment:32 Changed 11 years ago by maulman

Hi Pasha,

Table is attached.

comment:33 Changed 11 years ago by pasha

Do you try update new BIOS from ThinkPad? support site?

comment:34 Changed 11 years ago by maulman

Hi Pasha,

Updated bios to latest version 1.13 (year=2003) -> 1.38 (year=2005). No change.

comment:35 follow-up: Changed 11 years ago by pasha

Attach acpi.log pls after BIOS update, with comment FILE in acpi.cfg and output Iasl -d too

comment:36 in reply to: ↑ 35 Changed 11 years ago by maulman

Replying to pasha:

Attach acpi.log pls after BIOS update, with comment FILE in acpi.cfg and output Iasl -d too

Sorry for the long delay.

Installed eCS rc4 after a major disk crash.

I cannot get APM.ADD to shut down PC anymore.

The bug is disabled if battery power monitor is not used.

ACPI will not work on this laptop.

I suggest you say r40e is not supported, and close this bug.

comment:37 Changed 11 years ago by guest

  • Resolution set to wontfix
  • Status changed from assigned to closed

5 monthes.. The tester is tired, let's close the ticket.

We must support any Thinkpad http://ecomstation.ru/projects/ecspc/?action=notebook

Note: See TracTickets for help on using tickets.