Opened 9 years ago

Closed 6 years ago

#401 closed defect (fixed)

Intel ATOM system routinely hangs at boot logo

Reported by: mobybrick Owned by: eco
Priority: major Milestone: Feedback pending
Component: ACPI PSD Version: 3.16
Keywords: Cc: mobybrick

Description

Guess this might be the same boot hang that lots of people have.

Booting is sucessful in 1 out of 5 boots; most of the time it hangs at eCS boot logo.

ACPI currently at 3.12, will try 3.15 if this is likely to improve things.

Thanks, Moby.

Attachments (5)

acpi-log-Model-of-your-PC.ziq (49.5 KB) - added by mobybrick 9 years ago.
ACPI 3.15 09_05_09 build
17072009012.jpg (51.5 KB) - added by mobybrick 9 years ago.
17072009014.jpg (95.6 KB) - added by mobybrick 9 years ago.
os2krnl.sym (187.6 KB) - added by pasha 9 years ago.
acpi-1.txt (8.0 KB) - added by mobybrick 9 years ago.

Download all attachments as: .zip

Change History (29)

comment:1 Changed 9 years ago by eco

e-co:

0) send your e-mail via http://ecomstation.ru/support.php so we can contact you later

1) What is the model of PC?

2) Let's test ACPI 3.14 (and there is acpi 3.15 in your Mensys directory with special builds -- http://ecomstation.ru/projects/acpitools/?action=testcase)

3) Show us switches which you use with ACPI.PSD, better collect detailed logs -- ACPI Logs Collector 3.14 (http://betazone.ecomstation.nl/)

or simple log: copy acpica$ acpi.log and attach it

Changed 9 years ago by mobybrick

ACPI 3.15 09_05_09 build

comment:2 Changed 9 years ago by mobybrick

  • Version changed from 3.12 to 3.15

Logs collected using ACPI logs collector 20081203.

Latest ACPI 3.15 09_05_09 build.

System will *always* hang when booted from cold power-just-plugged in; works after warm reset (i.e. reset after hang).

Duplicated on an identical system; systems are generic systems with genuine Intel Atom LF2 Mainboards and integrated dual-coe Atom CPUs.

Please let me know if there is anything else you need; I have a bit of time this week for any additional testing you need.

comment:3 Changed 9 years ago by mobybrick

  • Cc mobybrick added

OK, to summarise - system seems to hang very often at random on eCS boot logo at completely random moments. Not sure that cold boot is anything to do with it.

comment:4 Changed 9 years ago by eco

e-co:

Main problem: hang on OS2LOGO

The user is waiting for support -- http://bugs.ecomstation.nl/view.php?id=2488

Message 1:

[skip]

e-co:

OK, ticket 401: you have attached logs..

Please try boot in /SMP /APIC mode

First of all, please test ACPI 3.14. Your computer should work with this version.

Then try ACPI 3.16

Please post to the acpi bug-tracker additional information:

1) post output of: http://ecomstation.ru/projects/acpitools/download/acpi-test.cmd

2) hang on OS2LOGO => http://ecomstation.ru/projects/acpitools/?action=logs -> LOGS-1


Message 2:

Sorry, I don't think you understand. 3.14 does not work. I've been testing ACPI on Intel systems for two years since ACPI-OS2 v2 and it has *never* worked reliably.

For this particular system, I've already attached the logs for version 3.14 to the SVN ticket months ago, with no response. I've also tried several versions of ACPI 3.xx, leading upto and including 3.14 and 3.16.

A run of ACPI-TEST.CMD reveals no problems on the system. It warns of the SNOOP.LST should only have IBMKBD.SNP - which it only does anyway, so ACPI-TEST.CMD seems to be buggy in itself.

I will try to copy the debug ACPI.PSD (I've already remote the OS2LOGO file) but having done this process with several Intel systems previously, are you sure this can be fixed?

Message 3, Message 4

[skip]

comment:5 Changed 9 years ago by mobybrick

  • Milestone changed from Release version 3.15 to Release version 3.16
  • Version changed from 3.15 to 3.16

I installed debug version of ACPI 3.16

  • Copy ACPICA$ logfile does not work
  • Hang at boot logo hangs at the following:

Event [_L1D] Install GPE0x1D EndScan? GPE Status 0 OEMHLPXHANDLER: ACPI_START_EVENTS 4 OEMHLPXHANDLER: CALLACPI16: 4700907, CALLACPI32: F96C5D8E, EXPORTTABLE2: F96B02B8

When it hangs here, the machine seems to hard hang.

Sometimes the hang occurs after an additional line:

UNMASK IRQ1 Mask: FFFFDCF9

and on this hang the machine will reboot if CTRL-ALT-DEL is pressed.

Many of the hangs with ACPI that I have reported previously have been at 'UNMASK' statements.

Any chance of some help with this?

Thanks.

comment:6 Changed 9 years ago by pasha

What is options for acpi.psd ? What do you mean copy acpica$ acpi.log don't work? What is setting in %etc%\AcpiD.cfg in AcpiLog? = ?

comment:7 Changed 9 years ago by mobybrick

  • I have tried no switches, and /APIC = no difference.
  • ACPID.CFG file is default.
  • The command 'Copy acpica$ logfile' produces 'The system cannot open the file or device specified'

Please see the attached logs from the ACPI log collector - I'm guessing that is where all the information is stored.

Thanks for the response Pasha...

comment:8 Changed 9 years ago by pasha

Do you try acpi.psd /SMP /!NOD ?

Changed 9 years ago by mobybrick

comment:9 Changed 9 years ago by mobybrick

  • Another dump screen attached of a hang
  • 'Copy acpica$ logfile' fails if ACPIDAEMON running, so I've got the output of this before and after shutting down ACPIDAEMON

1st log: 21:43:32 Button KernBlock? 4294967295 timeout

2nd log: 21:48:5 Button event rc 95 21:48:5 Button KernBlock? rc=95

  • Booting with /!NOD seems to work after the few boots I have so far tried; from docs this seems to suggest the another ACPICA.ADD file is required in this mode, but cannot find one. Does /!NOD indicate a problem with the OEMHLP$?

Thanks

comment:10 Changed 9 years ago by mobybrick

Spoke too soon, system still hangs at boot, this time with a different message. See photo of boot screen below - indicates 'no response' from something.

Changed 9 years ago by mobybrick

comment:11 Changed 9 years ago by mobybrick

Seems to hang every other boot, as before.

comment:12 Changed 9 years ago by pasha

Can you install debug kernel and os2ldr from hobbes.nmsu.edu with dbport=0. Then attach photo at hang

comment:13 Changed 9 years ago by mobybrick

Hi,

Is using debug kernel and loader from ACPI316FULL package OK?

Wasn't aware that there are any debug kernels on Hobbes :)

Changed 9 years ago by pasha

comment:14 Changed 9 years ago by pasha

  • Owner changed from eco to pasha

Yes, you can use from debug directory and add this .sym

Changed 9 years ago by mobybrick

comment:15 Changed 9 years ago by mobybrick

  • Debug OS/2 14.104b kernel and loader install
  • KDB setup to debug to COM port (instructions for dbport? above are unknown)
  • Result of debug attached in acpi-1.txt - last few lines below. Seems to include a sum of all of the reported traces before, in chronological order. Last few lines are:

--:--:-- CPU1 Status Evaluate _PCT 0x5 AE_NOT_FOUND --:--:-- CPU1 Status Evaluate _CST 0x5 AE_NOT_FOUND --:--:-- End init CPU1 rc:0 --:--:-- UNMASK IRQ8 mask:FFFFDEFB Symbols linked (screen01) 21:34:49 UNMASK IRQ9 mask:FFFFDCFB 21:34:49 Create resource, max = 31 21:34:49 OemHlpXHandler: ACPI_START_EVENTS 3 21:34:49 AcpiInstall? Power Device Status = 0 21:34:49 ACPI Error (evxfevnt-296): Could not enable SleepButton? event [20081204 ] 21:34:49 ACPI Warning (evxface-235): Could not enable fixed event 3 [20081204] 21:34:49 AcpiInstall? Sleep Device Status = 22 - AE_NO_HARDWARE_RESPONSE 21:34:49 AcpiInstall? PMTimer Device Status = 0 21:34:49 Total use:63200 unuse:5064 count:1282 21:34:49 Event [_L00] Install GPE0x0 21:34:49 Event [_L03] Install GPE0x3 21:34:49 Event [_L04] Install GPE0x4 21:34:49 Event [_L05] Install GPE0x5 21:34:49 Event [_L09] Install GPE0x9 21:34:49 Event [_L0A] Install GPE0xA 21:34:49 Event [_L0B] Install GPE0xB 21:34:49 Event [_L0C] Install GPE0xC 21:34:49 Event [_L0D] Install GPE0xD 21:34:49 Event [_L0E] Install GPE0xE 21:34:49 Event [_L1D] Install GPE0x1D 21:34:49 EndScan? GPE Status 0 21:34:49 OemHlpXHandler: ACPI_START_EVENTS 4 21:34:49 OemHlpXHandler: CallACPI16: 4900907, CallACPI32: F9AA5D8E, ExportTable3 2: F9C002B8

Still with /!NOD switch.

comment:16 Changed 9 years ago by pasha

Ok. Do you change kbd driver? Do you use KVM? What is your keyboard? PS/2 or USB?

comment:17 Changed 9 years ago by mobybrick

  • No changes to keyboard driver.
  • Usually the system has no keyboard (or mouse) attached when in use, as I control it via VNC
  • For testing the results above, it has PS/2 keyboard and mouse.
  • Adding the keyboard and mouse has not changed the frequency with which it hangs

comment:18 Changed 9 years ago by mobybrick

Is there anything else I can try?

I have an identical system to this that behaves exactly the same.

comment:19 Changed 9 years ago by mobybrick

If I boot with the debug version of ACPI.PSD, but without /01 and boot with not the debug version of OS2KNRL, but the usual build, I get some very interesting info when the hang occurs:

Wait INI App Proc Send SIPI1 Send SIPI2 Start Processor unsuccess

Is this of any help? Is there any chance this will be fixed?

Thanks

comment:20 Changed 9 years ago by mobybrick

... but I also still see it hang much latter at the mask statements, so I suspect that there are not one but TWO problems with the ACPI code that prevent booting.

comment:21 Changed 8 years ago by pasha

Please download experimental ACPI build from Mensys site:

  • Experimental build for you:

acpi319ForDesktop.zip

comment:22 Changed 8 years ago by pasha

  • Owner changed from pasha to eco

comment:23 Changed 6 years ago by dazarewicz

  • Milestone changed from Release version 3.19 to Feedback pending

This ticket is very old and for an unsupported version. Have you tried the current version?

comment:24 Changed 6 years ago by dazarewicz

  • Resolution set to fixed
  • Status changed from new to closed

No response from reporter. Assumed fixed in current version.

Note: See TracTickets for help on using tickets.