Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#198 closed defect (fixed)

crash Dell PowerEdge T105 server

Reported by: Chuck McKinnis Owned by: pasha
Priority: major Milestone:
Component: ACPI PSD Version: 3.05
Keywords: Cc:

Description

I have just installed RC4 on a Dell PowerEdge? T105 server (dual-core Opteron CPU). The install went well, and the system booted OK.

When the ACPI wizard ran after install, it suggested that I added /SMP to the PSD line in config.sys, and installed the SMP kernel. I did, but after that the system wouldn't boot. The system got to the Snap Graphics splash, and then crashed. I tried switching to VGA mode, but the system still crashes just before switching to graphics mode.

This is the start of the error message I get:

Exception in module: OS2KRNL TRAP 000e ERRCD=0000 ERACC= ERLIM= CPU=01 ... Internal revision 14.104a_SMP

After looking at the ACPI SMP FAQ, I tried changing /PIC to /APIC. That improves the situation slightly - the desktop is shown for about 10 seconds before the system crashes... If I boot the system using the original config.sys (Alt-F1->F2) the system boots. Alt-F1->F4 causes the same crash after 10 seconds as the normal boot.

To get the system booting, I went back to the installation config (Alt-F1->0) and changed to VGA mode again. Then the system boots - but without SMP of course.

Any tests I should perform to get SMP working?

A separate issue is the NIC, which is not supported. It's a Broaddcom BCM5722, which doesn't exist according to the Broadcom website. Perhaps it's a special Dell-only chip? I have hacked the B57.OS2 driver to support it, and it seems to be working fine.

Attachments (6)

acpi.log (10.0 KB) - added by Chuck McKinnis 12 years ago.
acpidaemon.log (19.8 KB) - added by Chuck McKinnis 12 years ago.
acpiirq.log (9.3 KB) - added by Chuck McKinnis 12 years ago.
pci.log (1.2 KB) - added by Chuck McKinnis 12 years ago.
acpi-log-Dell-PowerEdge-T105.ziq (46.4 KB) - added by Chuck McKinnis 12 years ago.
ACPI 3.7 logs
BCM5722.zip (23.0 KB) - added by Chuck McKinnis 12 years ago.
Broadcom BCM5722 (Dell-only chip?) driver

Download all attachments as: .zip

Change History (12)

comment:1 Changed 12 years ago by pasha

need acpi.log from any boot. And read pls acpi FAQ in Dell section

Changed 12 years ago by Chuck McKinnis

Attachment: acpi.log added

Changed 12 years ago by Chuck McKinnis

Attachment: acpidaemon.log added

Changed 12 years ago by Chuck McKinnis

Attachment: acpiirq.log added

Changed 12 years ago by Chuck McKinnis

Attachment: pci.log added

comment:2 Changed 12 years ago by Chuck McKinnis

I have read through the docs.

There are no add-on cards installed, and the only "special" drivers are for the NIC and USB. USB is needed, as the system has no PS/2 keyboard connector.

comment:3 Changed 12 years ago by eco

Please install ACPI 3.7, send us logs

comment:4 Changed 12 years ago by Chuck McKinnis

After installing 3.7 and a patched patched Broadcom driver the system seems to work with /SMP /APIC.

The original Broadcom driver I patched myself doesn't work (high IRQ problem). I tried REMAP, but the driver still didn't work. It installed, but networking didn't work, and the system behaved strangely. I tried your patched driver from ecomstation.ru, but that driver doesn't support the BCM5722. So I patched your patched driver to support the BCM5722 instead of the BCM5721, and now the driver works.

I have attached the logs and the BCM5722 driver.

Changed 12 years ago by Chuck McKinnis

ACPI 3.7 logs

Changed 12 years ago by Chuck McKinnis

Attachment: BCM5722.zip added

Broadcom BCM5722 (Dell-only chip?) driver

comment:5 Changed 12 years ago by Chuck McKinnis

Resolution: fixed
Status: newclosed

OK, we add the driver to the list of APIC compatible

  • Broadcom BCM5722 (Dell-only chip?) driver from Yuri Dario

URL: http://ecomstation.ru/download/drivers/BCM5722.ZIP

comment:6 Changed 12 years ago by Chuck McKinnis

ops, If I see Dell then I remember about Yuri Dario :)

-> patched by Mikkel C. Simonsen

Note: See TracTickets for help on using tickets.