Opened 6 years ago

Closed 6 years ago

#9 closed defect (fixed)

tcp/ip interface configuration

Reported by: fbakan Owned by:
Priority: major Milestone: 3 allow alternate DHCP client
Component: engine Version: 3.12
Keywords: Cc:

Description

just tried the new 3.12 beta. it connects to my wlan,
but the interface configuration is not 'stable'
every few seconds the the ip-address increases.
x.x.x.30
x.x.x.31
x.x.x.32
x.x.x.33
...
and so on

Attachments (4)

dhcpcd.log (26.0 KB) - added by fbakan 6 years ago.
dhcpd.log first part log with beta second part with working pre-beta-xwlan
dhclientlogs.zip (1.8 KB) - added by fbakan 6 years ago.
dhconf.cmd (13.9 KB) - added by andib 6 years ago.
dhclientlosgs2.zip (1.9 KB) - added by fbakan 6 years ago.

Download all attachments as: .zip

Change History (19)

comment:1 Changed 6 years ago by Lewisr

Franz, can you please go to the TCP/IP configuration page 2 in the Properties notebook for XWLAN, check the "Configure DHCP Client" option and then "Activate logging," taking note of the logfile name to be created, and then start the wireless connection?

Please post the resulting DHCP client logfile so we may have a look.

Also, if you have access to the wireless router/access point (or DHCP server behind it), can you please post DHCP server details (if using a wireless router/access point for address assignment, please post make/model of router, firmware revision, and relevant DHCP server settings - lease time, any device reservations, etc.)? This might shed some light on what is happening.

Lewis

Changed 6 years ago by fbakan

dhcpd.log first part log with beta second part with working pre-beta-xwlan

comment:2 Changed 6 years ago by fbakan

ok here's the requested log.
The router is a "FRITZ!Box Fon WLAN 7270 v3 (UI)" Firmware is "FRITZ!OS 05.60-26779 BETA".

Franz

comment:3 Changed 6 years ago by andib

dhcpd.log is only created by standard os/2 - eCS dhcp daemon (dhcpd.exe) not with ISC dhclient. So if you still get a log file with 3.12beta I wonder why dhcpd.exe is running on your system. 3.12beta kills this process if it is running. At least it tries to do so whenever the wireless interface is activated.

Do you start it manually again (DHCPSTRT.EXE)?

comment:4 Changed 6 years ago by fbakan

I don't start it manually again.
I think it's only started from \mptn\BIN\setup.cmd which is called
from mptstart.cmd which is started in config.sys

this is the content of setup.cmd:

route -fh
arp -f
ifconfig lo 127.0.0.1
REM ifconfig lan0
ifconfig lan1 127.0.0.1 netmask 255.255.255.0 metric 0 mtu 1500
dhcpstrt -i lan0 -d 0
ipgate off
Last edited 6 years ago by fbakan (previous) (diff)

comment:5 Changed 6 years ago by andib

To check if OS/2 daemon (dhcpd.exe) is still running you can check with some process viewer f.i. top. Or start the graphical monitor Systemkonfiguration-Netzwerk-TCP/IP-DHCP-Überwachung. It should say that DHCP-Client is not running.

To terminate the daemon manually use 'dhcpmon -t'

As this all should be done by XWLAN I wonder what's going wrong with your setup.

comment:6 Changed 6 years ago by fbakan

dhcpd.exe is not running. I even renamed dhcpd.exe, so it's not found.
Original problem still exists.

comment:7 Changed 6 years ago by andib

If dhcpd is not running have you tried configuring xwlan without dhcp? You can always start dhclient by hand after the wlan connection is established. Maybe output of dhclient running from command line gives us some clue what's going wrong on your system.

Changed 6 years ago by fbakan

comment:8 Changed 6 years ago by fbakan

Ok I renamed dhclient.exe to dhclient-.exe so it's not found.

After enabling radio I start dchclient-.exe manually and redirect the output:

dhclient-.exe lan2 1>1 2>2

and then after getting three or four increasing ip-adresses for lan2
I first disabled radio and then killed dhclient-.exe with ctrl-c

attached dhclientlogs.zip.

comment:9 Changed 6 years ago by andib

So lan2 is your wlan (Genmac) interface I guess, correct?

Do you have another wired interface active at the same time? I usually have.

My dhclient output is slightly different than yours. But probably that's only cause I've changed it to be more verbose. Anyway maybe you want to try the attached one.

[1;33;40mentering script
[36;40m
[36;40mDHCP Configuration Script
Action code:  PREINIT
Interface  :  lan1
ETC        :  M:\MPTN\ETC


ifconfig lan0 > lanIFtst.tst 
Deleting P:\usr\sbin\lanIFtst.tst
     1 file deleted           4.096 bytes freed
ifconfig lan1 0.0.0.0 2>nul
┌──────────────────────────────────────────────────┐
│                                                  │
│       Initializing interface lan1                │
│                                                  │
└──────────────────────────────────────────────────┘
[0m[1;33;40mentering script
[36;40m
[36;40mDHCP Configuration Script
Action code:  BOUND
Interface  :  lan1
ETC        :  M:\MPTN\ETC


ifconfig lan1 down>nul
route -f > nul
ifconfig lan1 192.168.1.79 netmask 255.255.255.0 broadcast 192.168.1.255
route add default 192.168.1.201 >nul
Pinging default route to test connection...
ping 192.168.1.201 1500 3
PING 192.168.1.201: 1500 data bytes
1508 bytes from 192.168.1.201: icmp_seq=1. time=10. ms
1508 bytes from 192.168.1.201: icmp_seq=2. time=10. ms

----192.168.1.201 PING Statistics----
3 packets transmitted, 2 packets received, 33% packet loss
round-trip (ms)  min/avg/max = 10/10/10
[32;40m
 
┌─────────────────────────────────────────────────────┐
│                                                     │
│   Your have recieved a valid IP address             │
│                                                     │
│                                                     │
│   State       :  BOUND                              │
│   Interface   :  lan1                               │
│   IP          :  192.168.1.79                       │
│   Subnet      :  255.255.255.0                      │
│   Broadcast   :  192.168.1.255                      │
│   Gateway     :  192.168.1.201                      │
│   Domain name :                                     │
│   Nameservers :  1.1.1.1 1.1.1.2                    │
│                                                     │
│   Lease time  :  864000 secs                        │
│   Renew       :  07/01/2014 at  4.02.49 UTC         │
│   Rebind      :  11/01/2014 at  4.14.33 UTC         │
│   Expire      :  12/01/2014 at 10.14.33 UTC         │
│                                                     │
└─────────────────────────────────────────────────────┘

stderr -

Internet Systems Consortium DHCP Client V3.1-ESV-R3
Copyright 2004-2011 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

can't create /@unixroot/var/lib/dhclient.leases: No such file or directory
Listening on Socket/lan1
Sending on   Socket/lan1
DHCPDISCOVER on lan1 to 255.255.255.255 port 67 interval 6
DHCPOFFER from 192.168.1.201
DHCPREQUEST on lan1 to 255.255.255.255 port 67
DHCPACK from 192.168.1.201
ioctl (SIOCAIFADDR): File exists
can't create /@unixroot/var/lib/dhclient.leases: No such file or directory
bound to 192.168.1.79 -- renewal in 409692 seconds.

Changed 6 years ago by andib

comment:10 Changed 6 years ago by andib

Another idea is to look at the pmprintf logging output of xwlan/wlanstat. If you're experienced with pmprintf I can upload a debugging version of wlanstat.exe. I find it easier to debug with the stand alone app than the widget. Then you should see a lot of debugging messages which are controlled by the \bin\deb.cmd script. If you're interested please let me know. I can upload my debug versions and we can try to work this out.

comment:11 Changed 6 years ago by fbakan

Attached the output generated with your more verbose version of dhconf.cmd

Well I'm not experienced with pmprintf, but I could give it a try
if you upload the debugging version of wlanstat.exe and tell me in short what to do.

Changed 6 years ago by fbakan

comment:12 Changed 6 years ago by andib

Wonders what

DHCPACK from 192.168.22.1
   119 +++         Call SysSleep 0;
DHCPDECLINE on lan2 to 255.255.255.255 port 67

in your 2 (error log) means. Seems to be a REXX error. Relevant code is -

116       '@echo nameserver 'name1' >> 'etce.envi'\resolv2'
117       if length(name2) > 0 then '@echo nameserver 'name2' >> 'etce.envi'\resolv2'
118       if length(name3) > 0 then '@echo nameserver 'name3' >> 'etce.envi'\resolv2'
119       Call SysSleep 0
120       call updatedyndns

REXX experts around?

comment:13 Changed 6 years ago by fbakan

OK, this hint helps:
I run Classic REXX and so don't have

SysSleep

available here.
After replacing

SysSleep 0

with something else the problem has gone.
Switching Classic REXX to Object REXX did not work.
I don't know why but when I first tried this, lan2 had the status 'deactivated'.
So I switched back to Classic REXX and replaced

'call SysSleep 0'

with

'@Sleep 0'

Sleep.exe is can be found in \usr\bin

Thanks for your support!

comment:14 Changed 6 years ago by fbakan

Forget the comment above.
I was wrong

SysSleep

is also Part of Classic REXX
The correct solution is to add

call RxFuncAdd 'SysLoadFuncs', 'RexxUtil', 'SysLoadFuncs'
call SysLoadFuncs

to dhconf.cmd before calling

SysSleep

(Thanks for the resolution posted in os2forum.teamos2hamburg.de)

comment:15 Changed 6 years ago by andib

  • Resolution set to fixed
  • Status changed from new to closed

Ok. Will update the script and push Yuri to include it in next dhclient rpm.

Note: See TracTickets for help on using tickets.