Opened 6 years ago

Closed 5 years ago

#28 closed defect (fixed)

Hotspot list returns to top upon auto-refresh, even when select bar is below bottom of window (window scrolled)

Reported by: Lewisr Owned by:
Priority: minor Milestone:
Component: GUI (dialogs) Version: 3.12
Keywords: Cc:

Description

(Using widget.)

Selecting Public hotspot | Scan for hotspots..., viewing a resulting large list of nearby WLANs (several screens long), and scrolling down either via keyboard or mouse (using scrollbar in the latter case), results in the scrollbar returning to the top upon the next auto-refresh of the window contents.

I am currently looking at a list of over 60 hotspots, with a window size of approximately 25 visible WLANs. It is impossible to scroll down even to the second page, because within a second, the scrollabr jumps back up to the top. This happens even when the selected hotspot is on the next screen down, thus the select bar is "hidden" below the bottom of the window.

Expected behavior: Select bar should always remain visible (if moving down via keyboard), or scroller should stay where placed (if scrolled via mouse).

Change History (2)

comment:1 Changed 6 years ago by andib

Do you by any chance know if 3.10 behaves the same with so much hotspots? In other words is this a new bug or the same since ever?

comment:2 Changed 5 years ago by andib

Resolution: fixed
Status: newclosed

Fixed in #1112

Note: See TracTickets for help on using tickets.