Opened 12 years ago

Closed 12 years ago

#94 closed defect (wontfix)

apparent IRQ conflict

Reported by: Steve Wendt Owned by: Steve Wendt
Priority: normal Milestone:
Component: Building Version: 1.1.4
Severity: normal Keywords: IRQ, ACPI
Cc:

Description (last modified by Brendan Oakley)

I am Using an ECS K7S5A with built in LAN and sound. When I load the drivers for the LAN only, the LAN works. When I load LAN with UNIAUD32.SYS and UNIAUD16.SYS, the LAN does not work (no error messages), but the sound seems to be fine (I have only tried a few files). They both share IRQ 10, which does not appear to be changeable. This PC is triple boot, eCommStation 1.2, Windows XP, and Ubuntu. Both the LAN and sound work in Windows and Ubuntu. Attached are the three files specified in the README.TXT.

Greg Gilbert luigi_ludwig <a t> ameritech dot net

Attachments (3)

uniaud.log (3.8 KB) - added by Steve Wendt 12 years ago.
mixer.txt (8.0 KB) - added by Steve Wendt 12 years ago.
hardware.txt (12.1 KB) - added by Steve Wendt 12 years ago.

Download all attachments as: .zip

Change History (5)

Changed 12 years ago by Steve Wendt

Attachment: uniaud.log added

Changed 12 years ago by Steve Wendt

Attachment: mixer.txt added

Changed 12 years ago by Steve Wendt

Attachment: hardware.txt added

comment:1 Changed 12 years ago by Steve Wendt

Owner: set to Steve Wendt
Status: newassigned

comment:2 Changed 12 years ago by Brendan Oakley

Description: modified (diff)
Keywords: IRQ ACPI added
Resolution: wontfix
Status: assignedclosed
Version: 1.1.4

Although Uniaud is not perfect with shared IRQ's, if sound works, this problem is in the LAN driver, not in Uniaud.

There is a chance upgrading to eComStation 2.0 will help, because of the ACPI support. I was not able to share IRQ's until eCS 2.0rc1. I have all devices on IRQ 11, and it's (mostly) working.

Note: See TracTickets for help on using tickets.