Opened 8 years ago

#213 new defect

uniaud16.sys hangs system when trying to play html5 video

Reported by: losepete Owned by:
Priority: highest Milestone: ALSA Hardware Compatibility
Component: UNIAUD16 Version: 1.9.26
Severity: blocker Keywords:
Cc:

Description

OS: eCS2.1 Uniaud build as supplied with eCS2.1 does not work that well with the hardware involved: nVidia HDA Audio, nForce430/MCP61, AD1988

I had backlevelled the uniaud32.sys file to:-

[L:\MMOS2]bldlevel uniaud32.sys Build Level Display Facility Version 6.12.675 Sep 25 2001 (C) Copyright IBM Corporation 1993-2001 Signature: @#Netlabs:1.9#@##1## 1 Apr 2008 20:26:55 mail.smedl:1.0.16 :::2::SVN r334@@Universal Audio Driver for OS/2 and eComStation (ACPI) Vendor: Netlabs Revision: 1.09 Date/Time?: 1 Apr 2008 20:26:55 Build Machine: mail.smedl ASD Feature ID: 1.0.16 FixPak? Version: SVN r334 File Version: 1.9.2 Description: Universal Audio Driver for OS/2 and eComStation (ACPI)

I had reasonable good audio performance using the eCS2.1 supplied uniaud16.sys matched with the above uniaud32.sys. The eCS2.1 supplied uniaud16.sys is:- Build Level Display Facility Version 6.12.675 Sep 25 2001 (C) Copyright IBM Corporation 1993-2001 Signature: @#Netlabs:1.9#@##1## 22 Sep 2010 11:36:43 DAZAR1 ::::5:: SVNr534@@Universal Audio MMPM/2 Driver for eComStation Vendor: Netlabs Revision: 1.09 Date/Time?: 22 Sep 2010 11:36:43 Build Machine: DAZAR1 FixPak? Version: SVNr534 File Version: 1.9.5 Description: Universal Audio MMPM/2 Driver for eComStation

However, when attempting to play html5 video the system hangs requiring the system box Reset button to be pressed.

Changing uniaud16.sys to:-

Build Level Display Facility Version 6.12.675 Sep 25 2001 (C) Copyright IBM Corporation 1993-2001 Signature: @#Netlabs:1.1#@##1## 11 Nov 2008 19:51:58 ECSDEV_RJJ::::4:: RC6@@Universal Audio MMPM/2 Driver for eComStation Vendor: Netlabs Revision: 1.01 Date/Time?: 11 Nov 2008 19:51:58 Build Machine: ECSDEV_RJJ FixPak? Version: RC6 File Version: 1.1.4 Description: Universal Audio MMPM/2 Driver for eComStation

Resolves the issue, html5 video now plays and the system does not hang.

Change History (0)

Note: See TracTickets for help on using tickets.