Opened 8 years ago

Closed 6 years ago

#214 closed defect (fixed)

no audio at all on ThinkPad T61p

Reported by: tholen Owned by:
Priority: highest Milestone: ALSA Hardware Compatibility
Component: UNIAUD32 Version: 1.9.26
Severity: blocker Keywords:
Cc:

Description

ThinkPad? T61p (type 6459)

Audio works fine with Windows XP (32-bit) Audio works fine with Fedora 14 (64-bit)

Appears to be Analog Devices AD1984 chipset, though Windows identifies it only as a SoundMAX Integrated HD Audio

Tried the eCS 2.0 default installation; no joy Tried the 1.9.26 recommended release; no joy Tried the 2.1.3 beta release; no joy (this was installed at the time UniLog? was run)

Attachments (1)

T61p-20111225-uniaud-2.1.3.log (51.2 KB) - added by tholen 8 years ago.
UniLog? output

Download all attachments as: .zip

Change History (7)

Changed 8 years ago by tholen

UniLog? output

comment:1 Changed 8 years ago by Silvan Scherrer

i would play with the control id 3, as it seems wrong to me. this switch means no output to the speakers

Control ID: 3

Interface: virtual mixer device Device(client): 0, subdevice (substream) 0 Name: [Speaker Playback Switch] Index: 0 Element type: boolean type Count of values: 2 Value:

Bounds: min: 0, max: 1, step: 0

value 1: 0 value 2: 0

comment:2 Changed 8 years ago by tholen

Yes! Changing the ID3 values to 1 and 1 enables the sound! However, the output from the built-in speakers is very weak, even after I adjusted both the UniAud? mixer value to its maximum (39) and the OS/2 Volume control to its maximum (100). The hardware volume and mute controls do nothing. Output from the headphone jack is okay.

As I recall, the volume had been turned down under Windows, so it may be that the hardware settings as configured by Windows were simply adopted by OS/2. Is there another volume control that I might be unaware of?

comment:3 Changed 8 years ago by tholen

I just finished booting into Windows and boosting the audio volume to maximum, then booting back into OS/2. No change in the volume. Furthermore, only the right speaker is producing sound; the left speaker is silent (but works in Windows, so it's not defective). The hardware controls do nothing to the sound, but if I press the mute button while my cursor is in this entry box, it produces "d", whereas the volume down button produces "c", and the volume up button produces "b".

So, progress; at least I have sound, but there are still issues. Many thanks for the tip.

comment:4 Changed 8 years ago by tholen

A further test has revealed that unimix uses a zero-based counting system, so my use of -cnt1 and -cnt2 to change their values from 0 to 1 is why I had a right channel but no left channel. Left channel is now active after using -cnt0 to change its value to 1.

Hardware controls are still of no use to affect the audio, but pressing them also produces the "d" "c" and "b" characters at a windowed command prompt, not just a Firefox entry box.

comment:5 Changed 6 years ago by Silvan Scherrer

i see exactly the same for the Hardware Controls on a T510.

comment:6 Changed 6 years ago by Silvan Scherrer

Resolution: fixed
Status: newclosed

As sound works on that system, I close that ticket in favor of a hardware control only one. See the new ticket #227

Note: See TracTickets for help on using tickets.