Opened 10 years ago

Closed 9 years ago

#169 closed defect (unknown)

Audio Looping

Reported by: wlhartzell Owned by: dazarewicz
Priority: normal Milestone:
Component: UNIAUD32 Version: 1.9.14
Severity: normal Keywords: 1.9.16
Cc:

Description

Audio loops with this game: Sunnypills. It loops almost every time I start it. When it does not loop, it crakles-pop several times and stops making sound. You should note that the version field of TRAC bug reporting has not been updated with the current version 1.9.16 number; and the debug build is different in behavior with respect to application setting their own sound levels (it does not allow this), although it shows the main complaint herein.

Attachments (1)

debuginfo.zip (11.0 KB) - added by wlhartzell 10 years ago.

Download all attachments as: .zip

Change History (4)

Changed 10 years ago by wlhartzell

comment:1 Changed 10 years ago by wlhartzell

Last night I was listening to some techno and the heavy base beat caused the audio to loop until I closed Z!. I open Z! again to classical stream and all was well. But when I return to the techno stream, the looping problem return. This suggest to me the PCM to analog codex is over flowing its buffer whenever it processes loud base noise, like the bita bing,bita bang, bita boom noise that Sunnypills produces.

comment:2 Changed 9 years ago by dazarewicz

  • Component changed from Building to UNIAUD32
  • Owner set to dazarewicz
  • Status changed from new to assigned

Please test with the latest BETA build and either change the version of this ticket to 2.0 or close it.

comment:3 Changed 9 years ago by dazarewicz

  • Resolution set to unknown
  • Status changed from assigned to closed

Version 1.9.16 is obsolete and we will not be debugging problems in older versions. All known issues regarding looping audio and buffer management have been fixed in the current versions.

Note: See TracTickets for help on using tickets.