Opened 11 years ago

Closed 9 years ago

#164 closed defect (unknown)

No sound with Intel HDA 8086:27D8 ICH7

Reported by: dpshea2415 Owned by: dazarewicz
Priority: normal Milestone:
Component: UNIAUD32 Version: 1.1.4RC6
Severity: normal Keywords:
Cc:

Description

Using ECS RC6 version of uniaud with HDA support - drive loads no errors shown but there is no sound.

Sound card is intel HDA 8086:27D8 82801G ICH7 family - found in the IBM/Lenovo Thinkcentre M52 model.

Attachments (2)

debuginfo.zip (5.8 KB) - added by dpshea2415 10 years ago.
debuginfo.2.zip (6.8 KB) - added by dpshea2415 10 years ago.
added 29/07/2009

Download all attachments as: .zip

Change History (12)

comment:1 Changed 10 years ago by psmedley

Can you please try with the latest v1.9.12 build from http://svn.netlabs.org/uniaud

Changed 10 years ago by dpshea2415

comment:2 Changed 10 years ago by dpshea2415

tried the suggested new build but still no luck. the driver loads and identifies the chipset as ad1981 but there is no sound once the wps loads etc.

comment:3 Changed 10 years ago by psmedley

Can you try with 1.9.14? You may need to play around with unimix to set audio mixer controls - some systems default to volume as zero

comment:4 follow-up: Changed 10 years ago by psmedley

http://smedley.info/uniaud32-20090615-debug.zip may also help - it correctly initialises some more mixer controls, including the Headphone control

comment:5 in reply to: ↑ 4 Changed 10 years ago by dpshea2415

sorry still no luck even with latest driver - i have also mucked around with unimix settings. This same chipset is also in my new Acer Aspire One D250 - with latest driver get sound but tends to stutter. Also enabling UNIAUD stops laptop from shutting down - when i rem drivers it powers off cleanly with latest acpi.

comment:6 Changed 10 years ago by psmedley

For the machine that has no sound output, can you please send a new debuginfo.zip from uniinfo?

Changed 10 years ago by dpshea2415

added 29/07/2009

comment:7 Changed 10 years ago by dpshea2415

Tried latest build - 1.9.19 - sound works for various apps - such as PM123 and youtube in Firefox but MMOS2 sound samples are choppy or do not play properly at all.

comment:8 Changed 10 years ago by psmedley

with respect to choppy audio with mmpm sounds, can I please have a uniinfo (ie ftp://ftp.netlabs.org/pub/uniaud/UniInfo.zip) log from debug versions of uniaud16 & uniaud32 after a reboot, and playback of one mmpm sound.

ISTR reading that some HDA cards don't support low bitrates well - most/all? mmpm sounds are lower bitrates that used by things like pm123 and mplayer which use 44100 or 48000Hz.

I'm thinking that whilst some HDA report that they support the lower bitrates, maybe we need a kludge in uniaud16 to always resample these sounds to 44100 or 48000Hz for HDA hardware.

comment:9 Changed 9 years ago by dazarewicz

  • Component changed from Building to UNIAUD32
  • Owner set to dazarewicz
  • Status changed from new to assigned

Please try the newest BETA build and if the problem still exists, change the version of this ticket to 2.0 or close the ticket if the problem is fixed.

comment:10 Changed 9 years ago by dazarewicz

  • Resolution set to unknown
  • Status changed from assigned to closed

This report is for a very old version and is probably fixed.

Note: See TracTickets for help on using tickets.