Opened 11 years ago

Closed 9 years ago

#163 closed defect (fixed)

114RC7 uniaud16.sys causes crash when playing \mmos2\desktop\dsk_lckp.wav

Reported by: losepete Owned by: dazarewicz
Priority: highest Milestone: Stabilization
Component: UNIAUD16 Version: 1.1.4RC7
Severity: blocker Keywords: crash
Cc:

Description (last modified by gentux2)

Hardware: nVidia HDA MCP61/Realtek AD1988

I installed *only* the uniaud16.sys file from this package - I use Pauls 1.9.2 HDA build of uniaud32.sys and none of the other driver related files in this package have changed since the last 114 build.

After a reboot system sounds worked - until I tried the \mmos2\desktop\dsk_lckp.wav file. This played but never finished - very good for a 2 second wav file...

It was necessary to press the Reset button to recover from this crash.

For comparison I also tried the HDA 1.9.11 build of uniaud32.sys - which I would not normally bother with as it does not work very well with this hardware - and can report that also crashes when trying to play that wav file with this version of uniaud16.sys. The problems with 1.9.11 uniaud32.sys do not include crashes with the 114RC6 uniaud16.sys installed; just lousy, distorted playback.

Conclusion: The uniaud16.sys included in 114RC7 has some new bug(s) which are, so far, only exposed by the file \mmos2\desktop\dsk_lckp.wav as this file plays without problems using 114RC6 uniaud16.sys with HDA 1.9.2 uniaud32.sys and also plays with some distortion but no crash when using HDA 1.9.11 uniaud32.sys.

Attachments (1)

UniAud16 Trap Screen.jpg (73.1 KB) - added by Blonde Guy 11 years ago.
digital photo of uniaud16.sys trap screen

Download all attachments as: .zip

Change History (5)

comment:1 Changed 11 years ago by Abwillis

I can verify the crash... I am using the 114RC7 uniaud32.sys so it is not restricted to a compatibility of uniaud16rc7 and the HDA uniaud32.sys.

Changed 11 years ago by Blonde Guy

digital photo of uniaud16.sys trap screen

comment:2 Changed 10 years ago by gentux2

  • Component changed from Building to UNIAUD16
  • Description modified (diff)
  • Milestone set to Stabilization
  • Priority changed from normal to highest
  • Severity changed from normal to blocker
  • Version changed from 1.1.4RC6 to 1.1.4RC7

comment:3 Changed 9 years ago by dazarewicz

  • Owner set to dazarewicz
  • Status changed from new to assigned

I believe all traps, hangs, and lockup problems have been fixed. Please try the newest BETA build and if the problem still exists, change the version of this ticket to 2.0 or close the ticket if the problem is fixed.

comment:4 Changed 9 years ago by dazarewicz

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.