Opened 12 years ago

Closed 11 years ago

#109 closed defect (fixed)

On SB Live (1102:002) trap after shut down, before turning system off

Reported by: guest Owned by: gentux2
Priority: high Milestone: Stabilization
Component: UNIAUD32 Version: 1.1.4RC5
Severity: normal Keywords:
Cc:

Description

eCS 2.0RC4, Uniaud RC5, SB Live! (CT4780). System boots fine, plays sound fine, shuts down normally until all files are closed. Then just before the system would normally turn off power to the cpu it traps.

Attachments (3)

mixer.txt (64.7 KB) - added by guest 12 years ago.
output of unimix.exe -list
hardware.txt (14.1 KB) - added by guest 12 years ago.
output of pci.exe
uniaudRC5.dump (624 bytes) - added by guest 12 years ago.
trap dump

Download all attachments as: .zip

Change History (9)

Changed 12 years ago by guest

output of unimix.exe -list

Changed 12 years ago by guest

output of pci.exe

Changed 12 years ago by guest

trap dump

comment:1 Changed 12 years ago by yoda

  • Component changed from Building to UNIAUD32
  • Milestone set to 1.1.4GA
  • Priority changed from normal to high
  • Version set to 1.1.4RC5

comment:2 Changed 12 years ago by yoda

You say it traps before Power OFF. Are you using APM or ACPI to turn power off ?

Try to shutdown without using power off function, and see if it still traps.

comment:3 Changed 12 years ago by yoda

  • Owner set to gentux2

Please test with RC6 !

comment:4 Changed 11 years ago by gentux2

  • Priority changed from high to normal
  • Summary changed from trap after shut down, before turning system off to On SB Live (1102:002) trap after shut down, before turning system off

I have this hardware, and I cannot reproduce this problem with Uniaud 1.1.4RC5. I'm not running ACPI on my test system, so perhaps that is the reason.

This strongly resembles Ticket #112, albeit with SB Audigy. That was reported fixed in 1.1.4RC6. I'm inclined to believe this is fixed already. Please report back if it is not.

comment:5 Changed 11 years ago by gentux2

  • Priority changed from normal to high
  • Status changed from new to assigned

Scratch that, sorry.

I am able to reproduce this by running at the commandline the eStyler 'shutdown o'. I get this with 1.1.4RC5 and 1.1.4RC6. It shuts down just fine with 1.1.4RC1. RC2-4 do not have sound with SB Live, but I tested them anyway, and they also trap.

I can fix this. I'm on it.

comment:6 Changed 11 years ago by gentux2

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in changeset:368.

Note: See TracTickets for help on using tickets.