Opened 6 years ago

Closed 6 years ago

#112 closed defect (fixed)

114RC2, RC3, RC4, RC5 all cause Traps with SB0090

Reported by: guest Owned by:
Priority: normal Milestone: Stabilization
Component: UNIAUD32 Version: 1.1.4RC5
Severity: normal Keywords:
Cc:

Description

Hi

I have 2 systems both using identical SB0090 sound cards.

System1: Asus M2N mainboard with MCP61 chipset, acpi v2.22 in use

Uniaud HDA does not quite work with the onboard NVidia HDA/AD1988 audio - but that is another problem :-)

Soundcard installed:
SB Audigy1 Rev3 PCI ID Vendor 0x1102 Device 0x0004
Using 114RC1
uniaud16.sys 61,594 2/8/2005
uniaud32.sys 568,236 19/1/2006

Drivers load and work fine except at Shutdown: sometimes the Shutdown sound is played, sometimes it is partially played and cut off, sometimes there is a loud spitting noise instead of the Shutdown sound. No Traps.

Using 114RC2
uniaud16.sys 61,198 26/11/2006
uniaud32.sys 598,518 26/11/2006

Drivers load and work fine except at Shutdown: a "splutter" or "spitting" noise replaces the Shutdown sound and then the system traps with either:-

Exception in module: Uniaud32
Trap 000E ... CPU=01
CS:EIP=0168:ee4536c8
The system detected an internal processing error at location ##0168:fff0f667 - 000f:e667
60000, 9084

or

TRAP 000d ... CPU=01
CS:EIP=0100:000004f4
The system detected an internal processing error at location ##0168:fff0f667 - 000f:e667
60000, 9084

Using 114RC3
uniaud16.sys 61,366 15/8/2007
uniaud32.sys 558,068 15/8/2007

Drivers load and work fine except at Shutdown: a "splutter" or "spitting" noise replaces the Shutdown sound and then the system traps with either:-

Exception in module: Uniaud32
Trap 000E ... CPU=01
CS:EIP=0168:ee4536c8
The system detected an internal processing error at location ##0168:fff0f667 - 000f:e667
60000, 9084

or

TRAP 000d ... CPU=01
CS:EIP=0100:000004f4
The system detected an internal processing error at location ##0168:fff0f667 - 000f:e667
60000, 9084

Using 114RC4
uniaud16.sys 61,758 20/11/2007
uniaud32.sys 557,949 20/11/2007

Drivers load and work fine except at Shutdown: a "splutter" or "spitting" noise replaces the Shutdown sound and then the system traps with either:-

Exception in module: Uniaud32
Trap 000E ... CPU=01
CS:EIP=0168:ee4536c8
The system detected an internal processing error at location ##0168:fff0f667 - 000f:e667
60000, 9084

or

TRAP 000d ... CPU=01
CS:EIP=0100:000004f4
The system detected an internal processing error at location ##0168:fff0f667 - 000f:e667
60000, 9084

Using 114RC5
uniaud16.sys 72,926 18/2/2008
uniaud32.sys 557,717 18/2/2008

Drivers load and work fine except at Shutdown: a "splutter" or "spitting" noise replaces the Shutdown sound and then the system traps with either:-

Exception in module: Uniaud32
Trap 000E ... CPU=01
CS:EIP=0168:ee4536c8
The system detected an internal processing error at location ##0168:fff0f667 - 000f:e667
60000, 9084

or

TRAP 000d ... CPU=01
CS:EIP=0100:000004f4
The system detected an internal processing error at location ##0168:fff0f667 - 000f:e667
60000, 9084

System1 now reverted to RC1 as it is the most current Uniaud without the above Traps.

Why did I suggest acpi may be involved? Well:-

System2: MSI 7123 with nForce4 chipset, single core cpu, no acpi

No version of Uniaud to date has been capable of producing sound with the onboard nVidia CK804/CMI9780 audio - drivers load but no sounds play. I tried playing with unimix but it looks like it does not turn on/off some settings. This is a 2nd user mainboard so I guess there could be some problem with the CK804/CMI9780 hardware that I am not aware of.

Soundcard installed:
SB Audigy1 Rev3 PCI ID Vendor 0x1102 Device 0x0004 - as in System1

This system has successfully used RC1, I'm also sure that I had RC4 installed prior to current drivers:-

uniaud16.sys 61,758 20/11/2007 - unisnddr (current version on hobbes)
uniaud32.sys 558,144 27/1/2008 - unisnddr

Drivers load and work fine, no problems at Shutdown - hence 1st choice for use on System1 when installing the SB0090 but when used on System1 these drivers cause the same Traps as RC2 - RC5.

As you can see from the above PCI IDs they are identical SB0090 soundcards

The unisnddr drivers work fine with the SB0090 soundcard on the nForce4 (no acpi) based system but not on the MCP61 (acpi v2.22) based system as these drivers cause the same Traps as RC2 - RC5 on System1.

If I get the chance over the next week or 2 I will test RC2 - RC5 with System2 for comparison with the System1 results.

Hope the above is of use

Pete

Change History (2)

comment:1 Changed 6 years ago by gentux2

  • Component changed from Building to UNIAUD32
  • Version set to 1.1.4RC5

Thanks Pete. I understand these results much better now, the way you describe them here.
It is not necessary for you to take the time to test again with 1.1.4RC2-4. This is enough information for me to try to reproduce this, if indeed I have this hardware in my stash.
It is possible the ACPI stuff I will be committing very soon could fix this. I can email you a test build if you want.
If that doesn't help, as long as I can reproduce it I'll try to isolate why the trap occurs after RC1.

comment:2 Changed 6 years ago by gentux2

  • Resolution set to fixed
  • Status changed from new to closed

Reported fixed in 1.1.4RC6.

Note: See TracTickets for help on using tickets.