Opened 12 years ago

Closed 12 years ago

#105 closed defect (fixed)

NVidia AC'97 (10DE:0059) is silent in 1.1.4RC5, was fine in RC4

Reported by: guest Owned by: yoda
Priority: normal Milestone: Stabilization
Component: UNIAUD16 Version: 1.1.4RC5
Severity: normal Keywords: NVidia AC97 ALC850
Cc:

Description

Hi

Just download V1.1.4-RC5, unzipped required files over existing files and rebooted.

No problems with the reboot, the nVidia CK804 and Realtek ALC850 mixer are reported when the driver loads:- NVidia CK804 at 0xd2003000, irq4 Detected Mixer : Realtek ALC850

However when the system has booted it does not have sound at all.

I tried rebooting 3 times with the same lack of sound result and then reverted to the v114-rc4+ version previously in use that works fine.

Attachments (3)

hardware.txt (23.7 KB) - added by guest 12 years ago.
mixer.txt (10.2 KB) - added by guest 12 years ago.
uniaud.log (5.1 KB) - added by guest 12 years ago.

Download all attachments as: .zip

Change History (11)

Changed 12 years ago by guest

Changed 12 years ago by guest

Changed 12 years ago by guest

comment:1 Changed 12 years ago by guest

I reinstalled v114-rc5 in order to generate the files now attached to this report.

While I had 114-rc5 installed and had just generated the required files I tried to use Seamonkey to attach those files.

No Go!!!

Seamonkey started but crashed immediately.

I tried starting Seamonkey with several different Profiles; same result: Seamonkey crashes on startup!!!

Why am I telling you?

Simply because the Seamonkey startup crash * only occurs * with uniaud114-rc5 installed.

This is very repeatable:-

Replace 114-rc4 files with those supplied with 114-rc5 and reboot; Seamonkey cannot run.

Change back to 114-rc4 files, reboot, no problems with Seamonkey.

I have tried the above 3 times always with the same result: If 114-rc5 files are installed Seamonkey does not run, just crashes on startup.

This suggests a very serious problem with uniaud114-rc5; wonder if it causes any other apps problems?

Hope the attached files help :-)

Pete - losepete@…

comment:2 Changed 12 years ago by gentux2

  • Component changed from Building to UNIAUD32
  • Keywords rc5 NVidia AC97 added; 114-rc5 removed
  • Milestone set to 1.1.4GA
  • Priority changed from highest to normal
  • Severity changed from critical to normal
  • Summary changed from 114-rc5 fails to produce any noise to NVidia AC'97 (10DE:0059) is silent in 1.1.4RC5, was fine in RC4

Can you please test using uniaud16 rc5 and uniaud32 rc4 and vice versa to confirm whether the problem is in uniaud16 or uniaud32?

I'm not terribly concerned about the SeaMonkey problem. It should not do that, but if a plugin or something is talking to a buggy uniaud16 implementation while the hardware driver (uni32) is malfunctioning, strange things might happen. If we fix the sound, that should sort itself out, if indeed Uniaud is the cause.

comment:3 Changed 12 years ago by guest

Hi

I have performed the suggested tests with the following results:-

uniaud16.sys(RC5) + uniaud32.sys(RC4) - 2 clicks heard when booting which is "normal" for uniaud versions that work but sound does not work once the system has loaded; I did not bother testing whether Seamonkey would start.

uniaud16.sys(RC4) + uniaud32.sys(RC5) - No clicks noticed when booting but sound works once the system has loaded. I have been up and running for a couple of hours without problems with this combination of drivers.

That seems to suggest the problem is with uniaud16.sys from the RC5 package.

The Seamonkey/RC5 problem is very repeatable but as you say fixing the sound should sort it out.

Of possible interest/feedback: I have also tried the uniaud16.sys and uniaud32.sys files found in the unisnddr package currently on hobbes and had no problems with those files on this system.

Regards

Pete losepete@…

comment:4 Changed 12 years ago by yoda

  • Version changed from 1.1.4 to 1.1.4RC5

comment:5 Changed 12 years ago by yoda

  • Component changed from UNIAUD32 to UNIAUD16
  • Keywords ALC850 added; rc5 removed
  • Owner set to yoda
  • Status changed from new to assigned

Could you download the debug versions, and give me logs from that, and please use the UniInfo? package to grab all the logs we need !

comment:6 follow-up: Changed 12 years ago by yoda

Try this: ftp://ftp.ecomstation.dk/uni16rc5a.zip

Logs needed as before

comment:7 in reply to: ↑ 6 Changed 12 years ago by guest

Replying to yoda:

Try this: ftp://ftp.ecomstation.dk/uni16rc5a.zip

Logs needed as before

Hi

Sorry to report that 114RC6 arrived before I got the chance to test uni16RC5a

Pleased to report that 114RC6 seems to be working fine on this hardware :-)

Regards

Pete

comment:8 Changed 12 years ago by psmedley

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.