Opened 8 years ago

Closed 6 years ago

#39 closed defect (worksforme)

yum update fails

Reported by: Leo123 Owned by: ydario
Priority: Feedback Pending Milestone:
Component: yum Version:
Severity: Keywords:
Cc:

Description

yum update results in:

netlabs-rel 100% |=========================| 1.3 kB 00:00
netlabs-rel/primary 100% |=========================| 384 kB 00:00
netlabs-rel: ############################################### 1445/1645S
etting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package libodin.i386 0:0.8.3-1 set to be updated
--> Processing Dependency: /@unixroot/usr/bin/sh for package: libodin-0.8.3-1.i386
--> Processing Dependency: stdcpp.dll for package: libodin-0.8.3-1.i386
--> Processing Dependency: /@unixroot/usr/bin/sh for package: libodin-0.8.3-1.i386
--> Processing Dependency: /@unixroot/usr/bin/sh for package: libodin-0.8.3-1.i386
--> Processing Dependency: /@unixroot/usr/bin/sh for package: libodin-0.8.3-1.i386
--> Finished Dependency Resolution
Error: Package: libodin-0.8.3-1.i386 (netlabs-rel)

Requires: /@unixroot/usr/bin/sh

Error: Package: libodin-0.8.3-1.i386 (netlabs-rel)

Requires: stdcpp.dll

You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

neither suggestion result in success

sh.exe is in path
stdcpp.dll is in libpath

Change History (4)

comment:1 Changed 8 years ago by dmik

It seems that despite the fact they are in PATH/LIBPATH (you must have installed them by hand), they are not in the RPM database. The problem is that some of the required files are in an experimental repository while the odin package you are installing is in the release repository. As a temporary solution, attach the experimental repo using this command:

yum install netlabs-exp

Or, if you don't want to participate in testing experimental builds, please wait until we fix this mis-synchronization issue (hopefully, today). Thanks for reporting!

comment:2 Changed 8 years ago by ydario

The release repository is now synched with latest packages.

Please try again.

comment:3 Changed 8 years ago by diver

  • Priority changed from major to Feedback Pending

@Leo123 could you retest with latest sync already?

comment:4 Changed 6 years ago by diver

  • Resolution set to worksforme
  • Status changed from new to closed

as sync works now since long i consider that as done.

Note: See TracTickets for help on using tickets.