Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#345 closed defect (invalid)

ANPM gives missing prerequisite message

Reported by: Shmuel (Seymour J.) Metz Owned by:
Priority: Feedback Pending Milestone:
Component: other Version:
Severity: low Keywords:
Cc:

Description

ANPM give an error message, presumably from yum:

An error occurred when trying to download or install packagws.

Error with transaction check vs depsolve:ghostsctipt = 9.10-4.oc00 is needed by
ghostscript-cups-9.10-4.oc00.i386Please report this error at
http://trac.netlabs.org/rpm/

This occurs whether the install DVD file:///drives/arcainst/CID/SERVER/RPM/LOCALREP is disabled or enabled. the other repositories are https://repos.arcanoae.com/release/$releasever/ and http://rpm.netlabs.org/release/$releasever/$basearch/

https://www.2rosenthals.com/rpm.netlabs.org/release/$releasever/$basearch/

Change History (4)

comment:1 Changed 3 months ago by Silvan Scherrer

Priority: minorFeedback Pending

please do the same update with yum only and attach the complete message. Or see where ANPM stores the messages. As with the above only it's not possible to see what you try nor what could cause the issue.

comment:2 Changed 3 months ago by Shmuel (Seymour J.) Metz

Okay, here are the console messages fro, both yum install commands.

Attempt to instal GS-*:

Mon  2-24-20  6:36:56{0}[h:\] yum install  ghostscript-doc ghostscript-cups
arca_inst            |  951 B  00:00
arcanoae-rel         | 1.9 kB  00:00
netlabs-rel          | 2.9 kB  00:00
netlabs-rel/primary_ | 2.1 MB  00:06     =-] 259 kB/s | 2.1 MB  00:00 ETA
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package ghostscript-cups.i386 0:9.10-4.oc00 will be installed
--> Processing Dependency: ghostscript = 9.10-4.oc00 for package: ghostscript-cu
ps-9.10-4.oc00.i386
---> Package ghostscript-doc.noarch 0:9.18-7.oc00 will be installed
--> Processing Dependency: ghostscript = 9.18-7.oc00 for package: ghostscript-do
c-9.18-7.oc00.noarch
--> Running transaction check
---> Package ghostscript.i686 0:9.10-4.oc00 will be installed
---> Package ghostscript.i686 0:9.18-7.oc00 will be obsoleting
---> Package gnu-ghostscript.i686 0:9.14-1.oc00 will be obsoleted
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================

 Package                Arch         Version            Repository         Size
================================================================================

Installing:
 ghostscript            i686         9.18-7.oc00        netlabs-rel       5.2 M
     replacing  gnu-ghostscript.i686 9.14-1.oc00
 ghostscript-cups       i386         9.10-4.oc00        netlabs-rel       1.6 k
 ghostscript-doc        noarch       9.18-7.oc00        netlabs-rel       6.5 M
Installing for dependencies:
 ghostscript            i686         9.10-4.oc00        netlabs-rel       6.7 M

Transaction Summary
================================================================================

Install       4 Packages

Total size: 18 M
Is this ok [y/N]: y
Downloading Packages:
Running Transaction Check
ERROR with transaction check vs depsolve:
ghostscript = 9.10-4.oc00 is needed by ghostscript-cups-9.10-4.oc00.i386
Please report this error in http://trac.netlabs.org/rpm/
 You could try running: rpm -Va --nofiles --nodigest
Your transaction was saved, rerun it with: yum load-transaction Q:/var/temp/yum_
save_tx-2020-02-24-06-39b4oig2.yumtx

Attempt to install odin-win32k:

Mon  2-24-20  6:43:03{0}[h:\] yum install odin-win32k
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package odin-win32k.i386 0:0.7.1-3 will be installed
--> Processing Dependency: libodin = 0.7.1-3 for package: odin-win32k-0.7.1-3.i3
86
--> Finished Dependency Resolution
Error: Package: odin-win32k-0.7.1-3.i386 (netlabs-rel)
           Requires: libodin = 0.7.1-3
           Installed: libodin-0.9.0-1.i686 (installed)
               libodin = 0.9.0-1
           Available: libodin-0.8.9-1.i386 (netlabs-rel)
               libodin = 0.8.9-1
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

comment:3 Changed 3 months ago by Silvan Scherrer

Resolution: invalid
Status: newclosed

as you can see there is no ghostscript-cups anymore after version 9.10. So just don't install that package, as it depreciate since about v9.10 or 9.11.
As info the ghostscript-cups parts are all integrated in cups-filters.

I'm closing this as not an issue.


comment:4 Changed 3 months ago by Shmuel (Seymour J.) Metz

Please remove odin-win32k and any other uninstallable packages from the stable repository. See discussion in https://mantis.arcanoae.com/view.php?id=2762

Note: See TracTickets for help on using tickets.